Sign in with
Sign up | Sign in
Your question

ATI Radeon HD 4850 - 3D Rendering Issue?

Last response: in Graphics & Displays
Share
April 18, 2009 6:00:28 PM

Recently bought a Gateway FX6800-01e. Came with a ATI Radeon HD 4850 w/1 GB.

Every time I loaded, it gave my a driver does not work with Catalyst center error, which I ignored.

Bought Empire Total War. Installed and played fine for a few weeks. Now when I play, the game starts fine, menus load, and it let's me start a game completely. Graphics, startup movie, etc. all looks great.

However, when I get into the game itself, all of the 2D menu popups I can read fine, but the map interface or battle inteface are basically haywire with various color shapes flickering around the screen making the game completely unplayable.

Went and uninstalled/reinstalled ATI drivers and came across an error with the C++ portion of the install, which comes up with a Application Install: out of disk space error.

Same issue occurs. Questions are:

1) Rendering issue possibly connected to C++ issue?
2) If so, how can I fix?
3) If not, where can I get support/other ideas?
April 28, 2009 12:58:43 AM

I also bought a Gateway FX6800-01e that came with a ATI Radeon HD 4850. I was having trouble running Riddick, Escape from Butcher Bay because it was freezing while loading levels.

I updated Catalyst Control Center and the latest drivers and got an "Out of disk space" error during a portion of the install which according to the log was for Microsoft Visual C++ 2005 SP1 Redistributable which failed to install. I tried installing a second time and received the same error.

This is difficult to understand because I have 527 GB free on my hard drive.

Now when I try to play Riddick, it freezes within 15 seconds of playing.

Anyone have any ideas?
May 23, 2009 6:11:53 PM

Dismount all virtual drives like cd drives used to mount iso's
!