Closed

VIA S3 unichrome Pro IGP Vista x64/7 x64

Hello, I drove crazy looking for this driver, but I still can't find it, hope you help me. It's an integrated video card, my motherboard is Asus P5VD2-MX and I need vista x64 or 7 x64 video drivers
16 answers Last reply
More about unichrome vista
  1. You are unlikely to find one .

    I had a board with the same onboard gfx . When the gfx card died I went back to onboard. There had been no updated drivers in the 3 previous years even for XP 32 bit .

    You could try installing the XP driver . Its rubbish though . Colors are muted and off tones , and the drivers didnt support widescreen resolutions even .

    I'd buy a very cheap gfx card .
  2. so no way? About the resolution, I flashed my motherboard to get 1440x900. Everything was fine with xp x64, but I need this drivers for windows 7 x64. As you say there are not drivers even for vista x86... Isn't there a way of "modding" the xp drivers to get it working with vista 64/seven 64?
  3. ^There probably is a way, but tbh get a cheap 8400GS/3450 card.
  4. Go to VIA's website and see if you find anything. If someone got fustrated enough they may have slapped together a driver, like good ol Daniel K for the creative cards, but if it's not a whql certified driver it's a pain to get Vista x64 to load it. Really though it's probably easier to buy a cheap card from CompUSA or something ^_^.
  5. Thanks to all of you for your suggestions. I'm gonna check VIA's website. I would really like to buy even a cheap card, but I'm still suffering the Argentinian Economic Collapse... Wish I were able to buy in USA ;)
  6. braian-k said:
    Thanks to all of you for your suggestions. I'm gonna check VIA's website. I would really like to buy even a cheap card, but I'm still suffering the Argentinian Economic Collapse... Wish I were able to buy in USA ;)


    Hey Man... I had an old PC that I use for testing and yesterday I installed Windows 7 on my old CeleronD 2.26 Ghz which has a Biostar mainborad (P4VMA-M) with an integrated VIA/S3G Unichrome IGP. As you may know, Windows 7 and Windows Vista are almost the same stuff, so I went looking for Vista drivers (which I could not find) and found myself in the same situation that you are now. Since the PC is for testing, I say what the hell and downloaded the XP drivers from biostar website; then I uncompressed them to a folder and pointed windows 7 to look in there. For my surprise, Windows XP driver worked fine on Win7 32 bit edition.

    I don´t know what will happen with 64bits, but at least, if you have al your information backed out, then you could try this and see if it solves your problem.

    Hope this helps!

    Greetings from Uruguay...
    Fede.

    PS.- Suerte!
  7. Brilliant, works treat on my Packard Bell Easynote on Windows 7. Thank you
  8. Great piece of detective work!!! It also works on all Shuttle G models with the UniChrome Pro IGP with W7 Ultimate 32b.

    Doesn't seem to be able to do the satisfaction test, but I don't need Windows to tell me how satisfied I am with their products. Really, they don't want to know for the most part.

    Guaymas Jim
  9. Hi there!
    Here it is! I went crazy looking for this driver and after looking to hundreds of posts, I modified a solution for something similar and voilá! It worked!!

    1. Download
    http://www.viaarena.com/Driver/P4M890_16950603_XPx64_wIShld_logod.zip
    2. Unzip
    3. Edit uc07i.inf
    4. Add the line FeatureScore = FC to the section [viagfx_3327]
    5. Install the driver from Device Manager
    6. Because of the changed file, the signature is not valid anymore. Simply ignore.
    7. Reboot
  10. edangulo said:
    Hi there!
    Here it is! I went crazy looking for this driver and after looking to hundreds of posts, I modified a solution for something similar and voilá! It worked!!

    1. Download
    http://www.viaarena.com/Driver/P4M890_16950603_XPx64_wIShld_logod.zip
    2. Unzip
    3. Edit uc07i.inf
    4. Add the line FeatureScore = FC to the section [viagfx_3327]
    5. Install the driver from Device Manager
    6. Because of the changed file, the signature is not valid anymore. Simply ignore.
    7. Reboot


    Hi everyone. I have the same problem trying to get the driver for an IGP Via S3 UniChrome for my MoBo Biostar P4M800-M7A Ver.7.0 whit windows 7 x64, tried this solution but doesnt work, it says that there's an error at the time of installation; can you specify where exactly to add the line that you say "FeatureScore.... =... " in the .inf file... or anyone there that know a solution for this, please help, thanks in advance...
  11. Quote:
    Hi everyone. I have the same problem trying to get the driver for an IGP Via S3 UniChrome for my MoBo Biostar P4M800-M7A Ver.7.0 whit windows 7 x64, tried this solution but doesnt work, it says that there's an error at the time of installation; can you specify where exactly to add the line that you say "FeatureScore.... =... " in the .inf file... or anyone there that know a solution for this, please help, thanks in advance...

    I don´t have that mobo anymore, but what I recall it should be like this:

    [viagfx_3327]
    FeatureScore = FC
    AddReg = viagfx.AddReg, DefaultU.AddReg, TraypNT.AddReg
    DelReg = viagfx.AddReg
    CopyFiles = viagfx.Miniport, viagfx.Display, viagfx.ICD32, viagfx.ICD64, DefaultUHlp.Copy, DefaultUSys.Copy, VTTimer.Copy, TraypSys.Copy, TraypHlp.Copy

    Hope it helps!!
  12. Thanks, works exellent.
  13. Fede_UY said:
    braian-k said:
    Thanks to all of you for your suggestions. I'm gonna check VIA's website. I would really like to buy even a cheap card, but I'm still suffering the Argentinian Economic Collapse... Wish I were able to buy in USA ;)


    Hey Man... I had an old PC that I use for testing and yesterday I installed Windows 7 on my old CeleronD 2.26 Ghz which has a Biostar mainborad (P4VMA-M) with an integrated VIA/S3G Unichrome IGP. As you may know, Windows 7 and Windows Vista are almost the same stuff, so I went looking for Vista drivers (which I could not find) and found myself in the same situation that you are now. Since the PC is for testing, I say what the hell and downloaded the XP drivers from biostar website; then I uncompressed them to a folder and pointed windows 7 to look in there. For my surprise, Windows XP driver worked fine on Win7 32 bit edition.

    I don´t know what will happen with 64bits, but at least, if you have al your information backed out, then you could try this and see if it solves your problem.

    Hope this helps!

    Greetings from Uruguay...
    Fede.

    PS.- Suerte!

  14. Thanks Fede_UY this worked a treat! With my AmiloPro V2030
  15. Thanks! Works fine with mobo ASUS P5VD2-MX
  16. Hey guys, just to confirm that this solution really does work. I've had an ASUS P5VDC-MX mobo running Windows XP for years and decided to upgrade it to Windows 7 last week. After install, resolution stuck to 640*480. Have used the WinXP 64-bit version of Unichrome pro driver.
    Edited uc07i.inf file and added line
    FeatureScore = FC
    to the section [viagfx_33xx]

    Installed driver and rebooted. Now works perfect. Saved me from buying an AGP card for this mobo!!
    Much thanks to all!
Ask a new question

Read More

Graphics Cards X64 Windows Vista Graphics