Laptop won't go past the BIOS screen - No error message at all

Sony VAIO VGN C-140-QG/B
Phoenix BIOS
Mobile Intel 945GMS Express Chipset

I just rebooted my laptop because I thought it was lagging abnormally (I just formated it).
But it didn't reboot. Actually, it didn't even successfully shut down in the first place. I had to force shut it down. When I booted it after that, it didn't get past the BIOS screen. I am unable to access the BIOS setup when pressing F2, it hangs after diplaying "Setup..."

There is no error message nor any "beep" code.


Is my laptop gone? : (
5 answers Last reply
More about laptop past bios screen error message
  1. Your hdd may be dead, or not fully dead but damaged to the point where system can see it but its unaccessible, which possibly causes the "hanging". Had a situation like that few times building PCs and hdd was always the culprit. I dont know why it affects POST though. If you know how and feel confident enough than open your laptop, unplug the hdd and try booting(if you dont than get somebody to do it for you). If it posts than you know what the problem is.
  2. Nope I had already removed my hard drive and tried to boot Puppy Linux on an USB flash drive but the problem was still there.

    I guess it's dead hun? : /
  3. Hmm, sorry but I dont have any other idea really, I just posted because it sounded similar to what Ive seen on desktp PCs, I dont deal with laptops myself.
  4. I've found the problem!

    It was an ExpressCard SD Card reader that came with the laptop that was effing everything up. I noticed it was in the slot when I was removing the screws to open the laptop. I tried to boot without it and it worked =D

    Of course now the thing is in the bin. It didn't even work anyway.
  5. Hahah, nice one ;] Good to hear it works
Ask a new question

Read More

Motherboards Laptops BIOS Error Message