Sign in with
Sign up | Sign in
Your question
Closed

Net, bcdedit commands won't work

Last response: in Windows 7
Share
September 19, 2011 10:35:40 PM

Hi,

When I open the cmd prompt and just type "net" or "bcdedit", I get those errors

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Nicolas>net
'net' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\Nicolas>bcdedit
'bcdedit' is not recognized as an internal or external command,
operable program or batch file.

Does anybody have a solution please?
Thank you !

September 19, 2011 10:50:09 PM

synor said:
Hi,

When I open the cmd prompt and just type "net" or "bcdedit", I get those errors

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Nicolas>net
'net' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\Nicolas>bcdedit
'bcdedit' is not recognized as an internal or external command,
operable program or batch file.

Does anybody have a solution please?
Thank you !


What do you get for the Path+ if you type "set" at the cmd prompt without the quote characters.
Score
0
September 19, 2011 10:55:05 PM

Path=C:\dev\tools\php-5.3.1;C:\dev\tools\MySQL Server 5.5\bin
PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC

Oh... this is because I installed Apache on my computer to study how a server works..?
Score
0
Related resources

Best solution

a c 209 $ Windows 7
September 19, 2011 11:01:48 PM

Your PATH variable needs to include the C:\Windows\System32 and C:\Windows folders, that's probably why it's not finding those commands.

I have no idea why it got screwed up, but you can fix it by:

- Click Start, right-click "Computer", and select "Properties"

- Click the "Advanced System Settings" in the left pane

- Click the "Advanced" tab

- Click the "Environment Variables..." button near the bottom of the dialogue box

- Change the value of the PATH variable in the upper box if it exists there, or in the lower box if it doesn't. Be sure to separate each folder name with a ";" (semicolon) character.

Share
September 19, 2011 11:05:19 PM

Now it works !

Thank you Sminlal and Jim !
Score
0
September 19, 2011 11:05:33 PM

Best answer selected by synor.
Score
0
a c 416 $ Windows 7
September 19, 2011 11:14:27 PM

This topic has been closed by Area51reopened
Score
0
!