Sign in with
Sign up | Sign in
Your question
Solved

Memtest86+ Problem

Last response: in Memory
Share
September 20, 2009 10:29:18 PM

I have an issue with Memtest86+ (using bootable ISO CD)

I can run Memtest86+ fine, but Memtest won’t recognize any keyboard keys I press. This is a problem since when I want to exit out of Memtest86+, I can’t. Ordinarily you would press Esc to exit it, but it won’t respond to my keyboard at all (for any of the key commands). Therefore, I have to press the power button on my tower to force shut my PC off. My questions are:

1. Since I force shut off the PC in this way while the memory is being intensely tested, could I damage the memory? (I need to know for future tests – I am RMAing some G.skill RAM right now and want to use Memtest86+ to test my new RAM without damaging it)
2. Does anyone know any suggestions on how to make it respond to my keyboard?

Regarding question #2, here’s some info:
My PC DOES recognize my keyboard commands upon normal booting. For example, I can press Del to enter my BIOS, etc. I can edit my BIOS fine. However, interestingly enough, whenever my PC has an emergency restart (due to power failure or me pressing the emergency restart button when my PC locks up), my PC will load the screen where it says your PC was not shut down properly, etc. and it will NOT respond to my keyboard at all. This is highly annoying since there is a 20 second countdown for windows to boot into normal mode at this screen, and ordinarily you can hit enter to skip it, but it won’t recognize any keyboard commands.
Also, for both Memtest86+ and this emergency restart screen, I have tried a different USB keyboard with no success – it still won’t respond to my keyboard commands.

Thanks ahead of time for any ideas/help.

More about : memtest86 problem

a c 80 } Memory
September 21, 2009 12:25:16 AM

Quote:
Since I force shut off the PC in this way while the memory is being intensely tested, could I damage the memory?
Absolutely not.

If possible, have you tried a PS2 keyboard?
m
0
l

Best solution

a b } Memory
September 21, 2009 12:27:00 AM

You have a USB keyboard.

Turn on "Legacy Support for USB Devices" in BIOS.

Then USBs will be recognized in DOS, which is where you are having trouble.
Share
Related resources
a b } Memory
September 21, 2009 7:53:18 AM

Many folks keep a PS/2 keyboard around to solve problems like yours - as suggested above. I'm not sure that even the Legacy support will fix the problem you mention when you have an abnormal boot.

I haven't ever had this issue, since I actually use a keyboard with an AT connector which I convert to PS/2. This particular one dates I think to 1988 - 101-key before they started putting the "Windows" keys on them. Works great as long as you know the keyboard commands in Windows if your mouse dies.
m
0
l
September 21, 2009 3:54:39 PM

There is also connector from USB to PS/2. Costs about $1.00.
Makes the keyboard function as a PS/2 one.
m
0
l
September 21, 2009 9:37:06 PM

Thank you all very much for your advice. I was able to find the correct BIOS setting that enables keyboards to work in DOS mode. I'll find out if it works after my next bad restart (I'm not going to do that on purpose to test since it can cause file corruption).
It is good to know that force shutting out of Memtest86+ won't hurt your RAM.
If my BIOS setting doesn't fix it, I might snatch me a USB to PS/2 adapter.
m
0
l
September 28, 2009 12:28:34 AM

Enabling "USB Keyboard Support" in BIOS which my manual says "Allows USB Keyboard to be used in MS-DOS" fixed my problem! I can now exit out of Memtest86+ fine. Thank you. A simple solution indeed!
m
0
l
!