Sign in with
Sign up | Sign in
Your question

Write protected memory stick - 8GB

  • Download
  • Memory
  • Windows XP
Last response: in Windows XP
September 6, 2011 12:03:21 PM

Hello, able to download a small file with no problem however when I tried a larger file only a small amount was loaded and when i wanted to delete the info I was told it was write protected

More about : write protected memory stick 8gb

a c 146 } Memory
September 6, 2011 12:46:22 PM

Did you try to format the stick?
September 6, 2011 3:20:00 PM

If your USB flash drive is write protected, possible solutions are as follows:

1. check that your flash drive doesn't have any mechanical switches on the outside of its casing, the switch can be fairly small, a little plastic knob, which can be easily overlooked.

2. Go to Start > Run > type in: regedit > hit enter. On the dialog box that opens up navigate to the following path:

Find the entry named "WriteProtect" if the value is set to 0x00000001 (1), double click it and set the value to zero.

Reboot your computer and try your flash drive.

Note: if you don't have the StorageDevicePolicies folder, it might do good to create it and then create a DWORD key inside called WriteProtect and set it to zero.

3. You might have a malware/virus causing this problem. Do a thorough full system scan with a few programs that you have, if you don't have any security programs some of these might be useful:
Free anti-virus:
-Microsoft Security Essentials

Free anti-spyware/anti-malware:
-malware bytes
-spybot search & destroy
-super anti-spyware

4. If the issue wasn't caused by a virus you might have to reformat your flash drive. The procedure is as follows:
Warning. Make sure you back up all important data from your flash drive. Formatting will cause all data to be erased

Download HP Format Utility to a folder on your desktop. With your flash drive plugged in, start the utility and select your flash drive to format. Once the reformat is done, you should be able to use your flash drive.

5. If you're still having issues try the following
Start > Run > cmd /k chkdsk :? /f > Hit OK
Replace the ? with the drive letter of your flash drive

6. If it's still not working, try formatting using this tool:" target="_blank">Apacer Formatting Tool[/url
Unzip it to a folder on your desktop, make sure you only have the faulty flash drive plugged in, go into the folder and double click the start.bat. Make sure your flash drive stops blinking completely, after that, pull it out and plug it back in.
Try step 5 after this formatting tool as well.

If none of the above help you there could be two possibilities. The flash drive you're trying to write to was issued to be read-only type of media OR the flash drive is defective (you should return it for replacement to vendor/manufacturer).