Sign in with
Sign up | Sign in
Your question
Closed

Cannot right click on desktop after virus

Last response: in Windows XP
Share
September 6, 2011 7:56:15 PM

GOT A VIRUS THAT HIDE ALL MY FOLDERS. ALL WERE FOUND AND RESTORED BUT DESKTOP. NO ICONS TO BE FOUND.

i ALSO CANNOT RIGHT CLICK TO CHANGE BACKGROUNDS.

IT DEPT CAN'T SEEM TO FIGURE THIS OUT.

More about : click desktop virus

September 6, 2011 8:34:17 PM

I would recommend checking to see if it redirected your profile. On a normal setup, your desktop folder should be located under C:\Documents and Settings\%username%\Desktop (XP) or C:\Users\%username%\Desktop (Win7). If your company has your profile redirected to a home drive, check with IT and see where it is supposed to be. Navigate to that folder and see if the Desktop folder has any icons. If not, then it looks like the icons are gone. If they are, it means that the virus has messed with the profile redirection and it probably needs to be fixed in the registry.
Score
0
September 19, 2011 10:48:30 PM

Run through the malware guide in my signature to verify that all the malware is gone.

To restore the desktop, press ctrl+alt+delete to open the task manager. Then go to file-->new task-->explorer.exe
Score
0
Related resources
March 18, 2012 12:44:27 PM

Anela55 said:
GOT A VIRUS THAT HIDE ALL MY FOLDERS. ALL WERE FOUND AND RESTORED BUT DESKTOP. NO ICONS TO BE FOUND.

i ALSO CANNOT RIGHT CLICK TO CHANGE BACKGROUNDS.

IT DEPT CAN'T SEEM TO FIGURE THIS OUT.


I also had a virus on a windows xp home edition laptop that did the same thing. It was a so-called rootkit. I was able to remove most of it with Kaspersky's tdsskiller. I then used malwarebytes and microsoft security essentials safety scanner to clean up the rest of it, even though MSE was the antivirus that let it in.

I found the virus hid the %username% documents and settings folder, the all users documents and settings folder, and the c:\programs files folders. I think C:\documents and settings\%Username%\Start Menu\Programs and C:\documents and settings\%Username%\Desktop Might have been hidden too. So what I did was right click those folders, selected properties, unchecked the hidden attributes, and hit the OK button. Now I was able to see the programs (Under all programs on the start button) but still not any desktop icons.

There are keys in the registry that can hide the desktop and disable right-clicking. In my case, the keys the virus used to do that were HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\ClassicStartMenu And also NewStartPanel just below it. I also found these same keys under HKLM\software. (Just go to HKEY_LOCAL_MACHINE instead of HKEY_CURRENT_USER).
The values were set to 1; you need to set them to 0. When the computer was rebooted all was Ok.

To do so, click the start button, click run, and type in regedit and press enter. In the registry, click the indicated keys in the left pane and right click in the right pane. Click modify, and type in a 0. Just be careful. If you mess up the registry you've messed up your whole computer. It's a good idea to back up the registry by doing a restore point, or you can click FILE > Export in the registry menu.

I must have googled the entire internet for solutions before stumbling on those keys by accident. The keys everyone said were the culprit were under HKCU and HKLM \software\microsoft\windows\currentversion\policies.

Another useful thing I found on the net was a registry script to re-enable the task manager-- control-alt-delete. It worked. Here it is:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"DisableTaskMgr"=dword:00000000 . So you can go right to that key and change the disableTaskMgr value to 0, or download the script, or recreate it in notepad (Give it a .reg extension). It's called EnableTM.Reg; sorry can't remember the site.
Score
0
March 18, 2012 12:56:05 PM

This topic has been closed by Area51reopened
Score
0
!