Sign in with
Sign up | Sign in
Your question

2 x 4830 crossfire, no improvement in performance

Last response: in Graphics & Displays
Share
April 28, 2009 3:15:55 PM

I added a second 4830 to my setup and when I run the ATI Tray Tools benchmark there is no improvement at all. Catalyst shows Crossfire is enabled and so does GPU-Z. I'm using only one XF bridge but from what I read one should be enough. What could be wrong? Where do I start? Thank you so much in advance!

Motherboard ASRock A780GXE/128M
CPU AMD Athlon 7750 X2
Powercolor AX4830 512M X 2
Vista 32bit Ultimate
Catalyst 9.4
April 28, 2009 3:21:27 PM

Go in the CCC under Crossfire options and select to show icon when crossfire enabled, then start a game and see if the ATI Crossfire icon shows up.

Also have you tryed to play any games using crossfire? Try COD4 or Left4Dead. Download first Fraps and run it so you can see Frames difference with crossfire disabled and crossfire enabled.

Cheers
April 28, 2009 4:29:53 PM

@ nihilante: You start from the beginning and work along;)
That MB has an odd way of enabling Crossfire, check through the manual and make sure you have followed each step correctly also, Crossfire will not function if a game is played in windowed mode.
Related resources
April 29, 2009 6:21:42 PM

To Euphoria_MK:
I don't see that setting in CCC. I have ver 9.4

I noticed in the motherboard manual they say you must use 2 crossfire bridges, is this correct?
I thought the second connector was for when you have 3 cards?
April 29, 2009 6:34:02 PM

YOu know what I use two bridges because both of my cards came with a bridge, but I've read various posts and articles that state you need only one bridge.
Try placing the bridge on the first set of pins.

Hmm, there should be an option under CrossfireX settings: "Show CrossfireX logo (where applicable)"

I am also running Cat 9.4, but I previously had Cat 9.3 installed..
I am at work now but I'll double check my settings when I get back home.

Cheers
April 29, 2009 6:38:00 PM

Thanks for your very fast reply!
That's the reason I didn't get two connectors, because I read the second is not needed.
I am also at work hehe :) 
Do you also have 2 x 4830?
April 29, 2009 7:10:45 PM

Naah, I have two 4870s.. I know I am being quite productive here :p 
April 29, 2009 10:22:25 PM

OK, so to show icon when using Crossfire you have to go over the ATI CCC Icon in the system tray, right click on it and then under Crossfire settings you can select to show Icon when Crossover enabled.

Try it out

Cheers
April 30, 2009 12:12:04 AM

Euphoria_MK said:
OK, so to show icon when using Crossfire you have to go over the ATI CCC Icon in the system tray, right click on it and then under Crossfire settings you can select to show Icon when Crossover enabled.

Try it out

Cheers

Got it! Thanks so much, I'll do so more testing and post back.
April 30, 2009 12:13:50 AM

Quote:
You don't have enough horsepower to make Xfire beneficial.

Umm, excuse me??
Oh I get it, you're only posting to see your signature. Please stay out of this thread and go back to admiring yourself in the mirror.
Thank you.
April 30, 2009 12:45:16 AM

Euphoria_MK said:
OK, so to show icon when using Crossfire you have to go over the ATI CCC Icon in the system tray, right click on it and then under Crossfire settings you can select to show Icon when Crossover enabled.

Try it out

Cheers

OK, so I ran Furmark and the ATI Crossfire did show up. I got 5287 marks at standard speeds.
From what I've read 2 x 4830 should be just as fast as a 4870 so I'm expecting around 6200 marks:
http://www.ozone3d.net/benchmarks/fur/#comptable
May 1, 2009 5:20:05 AM

nihilante said:
OK, so I ran Furmark and the ATI Crossfire did show up. I got 5287 marks at standard speeds.
From what I've read 2 x 4830 should be just as fast as a 4870 so I'm expecting around 6200 marks:
http://www.ozone3d.net/benchmarks/fur/#comptable


Yes but that might involve other factors like PCI-E bus speed on your motherboard, Operating system, CPU, RAM speed, etc, etc...
Try running some gaming benchmarks and run them first with only one card and then with second card in crossfire and see what kind of results you get. Some games and benchmarks respond better in crossfire and some not as good, but there should still be some performance increase.

Cheers
May 1, 2009 9:13:24 PM

and make sure the catalyst AI is set to standard or advanced... (not disabled)
!