Sign in with
Sign up | Sign in
Your question

[Solved] Maxtor Personal storage 3200 suddenly not recognized

Last response: in Windows XP
Share
September 8, 2011 2:30:04 AM

Unit not responsive. Originally accessed through a 4 port hub. More recently as direct plug into usb port, via cold boot.

Now comatose. Light does not go bright. Feels like disc not operating.

Any answers would be appreciated
September 8, 2011 2:01:56 PM

unplug USB cord completely and unplug power if it has a separate block.

let it sit for 1 min, plug in the power (again if you have the cord for it), then plug in the usb cable into your computer.

if nothing happens, verify that the USB port you are trying to use is working (use a mouse or something)

check for USB controller driver update with the manufacturer for your computer

if the USB port appears to be working but HDD refuses to be recognized/turn on you either have a dead power element on the HDD or it's not getting enough power from the USB.

check your power options and set everything to maximum performance
m
0
l
!