Sign in with
Sign up | Sign in
Your question

Radeon 4830, 7750 black 2.7, and major game lag

Last response: in Systems
Share
April 8, 2009 2:24:01 PM

Problem: Experiencing low fps in company of heroes and other games of similar release era, when posted benchmarks of similar systems have shown far better performance. Also, score on 3dmark06 with base settings is 9200. I've overclocked the 4830 "Sapphire" to 650 gpu clock, 950 memory clock without any significant increase in performance. Next the CPU "7750 Black edition 2.7 stock" was OC'd to 3.0 by setting the multiplier to 15x. This also did not seem to increase performance for Company of Heroes nor 3Dmark06. Ive made sure that ram is running in 1066 mode via bios. The following are my system specs

Asrock [AOD790gx/128M] mother board.
KUMA 7750 black edition 2.7 processor
550w PSU
300gig SATA maxtor hdd
Radeon HD 4830 512 mb Pci express 2.0 16x
2x [Kingston HyperX 1GB 240-Pin DDR2 1066] set to ganged in bios
sony dvdrw
80mm fan intake front of case, 120 mm fan blowing out rear, 80mm blowing in side directly on cpu heatsink, 80mm intake for 4830.
Temps as read by several utlities read an average 29c to 40c for 0 and 1 cpu cores. GPU temps never read above 50c.

My major question, what performance this community thinks I should reasonably expect from my setup, using Company of Heroes and other equivalent games as a common refference.

Thanks for your time.
April 8, 2009 4:11:27 PM

I have loaded bios defaults without clearing cmos. I didnt notice any change in performance with default settings. I will try clearing the cmos tonight, and will repost with results, including those from cpuid, and with psu information. Thanks for the quick post.

April 8, 2009 8:13:42 PM

Onboard video is automatically disabled when a pcie, non hybrid compliant, video card is detected. This is according to asrock specifications. There doesnt appear to be any way to ensure that the mGPU is disabled in the bios other than setting primary display to pcie, which i have done. The mGPU does not show up in device manager, so I dont think this is a cause for this problem, but I could be wrong. The heatsink is firmly connected and per amd overdrive temp sensors, neither core rises above 40c. However, I do get rather high temperature readings (46-54c) for the cpu, from asrock's OC utility. This reading does not agree with every other temp monitoring program Ive used, which all report moderate temperatures. Bios is up to date, as are all other drivers. As this was a clean install of windows there were no other VGA drivers present to cause conflict with the 4830. I've tried using an earlier driver version from ati with no success.

I hope that this isn't a case of unrealistic expectations. Benchmarks for this card show company of heroes running all settings high with max resolution and FPS in the 60s to 100s range. Im lucky if I get 30 with settings on low.

Update: So setting bios to default will cause windows to freeze about 2 minutes after windows boots to desktop. I was able to track the cause to a setting in bios, CPU/PCIE overclock, the options are: Async, Sync, Auto, and Optimized. Auto is the default setting and causes the system freeze. I have Optimized selected at this time.
April 9, 2009 5:45:41 PM

Oceanian, I cleared cmos per your recommendation and the issue wherein the comp froze on startup has cleared. However, the lag still persists in game and per HW monitor, voltage fluctuations never pass 5%. Ill contact asrock but would still like to keep this thread open for user input.
April 10, 2009 2:30:11 AM

Sorry about the misusage of a term. I should have correctly described the problem as low FPS. Im not using AA and filtering is off. All other settings in CoH are set to high, which is apparently well within the means of this card. Resolution is 1680 x 1050, native for the monitor. The reviews and benchmarks of the 4830 paired with the 7750 and 2gig 1066 ram, more than satisfied my requirements for a budget gaming rig. Im certainly not looking to run all new games on high.
April 10, 2009 9:43:50 PM

Ok so to Oceanian, thanks for your advice which had the best results. The problem is resolved to my satisfaction. Thread can be closed.
!