Sign in with
Sign up | Sign in
Your question

Motherboard no longer 'sees' sata hdd

Last response: in Storage
Share
November 10, 2010 6:03:13 PM

Hello,
I tried to install my new wd 1tb SATA hdds last night.
I already have a 80g in SATA 1 port. It's the xp sp3 boot drive.
I also have another 2 80g hdds on IDE rails.

I connected the new SATA cable, turned it on, and it loaded from my old IDE hdd which also has an old xp boot drive.
I reset and changed to 80g SATA boot in BIOS.
When I saved and restarted it now doesn't recognise any SATA hdd.

How can it drop out, and how do I fix it??

My board is a p4 800se with 2.4ghz o/c to 3.15 and 1.5gb RAM.
a c 197 V Motherboard
a c 85 G Storage
November 10, 2010 6:38:24 PM

What do you mean? Does the BIOS still recognize the presense of the SATA HDDs?

What HDD is your Boot Disk?
a b V Motherboard
a c 328 G Storage
November 10, 2010 8:05:00 PM

How is the SATA Port Mode set for your SATA ports? XP in all forms does not know how to use "Native SATA", better called AHCI, devices. So to use a SATA unit you need one of two options: either have a AHCI driver loaded into Windows, OR set the SATA Port Mode in BIOS to "IDE (or PATA) Emulation". The latter option is the easiest.
Related resources
November 10, 2010 11:27:06 PM

Col- I have 2 boot drives
The 80g SATA has xp sp3
The other 80g is IDE but only has xp sp1.

The pc is meant to boot using SATA,
but atm SATA is not recognized.
BIOS says SATA is enabled.

I was speaking to another guy at work,
He said I need to have sp3 in order for it to recognize it.
Is that correct?
November 10, 2010 11:42:19 PM

Doc-
Does sp3 contain this ahci program?
I'll have a look at the SATA port mode to see what it says when I get home tonight.

Also to add, I reset all BIOS values to standard and even removed the cmos battery cause I thought is done something really wrong.
a c 197 V Motherboard
a c 85 G Storage
November 11, 2010 12:09:59 AM

Just make sure your SATA mode is set to IDE and you should be fine. BTW, make sure SATA is actually enabled and that the BIOS recognizes the HDD properly. Unless the BIOS recognizes the HDD, Windows will never work.

You do need XP SP3 for SATA to work properly, and you should be using it generally as well. Why do you have 2 separate XP loads on 2 HDDs?
November 11, 2010 1:23:07 AM

Col-
Thanks for the help, will try it tonight.
It's a bit of a long story, basically 268 Trojan horse viruses deleted drivers and programs on that system, I had sp3 and it even took out that. I cleaned all the viruses installed the 80g sata hdd and never got around to deleting the OS- luckily I didn't in this case though.

Thanks again, will report back tonight.
a b V Motherboard
a c 328 G Storage
November 11, 2010 1:57:02 AM

XP is not necessary to use SATA, BUT you do need SP1 or higher of Win XP in order to use hard drives over 137 GB - it's a feature called "48-bit LBA Support" that was added to XP beginning in SP1. However, as I said, no matter which SP you have added into Win XP, it still cannot use SATA drives in their "native" mode as AHCI devices unless you load the driver for them into Windows. That makes it difficult to use SATA HDD's as BOOT drives unless you run a special procedure during initial installation of Win XP on that drive. If you are booting from an IDE drive anyway and always will, you can get Win XP running and then install the AHCI driver for the SATA controller in your machine (mobo). BUT the even easier way is to set your BIOS' SATA Port Mode to IDE (or PATA) Emulation. This has the BIOS itself fool Win XP into believing it is only using an IDE drive it understands fully, and it all works for everything.
November 11, 2010 4:53:22 AM

Make sure your wire is well connected.

Or your master boot sector got damaged which you can fix it with some partition recovery tool like http://www.partitionrecovery.com

Or restore your files from sata hdd with some file recovery tool like http://www.icare-recovery.com

The first one can rebuild your mbr and the later one is useful to restore files when your hdd cannot be detected by your pc.
!