Sign in with
Sign up | Sign in
Your question
Solved

Cloning Win7 boot to SSD

Last response: in Storage
Share
November 11, 2010 9:06:31 PM

I just bought an OCZ Vertex 2 SSD 120 Gb, and I want to avoid reinstalling windows 7 and all my applications. I use the PC to work, and don’t want to lose time.

My plan is to use Clonezilla to do the work.

I never used it, so I don’t know if there is a flaw on my plan, so I ask for wise dudes advice.
_I have 1 TB HD with 4 Partition:
___100 Mb automatically created at Windows 7 installation (I think that have boot data)
___120Gb for Windows 7
___120GB unformatted
___~700Gb with Data, My Documents, and custom garbage.

_Also, I have an ICH10 controlled RAID 0 (2x80GB) with
___12 GB partition with SWAP file.
___136 GB partition without useful destination.

I want to translate Windows 7 and SWAP to SSD

This is my plan:

[Edit] 0-apply any new SSD firmware.

1-Reduce my 120Gb Windows 7 partition, because I don’t know if The 120 GB in OCZ Vertex 2 really are 120 GB usable space (maybe some amount is reserved for spare space to guarantee performance).
I have 70 Gb free, so I expect to do a large reduction (and also save time cloning).

2-Prepare a bootable USB with Clonezilla (is easy with UNetbootin and the freely downloadable ISO image of Clonezilla)

http://unetbootin.sourceforge.net/

3-Boot from USB (since Clonezilla don’t run on Windows), and clone the 100 Mb partition that Windows 7 created at installation, followed by cloning the Windows 7 partition.

4-unplug any HD. I suppose that windows will create his swap file when fail to detect the swap partition.

5-Boot from SSD, and if anything is right, then plug the remaining HD and fix the problems caused by change of partitions letters (My document will be on a random new partition letter, and SWAP probably will run faster in the SSD).

-But I don’t know if Clonezilla also leave the SSD as bootable disk, so if SSD does not boot, then I plan to boot from Win7 Installation disk, and fix boot with his tools.

-Also, I don’t know if this cloning will cause a TRIM, or Garbage Collection issue, reducing the SSD performance. I think that the Vertex 2 has a SandForce 1200 controller, who compresses data, and the cloning maybe writes zeros, which can be interpreted as data by the controller, maybe impeding it from TRIM those blocks.
I expect it to be a non issue, and to be use-transparent, and OS agnostic. Or I’m wrong?

-I’m missing something important?

-I know that Windows 7 has a backup and migration tool, but I never used it, and don’t really know if it would left me with a working windows (without reinstalling all my applications). Somebody knows if is more advisable to use that other way?

More about : cloning win7 boot ssd

November 11, 2010 9:32:05 PM

Maybe this could cause a 4Kb block alignation issue?
m
0
l

Best solution

a b $ Windows 7
a b G Storage
November 11, 2010 9:37:39 PM

Trim would be my consern... I would do a fresh install.
Share
Related resources
November 11, 2010 11:29:32 PM

I spent days trying to do what you want to do and can only say, do a fresh install.
You won't be sorry. With Windows 7 64 bit, Photoshop CS5, Photoshop Elements 9,
MS Office 2010, etc. I am only using half of an 80GB SSD. A secondary (SATA 6) HDD takes care of the yeoman's work. This thing boots real fast and changes the way you operate in a good way.
Good luck.
m
0
l
a c 209 $ Windows 7
a c 415 G Storage
November 12, 2010 1:47:22 AM

I did exactly what you are trying to do by simply using the "System Image" backup that's already built into Windows 7. Here are the steps I took:

1) Connected an USB external drive and ran Windows 7 Backup to perform a "System Image" backup to it.

2) Used Windows 7 Backup to burn a "System Restore" DVD.

3) Shut down the system, removed the HDD and installed the SSD.

4) Booted the system from the "System Restore" DVD and used it to restore the image backup from the external drive to the SSD.

It worked without any problems and restored both the 100MB recovery partition as well as the 160GB partition that my OS resided in.
m
0
l
November 16, 2010 5:27:02 AM

@sminlal, is trim working on your imaged win 7?

m
0
l
a c 209 $ Windows 7
a c 415 G Storage
November 16, 2010 2:12:56 PM

Well, "fsutil behavior query disabledeletenotify" shows that TRIM commands are being sent to all my drives. AFAIK that's the default for all Windows 7 installations whether they have SSDs or not.
m
0
l
November 19, 2010 1:17:09 PM

Best answer selected by marraco.
m
0
l
November 19, 2010 1:27:26 PM

Well, I Choose first the windows image backup/restore way.

It completely failed. Despite that I was triyng to restore a boot partition + Windows partition, who had less than 60 GB, into a 120 GB Vertex 2 SSD, the restore DVD I burned after doing the backup, failed to restore the image.

Then I switched to Clonezilla, and it worked, but forced me first to create the partitions, and the Clonezilla copied the partitions. Nonetheless, I made a 100Gb partition to clone the 60Gb Windows partition, but after boot from it, it recognized it as a physical 100 Gb partition, but a logical 60Gb partition. Chckdisk recognized the error but was unable to fix it.

Not willing to run risks, I completely deleted all partitions, and tried again with Parted Magic Boot CD, but it failed to recognize most drives as already partitioned. I suspect that the reason is my ICH10 RAID 0.

So, I got back at the start point, and tried Paragon Partition Manager 10.
It worked, but misaligned the partitions, forcing me to use the Paragon Alignment tool. It did the trick, and Windows booted, and run Ok.

I’m now checking all the tweaks that Windows 7 is supposed to apply automatically when is running in SSD.

Nonetheless, I agree with anonymous1. Doing a fresh install saves a lot of headaches.
m
0
l
!