Sign in with
Sign up | Sign in
Your question

ICH10R, R5, replaced harddrive won't add to raid

Last response: in Storage
Share
November 14, 2010 12:12:46 PM

Hello,

I have a ICH10R raid 5 setup, with 6x 1,5TB WD disks.

One of the HDD's failed, and it actually seems to be broken. I can't format it etc.


So i bought a new harddrive, i wanted an identical harddrive to the one that just failed,
but i couldn't find any stores in my country with WD15EADS disks in stock.
So i bought a Seagate Barracuda 7200.11 1,5TB instead.

Intel Matrix Storage Manager also reports that the Seagate drive is of the exact same size as my WD drives. (1397.2 GB)


The problem now is that i can't add this drive to the raid. It just appear underneath "Non-RAID Hard Drives".
If i right click on it, i have the option "Mark as spare". I tried to do that, and reboot my computer, but then it's just listed
as a spare drive, i have no options of rebuilding the raid to that hdd.


Anyone have any idea how to add this drive to the raid, and start rebuilding it?

I'll add a screenshot of how it looks in Intel MSM.







a c 127 G Storage
November 14, 2010 1:04:21 PM

You should look at the missing hard drive and see if you can swap your spare drive for it. I didn't use any of these utilities, but the option to rebuild your degraded array should be there. What about the Actions menu?

Normally i would think you would select the failed disk, right click and click say Replace, then select a new (non-raid) disk and the rebuild should start, something like that. But i'm not sure how exactly it works, but this really should be possible using that management application.
November 15, 2010 5:45:37 PM

Yeah that would be logical, but it's weird that i have no options what so ever when i right click (or use the Actions menu on top) on the Non-RAID disk, or the Missing Disk.
I've also tried to enter the Raid BIOS menus, but the only options there is for create or delete raid..

Anyone had any similar problems?
!