Sign in with
Sign up | Sign in
Your question

Large Files Get corrupt when sending over network

Last response: in Networking
Share
August 1, 2009 6:27:23 PM

I have a Server running win2k3 acting as a NAS with raid 5+1 on an adaptec 5405 card. Attached via gigabit network Netgear16 port switch,

I have been getting alot of corrupt files. I like to rip software and DVD's into ISO's and then store them on my nas for convenience. Of late When I try mounting the iso's and installing the software i get corrupt installations and have to rerip the iso image. This is getting rather frustrating so i tested something.

I zipped an iso, sent it to my nas, then copied it back to my pc. the zip archive got corrupted... What gives? I've never had something like this happen before. It only seems to be affecting large files like disc images. things over a few 100MB. I have lots of images and stuff sub 100mb that are not corrupt.

I also used a sync program to re-test this theory, i had it sync a 500mb zip file, and told it to verify the files were copied correctly. It failed saying the files on the destination were difference from the source...

I also tried sending it to the servers C drive instead of the Raid drive, same results... so network error or windows error? I don't know where to begin to trouble shoot this. First step. I'm bringing the PC upstairs to work on. I'll wait for someone to post back and give me some advice.

Also tried switching switches from a 16 port to an 8 port, just to make sure that wasnt the issue. Still getting corruption

I copied a file to a thumb drive, put it on the server, then copied it to my pc via the network, and it was not corrupted...

After playing with it some more I have figured out that the problem is intermittent. It affects files as small as 10 megs, and affects larger files more frequently. Hence why I didnt realize it was a problem until now. I can use my sync program to bypass the problem temporarily, because of the built in verification, but that is definitly not a long term solution.
August 2, 2009 3:39:57 AM

Is your network Gigabit or 100 Mbps? Did you perform enough tests to make sure that files are corrupted only when copying them to the server? Does it take approximately the same time to copy a file to and from the server?
m
0
l
!