Sign in with
Sign up | Sign in
Your question

How Do You Enable USB 3.0?

Last response: in Overclocking
Share
January 5, 2011 7:09:24 PM

I have a Gigabyte X58-USB3 motherboard, and I installed the drivers, im running windows 7 64 bit, and I cant get my usb 3.0 flash drive to show up in windows when I connect it? When I plug it in, it flashes for about 4 seconds, but does not show up in windows, help??

Thanks!

More about : enable usb

a b V Motherboard
a b $ Windows 7
a c 242 K Overclocking
January 6, 2011 6:57:16 AM

USB3 recognize , try install driver form cd bundle motherboard
m
0
l
January 6, 2011 7:34:39 AM

henydiah said:
USB3 recognize


huh? what?
m
0
l
Related resources
a b V Motherboard
a b $ Windows 7
a c 242 K Overclocking
January 6, 2011 7:56:41 AM

sorry ....missing text !
install driver from CD bundle motherboard & sure in BIOS enabled
m
0
l
May 22, 2011 11:21:27 AM

yutubemedia said:
I have a Gigabyte X58-USB3 motherboard, and I installed the drivers, im running windows 7 64 bit, and I cant get my usb 3.0 flash drive to show up in windows when I connect it? When I plug it in, it flashes for about 4 seconds, but does not show up in windows, help??

Thanks!


This problem drove me crazy, until a came across the solution in another Forum...

Before you enable USB 3.0, you need to 'see' the USB Flash Drive in Windows Explorer. To do that, right click 'My Computer', then left click Manage, and Disk Management. On the next screen, in the column headed by Volume, Layout, etc..., scroll (all the way) down until you see the graphical representation of your USB Flash Drive (it won't have a Drive Letter assigned). Right click it, and left-click 'Change Drive letter and paths'. Then, add a new drive letter, and click OK. You will then be able to see/use the Flash drive in Windows Explorer.

Izmir Can
http://www.learningpracticalturkish.com/
m
0
l
!