Sign in with
Sign up | Sign in
Your question

Can you help me set my ram on the right settings.

Last response: in Memory
Share
October 1, 2009 5:00:38 AM

I bought some ddr2 Dominators 8gb memory sticks (TWIN2X4096-8500C5D) and the settings it stated are 1066mhz, timings at 5-5-5-15-2t and the voltage at 2.1.

However when i look at the bios the timing are all wrong
http://img198.imageshack.us/img198/6401/img0007pr.jpg


and the memory clock is set at 400mhz
http://img188.imageshack.us/img188/2635/img0005yl.jpg


so can anyone help me set the timing and mhz right? please

More about : set ram settings

October 1, 2009 6:38:50 AM

In the first image set DDRII Timing Items to manual.

In the second image go to Set Memory Clock and set that to manual also.

This will open them up so you can change the settings you need.

As for changing the voltage to spec. you should be able to type the numbers in, be careful to make sure you type in 2.1
m
0
l
October 1, 2009 10:14:41 AM

do not worry about it showing 400mhz clock speed. this is correct. with double data rate 2 (ddr2) the actual clock is 800mhz. or for example 667mhz would show at 333mhz
m
0
l
Related resources
October 1, 2009 12:28:01 PM

logan86 said:
do not worry about it showing 400mhz clock speed. this is correct. with double data rate 2 (ddr2) the actual clock is 800mhz. or for example 667mhz would show at 333mhz

His memory is 1066 not 800, and to be specific 400Mhz equals ddr 800 not 800Mhz as it doesnt run at 800Mhz.

@nero25 do as unclefester said or if your mobo supports it than enable the EPP profile and all correct values should be loaded automatically.
m
0
l
a b } Memory
October 1, 2009 3:27:19 PM

That BIOS looks a lot like my Gigabyte 785 series. First step is to put the DDR2 Voltage Control to +0.3 to take it to 2.1V. This will be in RED numbers, don't worry about that. Then re-boot and see if it comes up at 1066. If not, then change Memory Clock to manual, reboot. Then Memory Clock to 5.33 and all should be fine.

Once you've got it at 1066, you might go into the DRAM configuration and note the Auto settings. They should be higher than the 5-5-5-18 you see now. You can try setting them to manual and change them to the 5-5-5-18 settings designed for the 800 mode - but be sure to test for stability afterwards.

The SPD/EPP profile will show settings for 533MHz when all is correct and should be picked up by the BIOS. There's no setting to turn on EPP.
m
0
l
!