Sign in with
Sign up | Sign in
Your question

Numerous Blue screen errors

Last response: in Systems
Share
April 15, 2009 3:33:42 AM

Not sure if this is the place to post this but in searching around the site I couldnt really find a specific place to post error problems. Its a home built system so I'll try here. I've built several systems in the past with no problems like this.

Ok last Nov I built a new system just for photo storage and processing. Since then I have been plagued by error upon error. These range from IRQL NOT LESS OR EQUAL, PAGE FAULT IN NONPAGED AREA, THE DRIVER MISTAKENLY MARKED PAGABLE INSTEAD OF NONPAGABLE. etc etc . Sometimes there is no error type. All kinds of different .sys files listed so on and so forth...nothing seems constant.

I've done all the memtest86 tests for days on end with no errors found. I've tested my hard drives numerous times with no errors ever found. I've reloaded, replaced, upgraded, reinstalled every device driver I can think of. I've gone from XP Home to Vista 32 to Vista 64. I replaced the graphics card and even the memory just to do it, and the power supply (650 w).

I have a Gigabyte GA-EP45-UD3P and have never found a bad word said about it when googleing, but could it be a bad chip set or controller causing all this randomness?

I'm really pulling my hair out on this one and ready to throw it it out a window, but I need this for my photography business.

Thanks in advance,
Stan A

Some specs

MB GA-EP45-UD3P
Proc Q6600 Duo Quad core
RAM 8GB's Kingston DDR2800mhz PC2-6400
Graphics EVGA 9400 GT
HD's all SATA all WD
500GB (main drive OS etc)
80GB (Photoshop scratch drive)
1TB external (x2 RAID drive)

a c 136 B Homebuilt system
April 15, 2009 4:36:12 AM

The IRQ error is probably the main issue .

When you boot the bios splash screen probably shows you the IRQ assignments . Chances are there are several devices assigned to the same IRQ as your gfx card.

reassign the other devices leaving only the gfx card on that IRQ

In the PnP/PCI page of the BIOS. You have to use the hotkey to access the settings in that page. Press control + F1 on the MAIN Page of the BIOS and then go into that page and you will probably find what you need.
April 15, 2009 10:25:42 PM

Thanks for the reply Outlander,

So you're saying that with the gfx card sharing an IRQ with other devices this could cause a variety of drivers to be listed as being the problem, however only because they are being affected by the gfx card...hmmm that does make sense. I have built several machines in the past but never had to deal with these issues. I am going to try that.

Thanks,

Stan A
Related resources
April 16, 2009 1:16:02 AM

Well even using ctrl f1 at the bios I didnt see any settings that allowed me to chose what device was assigned to an IRQ. Several google searches didn't reveal any way to do it either. I read alot about how ACPI would overrule any bios changes anyway. I have to imagine there are hundreds or thousands of systems similar to mine. Why would mine be having these error. It either has to be some simple setting I'm missing or something about my MB is damaged.....errr
April 16, 2009 1:48:00 AM

At this point, my guess is the motherboard. That, or the processor's cache is malfunctioning. I had an AMD Opteron that's L2 cache had a bug in it and would throw some of those same errors, mainly the fault in nonpaged area one. However, Memtest would show that, and that's how I found out.

*points at mobo*
a c 136 B Homebuilt system
April 16, 2009 3:17:46 AM

Whats probably happening is that when too many devices use the IRQ some of them have to crash .

Which one actually crashes is going to depend on a number of things like whats already using the IRQ, and thats why you get different error messages .

nVidia say that their cards should be the only device on an IRQ

There will be a PnP/PCI page in the BIOS and it will list how IRQ's are assigned . Change it to anything else thats available and see if it works .

You may also be able to correct the problem by moving expansion cards to different pci slots . If you have a sound card [ or similar ]using the same IRQ as the gfx card then move it , and the mb will probably reassign it .

You may be able to disable ACPI
and you may be able to change IRQ assignments from windows XP easily enough[ but this is even less likely to work because of ACPI] , but Vista looks tricky .

I googled a bit and found
http://tinyurl.com/d9vwwx

which sounds like MS have messed with your mind
April 16, 2009 4:21:52 AM

So pretty close to last november I upgraded my system with a GA-EP45-UD3P and I too have faced nothing but random bsod's using Vista 32 bit. I don't seem to have too much trouble running the windows 7 beta though. I have also pretty much replaced just about everything. Heck the stupid thing wont bsod running prime made it over 40hrs overclocks like mad but running at stock and I have tried everything I could think to get this stable and it won't. So you not alone. I am going to try looking into this IRQ stuff more this weekend and see if I get anywhere. I don't have time at the moment but I think I will change the pci1 and pci2 assignments to something random and just see maybe adjust some other settings. Please post if you get anywhere. I usually get a bsod between 4 and 24 hours of on time.
April 18, 2009 3:06:48 AM

Hey Guys thanks for all the responses I wasn't able to get on for a couple days due to work.

The only thing I can see sharing the IRQ with my GFX is a USB controller. I went to the PnP/PCI page in the BIOS using cntr1 and got additional options but none give an actual list of what is assigned ( I found that info during POST) All the BIOS gives as an option is to assign PCI1 and PCI2 to a specific IRQ but the way I read it thast wont help me because my GFX apparently has to plug into the one and only PCIEx16 slot. There are a PC1 and 2 but I "dont think" the card will plug into one of those...I will of course double check that. If I can move it will it operate any differently since it is apparently meant to be in a PCIEx16 slot?

The other BIOS IRQ setting was simply to change it from auto assign to manual, which I thought was the pot of gold, but once I do that all it lets me do is either allow PCI devices to use an IRQ or to reserve it for "another device". When I tried that function all it did was force the GFX and the USB controller to another (but the same) IRQ and didn't solve the problem.

I wish I could disable ACPI somehow because i see grayed out options in the device mgr for IRQ's but I cant find a way to allow access to this..I wonder if I turn off user controls it will let me...hmmmm

I missed out on the Win 7 beta, which you cant get now. A guy at work told me he loves it and said it is everything Vista "should have been". It's not dueout for quite a while yet in final.

I am thinking MOBO as well but am unsure. This may be the last gasp that forces me to go MAC (for photo processing) after all these pro PC years....ugh
April 18, 2009 10:14:46 AM

you can still get the latest builds of win7 off torrents plus the released keys work on all the builds so just check the torrent info for a key, im sure they will post one.
May 27, 2009 4:56:02 AM

Has anyone figured out a solution to this yet? I thought I was the only one having this issue!! I have nearly the exact same setup except for the video card and RAM which also passes memtest86, memtest86+, windiag without errors on multiple passes.

I have tried all other suggested fixes without success. I'm thinking the motherboard is faulty. I purchased it in late March from newegg, perhaps they came from the same bad batch?!?

I started having issues using Vista 32-bit, and then tried using the Windows 7 64-bit RC. The RC version is available again though the problems persist. Any suggestions would be greatly appreciated!!


MB: GA-EP45-UD3P
CPU: Q6600 Duo Quad core
RAM: 4GB OCZ Reaper DDR2 1150 (PC2 9200)
Graphics: EVGA 9600 GT
HD: 500GB SATA (Western Digital)
!