Sign in with
Sign up | Sign in
Your question

Packard Bell UTOW - RIO Doesn't boot, motherboard problem?

Last response: in Motherboards
Share
Anonymous
a b V Motherboard
October 5, 2009 11:15:49 AM

Hi,

I have a Packard Bell UTOW-RIO Tower PC and it's not booting. The lights come on and the hard drive whirrs but just ticks away and nothing appears on the screen. Here's what I've tried:
- Replace Hard Drive with one I know works, same issue.
- Replaced power supply with one I know works, same issue.
- Tested HDD and power supply in other computers, both work fine.
- Changed SATA cable, same issue.

The motherboard is a Gigabyte (Rio?) GA 8trc410mnf-rh. I could replace this, but I saw on another forum that replacing the HDD didn't help someone else. Any ideas?? Sorry for wrong sub-category, but I couldn't find a Gigabyte one...

Thanks!
a b V Motherboard
October 6, 2009 9:44:39 AM

Try new RAM, though I doubt that's your issue. Either your PSU or motherboard needs fixing/replacing.
Anonymous
a b V Motherboard
October 6, 2009 10:38:23 AM

Thanks. If the RAM was faulty then it should still boot to BIOS, shouldn't it? The power supply is fine, so I've ordered a new motherboard.
Related resources
October 6, 2009 11:59:35 AM

no, if ram is faulty, it would make beeping sounds if you have a case speaker... It's annoying when you first hear it.. BEEP...BEEP...BEEP and no post, nothing
Anonymous
a b V Motherboard
October 7, 2009 11:22:25 AM

There is a case speaker, and it's not making any sounds, all you can hear is the HDD clicking (have tested HDD and it works in another computer) but I'll try changing the RAM. Replacing the RAM and motherboard are the only things I haven't tried, so logic suggests one of them will solve the problem!
!