Sign in with
Sign up | Sign in
Your question

Help needed with Gigabyte P55-UD3

Last response: in Motherboards
Share
October 5, 2009 6:37:34 PM

Hi guys, need a bit of help please. I have just built a new system, the main components of which are i5 750, Gigabyte P55-UD3, and G-Skill 4gb 1600mhz 7-7-7-24 RAM.

It's the BIOS I'm struggling with...it defaults the RAM to 1333mhz (133 bclk) and the CPU to x20 (x21 for turbo), which is fine, however I want the RAM to run at 1600mhz. I selected the XMP RAM profile which automatically altered the bclk to 160 (increasing RAM speed to 1600) and the CPU multi to 16. Now the problem I've got is the turbo multi for each core also says 16 and sure enough I don't get any turbo kicking in in Windows.

I've tried enabling/disabling C1E and EIST etc but nothing I do seems to allow me to have any turbo. I'm not bothered about overclocking as I only have stock cooler, I just want the damn turbo to kick in!! Is this impossible due to changing the bclk?

Any help appreciated, thanks
a b V Motherboard
October 5, 2009 7:01:22 PM

Not much boost in going from 1333 -> 1600, unless you overclock. The timings provide more of a boost. With your ram you MAY (???) be able to tighten the timings up abit by running @ 1333. May be wrong, but some of the articles dealing with speed seem to favor this point of view.
http://www.tomshardware.com/reviews/memory-scaling-i7,2...
Quote
Knowing all of these results, it is obvious that highest speed DDR3 memory only makes sense for serious enthusiasts, or for those with unlimited budgets. Everyone else should focus on mainstream clock speeds of DDR3-1066 or DDR3-1333, and go for a trustworthy brand and the quickest timings their budget allows.

PS: If and when I build my I5, I will also get the 1600 RAM.

a c 177 V Motherboard
October 6, 2009 1:39:27 AM

I've posted the beginnings of a tool to compare latencies on tri-channel RAM here:
http://www.tomshardware.com/forum/263947-30-memory-comp...

The fact is that the new i7/i5 architecture is much more responsive to low-latency, as opposed to faster-clocked RAM; I recently wrote this, in explanation:
"There is a place where high speed, versus low latency, will be an advantage - any operations that require large, sustained, reads from and writes to RAM - like, as I mentioned, video transcoding... I always consider my 'pass/fail' system stress test to be: watch/pause one HDTV stream off a networked ATSC tuner, while recording a second stream off a PCI NTSC tuner, while transcoding and 'de-commercialing' a third stream to an NAS media server... But, for the vast majority of people, for the vast majority of use, this is not the case. What's going on behind the scenes: the task scheduler is scurrying around, busier than a centipede learning to tap-dance, counting 'ticks': ...tick... yo - over there, you gotta finish up, your tick is over, push your environment, that's a good fella; oops - cache snoops says we've got an incoherency - grab me a meg for him from over there; ...tick... you - get me the address of the block being used by {F92BFB9B-59E9-4B65-8AA3-D004C26BA193}, will 'ya; yeah - UAC says he has permission - I dunno - we'll just have to trust him; damnit - everybody listen up, we've got a pending interrupt request, everyone drop what you're doing, and you - over there - query interrupt handler for a vector - this is important!!! ...tick.... This is why (aside from the obvious matter of access architecture) that swap files are optimized in 4k 'chunks'... And the most fascinating (scary) thing about it all, is that, at some synaptic, neural level, we're doin' the same thing! (...though, the older I get, the less dependable my interrupt return mechanism is - I repeatedly find myself at the bottom of the basement steps, wondering "now what did I come down here for?!" )
Related resources
a b V Motherboard
October 22, 2009 4:15:20 PM

Did you find a solution to your problem? I ran into a similar situation with a GA-P55M-UD2, G.Skill 2x2GB 1600 CAS9's and an 97 860. My CPU multiplier got stuck at x21 or x22, so yours getting stuck at x16 is odd. Still, maybe the 'fix' I found will work for you, too.

The problem I was running into, and it sounds like you may be having, was basically that Turbo was not working. I traced the cause of this problem to be turning on the XMP RAM profile in the BIOS. With XMP turned off, Turbo mode worked as expected. With XMP turned on, Turbo stopped working. After some easy changes to a few default settings in the BIOS, I was able to get XMP and Turbo working together. The changes I had to make in the BIOS were on the Advanced CPU Core Features page:
Intel Turbo Boost Tech. - changed from Auto to Enabled
CPU Cores Enabled - left as All
CPU Multi-Threading - left as Enabled
CPU Enhanced Halt (C1E) - changed from Auto to Enabled
C3/C6/C7 State Support - changed from Auto to Enabled
CPU Thermal Monitor - changed from Auto to Enabled
CPU EIST Function - changed from Auto to Enabled
Bi-Directional PROCHOT - changed from Auto to Enabled

My board now idles with a multiplier of x9 (about 1.2GHz). And when I run a single thread of Prime95 it hits a multiplier of x26 and the max speed of 3.46GHz. Turbo now appears to be working with RAM set to XMP.

Note: These readings are as reported by CPU-Z. CoreTemp approximately matched the idle numbers, but it never reported a multiplier and speed higher than x22 and ~2.93GHz. I'm hoping CPU-Z is correct and CoreTemp has a bug keeping it from reading this processor correctly!

It sure would be nice if Gigabyte explained under what conditions "Auto" settings would result in Enabled vs. Disabled. But since they don't (or I couldn't find it), I have to assume that if I changed any settings, i.e. when I turned on XMP, all of the Autos would be treated as Disabled.

I have not been able to find confirmation of my work elsewhere in the forums or on the internet yet, but I am fairly confident that I have nailed down the cause of and solution to my problem. If you test this theory please let us know the results.
October 23, 2009 1:33:42 AM

When leaving BIOS function in "Auto", usually it means this function is decided by the BIOS policy. In this case, when CPU ratio is set by manually, Turbo Boost will be disabled by BIOS policy if you leave the option in "Auto". To change the status, manually set to enable will overwrite the policy it set.
October 28, 2009 7:55:07 PM

ekoostik said:
Did you find a solution to your problem? I ran into a similar situation with a GA-P55M-UD2, G.Skill 2x2GB 1600 CAS9's and an 97 860. My CPU multiplier got stuck at x21 or x22, so yours getting stuck at x16 is odd. Still, maybe the 'fix' I found will work for you, too.

The problem I was running into, and it sounds like you may be having, was basically that Turbo was not working. I traced the cause of this problem to be turning on the XMP RAM profile in the BIOS. With XMP turned off, Turbo mode worked as expected. With XMP turned on, Turbo stopped working. After some easy changes to a few default settings in the BIOS, I was able to get XMP and Turbo working together. The changes I had to make in the BIOS were on the Advanced CPU Core Features page:
Intel Turbo Boost Tech. - changed from Auto to Enabled
CPU Cores Enabled - left as All
CPU Multi-Threading - left as Enabled
CPU Enhanced Halt (C1E) - changed from Auto to Enabled
C3/C6/C7 State Support - changed from Auto to Enabled
CPU Thermal Monitor - changed from Auto to Enabled
CPU EIST Function - changed from Auto to Enabled
Bi-Directional PROCHOT - changed from Auto to Enabled

My board now idles with a multiplier of x9 (about 1.2GHz). And when I run a single thread of Prime95 it hits a multiplier of x26 and the max speed of 3.46GHz. Turbo now appears to be working with RAM set to XMP.

Note: These readings are as reported by CPU-Z. CoreTemp approximately matched the idle numbers, but it never reported a multiplier and speed higher than x22 and ~2.93GHz. I'm hoping CPU-Z is correct and CoreTemp has a bug keeping it from reading this processor correctly!

It sure would be nice if Gigabyte explained under what conditions "Auto" settings would result in Enabled vs. Disabled. But since they don't (or I couldn't find it), I have to assume that if I changed any settings, i.e. when I turned on XMP, all of the Autos would be treated as Disabled.

I have not been able to find confirmation of my work elsewhere in the forums or on the internet yet, but I am fairly confident that I have nailed down the cause of and solution to my problem. If you test this theory please let us know the results.


No still haven't found a solution to this. My CPU multiplier doesn't get stuck at x16, I can change that to whatever I wish, but whatever I set it to, the turbo frequency is locked at the same value when it should be x1 higher for each core. Hopefully this makes sense! Even when enabling everything on the advanced CPU core features, I don't get any turbo, only reduced multipliers when usage is low.
a b V Motherboard
October 29, 2009 4:34:23 PM

I re-read your initial post and noticed I had missed something in there with all those numbers. It is odd to me that turning on XMP adjusted up your bclk. That doesn't happen with my i7 860. But the i5 750's are not always supported by the motherboards at higher speeds.

If you check the explanation of the i5 750 test setup in this review: http://www.anandtech.com/mb/showdoc.aspx?i=3639
the thing that jumps out at me is "We used DDR3-1333 6-6-6-18 1T timings for the i5/750 stock setup as DDR3-1600 is not natively supported in current BIOS releases for this processor at a stock Bclk setting of 133."

The increasing of Bclk could be causing your loss of Turbo. What happens when you disable XMP? Does Turbo work?

Also, how are you measuring the multiplier?
October 30, 2009 9:36:35 AM

The bclk has to be increased to 160 as the highest memory multi is x10 (on my board at least). I'm using CPU-Z to measure the CPU multi.

I have actually just made an interesting discovery though... I'm still using a bclk of 160 and If I change the CPU multi from x16 to x20 I get turbo mode again. On the BIOS CPU summary screen it shows x21 for the turbo multi and CPU-Z confirms it. For some reason using any CPU multi below x20 will not allow turbo mode.

The only thing is I'm reluctant to leave the CPU on these settings due to only having a stock cooler!

a b V Motherboard
October 30, 2009 10:25:32 AM

I wondered about that. It (kind of?) makes sense that if you set a specific multiplier it would honor that. But if the multiplier is at 20 that is its natural state so then it would allow turbo. I guess I could see the logic in that.

If you're worried about temperatures you should download a program to monitor them. Take your pick. Common favorites include SpeedFan, CoreTemp and RealTemp. One word of caution with SpeedFan, unless they've updated it recently it reports ~20C low for the Lynnfield chips. You may want to download 2 programs to monitor temps until you get a feel for what is right. SpeedFan allows you to adjust the offset on the temperatures and there are other guides in these forums to help with that. (On a related note, CoreTemp does not measure single or dual core Turbo correctly, it never shows my i7 860 with a multiplier >22 even while CPU-Z shows x26.)

Another thing to consider:
a 160 bclk x 16 multiplier = 2560
a 133 bclk x 20 multiplier = 2660

So by turning on your XMP - which ups the bclk - and lowering the multiplier manually to what you think is safe, you can end up with a CPU that is actually running slower than stock. It's been pointed out already above, your observable gains from the faster memory are not very significant. And the faster CPU will bring greater gains than the faster memory. You may want to look into bilbat's advice and leave the memory speed alone and tighten the timings instead.
October 30, 2009 11:47:46 AM

Ok thanks for your help (and the other guys too). I was running at the default lower memory speed as you say but I cant see it being a problem running 160bclk and x20 CPU due to the fact that during low usage the multi is reduced. Will defintely keep an eye on temps though.
Re tightening the timings, I have no idea what effect over-tightening has and whether it damages RAM etc. How do you know how much to reduce the timings? I'll have a look around myself but do you know of any good guides?
a c 177 V Motherboard
October 30, 2009 1:37:44 PM

For temperature monitoring -
RealTemp: http://www.fileden.com/files/2008/7/28/2024082/RealTemp...
HardwareMonitor (32 bit): http://www.cpuid.com/download/hwmonitor/HWMonitor_114.z...
HardwareMonitor (64 bit): http://www.cpuid.com/download/hwmonitor/HWMonitor64_114...
CoreTemp (32 bit): http://www.alcpu.com/CoreTemp/CoreTemp32.zip
CoreTemp (64 bit): http://www.alcpu.com/CoreTemp/CoreTemp64.zip

For monitoring 'turbo mode': http://www.hardforum.com/showthread.php?t=1417780

As far as memory tweaking, the first thing you want to do is get a solid 'read' of your actual SPD. Assuming this will run correctly on the new platforms, this tool is the best (MemSet4.1β6): http://www.tweakers.fr/download/MemSet41b6.zip
Again, assuming it runs, MemSet will also let you 'tweak' memory settings 'live' - I don't recommend its use to give a final setup, but, like EasyTune, it's good for quickly testing changes which you then want to go in and set permanently in your BIOS...
January 31, 2010 9:13:53 PM

I have the same problem as the original poster: I don't have turbo mode. At idle it drops to 9x, and under load for a single core, or 4 cores (doesn't matter), max multiplier is 20x. The BIOS shows 21x, but CPU-Z or CoreTemp or i7 Turbo 6.95 never show more than 20.

OS is Windows 2008 R2, CPU is i5-750 on Gigabyte GA-P55A-UD3. BIOS settings set to enabled instead of Auto, and I have no XMP settings in BIOS, only SPD.

Which is weird, 'cause the manual and screenshots show everyone else has XMP but me. Maybe my RAM (Crucial CT2KIT25664BA1339) doesn't support it?

Either way, I'd like the turbo tech because i'm trying to have a low-powered machine which will be on 24x7 and sit idle most of the time.
a b V Motherboard
January 31, 2010 9:41:59 PM

If you have not done so already, get the latest BIOS update for your board. When you've updated it, select Load Optimized Default options and save the settings.

Then go back into BIOS, make sure Turbo, C1E, C3/C6/C7 are all set to enabled.

Your CPU multiplier should be set to 20.

Download Prime95 and run 1 thread. Monitor your speeds with CPU-Z. With only 1 thread running you should get a multiplier of x24. If you don't, open Task Management. See what else is running. If there are activities running in the background, such as anti-virus, that are taking other cores you will not get more than 1 Turbo boost.

If you still don't see the boost, check that you have the latest CPU-Z. Then check your temperatures. If the CPU is running too hot it will not give you a boost.
January 31, 2010 10:04:27 PM

Thanks for the quick reply. I already flashed the latest BIOS, F5 (upgraded from F5c, which was upgraded from F4).

I set it to Optimized defaults. Incidentally, this set my SSD and drives to PATA mode instead of ACHI. Will reset those later.

This also of course removed my overclock so it's running at 133x20 in the BIOS and under load.

Multiplier is set to 20. I have been running prime95 with one thread. In Task Manager I set processor affinity to proc 0, otherwise it jumps around.

I'm still seeing x20 multiplier. CPU-Z is the latest @ 1.53.1. Core Temp 0.99.5 shows the same x20, as does Turbo i7 6.95.

Temperature highs are 38/34/37/31 under load.


What's interesting is the BIOS actually shows on the POST screen "133x21 2.80Ghz" but I don't get that in Windows.

Is this a 2008R2 problem? It's based on Kernel 6.1, which is the same as Windows 7.

My power profile is a default one, but I don't see anything in the advanced settings that would limit this.
a b V Motherboard
January 31, 2010 10:15:46 PM

Those are some impressive load temps. What HSF are you using?

I suppose it could be an OS problem. I never have to set the processor affinity. I tell P95 to start 1 thread and I tell it which thread to start - with my i7 860 I pick a number 0 to 7. When it starts I watch in Task Manager - Performance and the thread I kicked off goes to 100% while the others stay at or about 0.

Are you other 3 cores staying at 0?
January 31, 2010 10:32:51 PM

I'm using the Zalman 9900 with two 120mm case fans inverted in a wind tunnel config - see the Silverstone Temjin TJ06. Of course this is only at 2.66Ghz, so of course temps will look a bit low. When manually overclocked to 3.6Ghz I hit 55c.

Prime95 is v25.9 build 4 64bit. It doesn't ask which processor, it just asks how many threads to start. with it set to 4, it maxes out. With threads set to 1, it jumps around unless i set the affinity in task manager.


The other cores are at zero, with the occasional bump here and there.

Are there programs for testing turbo boost in Linux? I can boot a Ubuntu disk and see if it's an OS issue.


I just noticed that under full load, all 4 cores are at 20x, and while idle all 4 cores are at 9x. Before, only one core would jump up to 20x and the rest would stay at 9x. This started after switching to optimized defaults in the BIOS.
January 31, 2010 11:28:33 PM

I think I may have found the problem. In 2008 Advanced Power management, there is a setting:

* Processor power management -> Minimum processor state was set to 0%
* Processor power management -> Maximum processor state was set to 100%

When I set the maximum processor state to 50%, CPU-Z et. al. instantly change to 1600Mhz.

So is it reading 3200 as the max speed and preventing the proc to exceed this? Worse still, the box won't allow input over 100%.

Still googling this one...
a b V Motherboard
January 31, 2010 11:50:54 PM

It probably would have been better to start a new thread. I'm not sure where the 1600 MHz comes from, but I do not think this is related to your problem.

Setting the minimum state to a low number, typically 5%, is what allows your computer to run at, for example, a x9 multiplier when in idle state. Setting the max at 100% will not hold back your CPU.

What were you using before that reported the speed of each core? You said that only one core would jump up to x20 and the rest would stay at x9. I'm not familiar with, or not remembering, sofware that reports each core speed independently.

I want to explore Prime95 a little further. Open the program, but if it starts running stop all the threads. Then go to Test - Worker Windows. What are your settings? I have # of worker windows to run = 8; priority = 1; worker number = all workers; type of work to get = whatever makes the most sens; cpu affinity = smart assignment; multithreading (CPUs to use) = 1.

After noting these settings, go to Test - Continue. This is how I can choose which core to test. The window that opens is titled "Start one or all workeres". I uncheck "Start all workers." Then I enter a number in the "Worker number to start". I got this slightly wrong before, I can enter a number 1 through 8 and that launches on one of my 'cores'. Do you have the option to enter 1 through 4?

I don't really see this as a P95 issue. But I'm not sure why you saw something different.
February 1, 2010 12:50:02 AM

Solved! More below.

You're correct, I should have started a new thread. Apologies. In Prime95 the number of workers was different than yours, so I set it up the way you described. I found the problem with Prime95, though. I was running torture test and not benchmark. When running benchmark, it runs exactly as you said w/o needing to set the proc affinity.

However, I discovered the flaw. When I disabled EIST in the BIOS, turbo boost now works exactly as it should. And I think I found a bug in CPU-Z (with EIST disabled, that is).

In CPU-Z, if you open the program 4 times, you can right-click and select which core to report. "i7 Turbo 6.95" will report the real-time multipliers of each core, much faster than CPU-Z does. This program appears to work correctly.

So in my BIOS I'm set to 160x20, EIST disabled but everything else enabled. In this scenario, CPU-Z is showing a core speed of 3838 (x24) all the time, with an occasional dip into x23. This is at idle. Under load it reports x21.

However, with i7 Turbo, it correctly reports the multipliers anywhere from 9-20 when idle and under load on one core it goes up to 24 and with all 4 cores under load, it reports 21, like I read about (only one bucket with 4 cores under load).

So it seems CPU-Z isn't reporting the correct multiplier in any of the 4 cores with EIST disabled (it works fine with EIST enabled), but I don't get turbo boost with EIST enabled.

How's that for strange? Can anyone else test this?

BTW I have a kill-a-watt meter plugged into the wall so I can verify the load by the wattage it is sucking up in all of these scenarios. With EIST enabled, when idle I consistently got 9x and drew 97-99 watts. With EIST disabled, the turbo works and is much more active, going from 9-16 under idle and using 99-102 watts.

Under load, before i drew max 205 watts. After I disabled EIST and now get the x24 multiplier, it's drawing 230 watts under load.
a b V Motherboard
February 1, 2010 1:04:39 AM

Congrats on getting that solved. Enabling EIST shouldn't take away your Turbo though. You sure Turbo isn't working in this scenario? Another possibility is that there's another CPU-Z bug such that with EIST enabled CPU-Z doesn't report higher than a x20 multiplier. I did observe the same problem in either RealTemp or CoreTemp. Forget which now, but it never reported multipliers higher than the baseline CPU multiplier, even though the chip was running Turbo'ed up a few notches.
February 1, 2010 1:10:14 AM

You're right, I can't really trust any programs at the moment. Which is why I reported the kill-a-watt meter plugged into my UPS (PSU -> kill-a-watt -> UPS -> 120V wall).

I can confirm it's going faster because it's using more power, hehe. Or at least the power perfectly corresponds to what i7 Turbo reports. Which makes i7 Turbo the only accurate program at the moment.
!