Format issues

Heres my issue: I was having problems moving, saving, or deleting items to and from my Hitachi SimpleDrive USB 1TB hard drive. So i decided to reformat it to solve the problem. This is where the problems come up.

It now wont let me format it (errors include: "Media is write protected", "Windows cannot complete the format" format takes a little while to start then stops after a minute or so)

I have tried to format in disc manager and also some other tools but none seem to work.

Please help me!!!!!! I will give any information needed to assist.

P.S. I have tried partitioning it with no success
4 answers Last reply
More about format issues
  1. It certainly seems like you've got some fort of issue with the disk. Is it internal? Try using a utility that can report the SMART error counters (such as "DiskCheckup").

    If it's an external drive, I think I'd remove it from it's case, mount it internally, and check the SMART counters on it.

  2. It is a External Drive. and if i did install it internally how would I fix it?
  3. Well I'm not sure whether you could fix it or not, but if you can connect it internally then you'll be able to look at the SMART counters and get a little better idea what the problem is. If you've got reallocated sectors then you're seeing a problem with the drive itself, but if you've got protocol errors then it's more likely to be a (less serious) connection problem.
  4. ill try that asap ill reply back once i try it
Ask a new question

Read More

Hard Drives Hitachi Format Storage