Sign in with
Sign up | Sign in
Your question

GA-EP45-DQ6 IDE DVD Writer shown as SCSI/RAID, not working properly...

Last response: in Motherboards
Share
October 7, 2009 1:22:20 PM

Afternoon all,

My IDE DVD drive isnt working properly and is showing up as a SCSI/RAID drive on my system.

Specs are:-

Win XP 32 SP3
GA-EP45-DQ6 F12 Bios
2 x 160gb HD plugged into YELLOW SATA's (none RAID)
1 x Pioneer DVR-111D Writer plugged into IDE Port

Initially it was shown as a SCSI in programs such as IMGBURN. I read that it was a problem with the Jmicron JMB36x Controller which controls IDE getting confused so i updated the driver using the latest R1.17.50_WHQL_Writecachedisabled from here:-

ftp://driver.jmicron.com.tw/jmb36x/XP_Vista_Win7/

I used the writecachedisabled version as that's what some else used with a similar setup to me.

This did nothing but change the Drive from SCSI to RAID in IMGBURN etc.

So i then uninstalled all devices under IDE ATA/ATAPI Controllers to force Windows to find and reinstall them on reboot. Windows found them fine but the DVD Drive is still set as RAID and wont let me browse any media in it.

I think its in PIO mode and dotn know how to change it to DMA. Settings in the Primary/Secondary IDE Channels under Device Manager show 'DMA if available' selected?

I am in no way in the know about things like this and was wondering if anyone knows how to get my Writer setup properly so i can start burning disks.

FYI, couple of settings in my BIOS which may be affecting this:-

SATA RAID/AHCI Mode ......................Disabled
Sata port0-3Native Mode................... Disabled(i think)
Onboard SATA/IDE Ctrl Mode ..............Enabled

Thanks for an help, apologies if ive missed out any info needed.
a c 177 V Motherboard
October 8, 2009 4:15:06 PM

First and foremost, the cabling issues:

Here's an IDE cable:
M|----------|------|D
M1---------2-----3D
The 'M' end is the motherboard connector; the 'D' end goes to the drives.
There are two kinds of cables: 'standard' (on which the drives are jumpered to identify them), and 'cable select' (on which the cable itself sorts out the drive IDs).
If there are no labels (often, a large plastic or fabric 'pull-tab') saying 'master' and 'slave' on connectors 2 and 3, you have a 'standard' cable - jumper as follows:
it doesnt matter what connector goes to what; your ODD will need to be jumpered as 'master' [MSTR] on the drive.
If there are labels saying 'master' and 'slave' on connectors 2 and 3, you have a 'cable select' cable - jumper as follows:
your ODD will need to be jumpered as 'cable select' [CSEL] on the drive; the ODD goes on connector 3, which should be labeled 'master'; connector 1 goes to your MOBO IDE port...

Next, the BIOS:

On the "Integrated Peripherals" page:
"SATA RAID/AHCI Mode" to "Disabled"; this setting ONLY affects the Intel southbridge, where your SATAs are connected, and is used to enable either RAID or AHCI...
"SATA Port0-3 Native Mode" to "Enabled"; this setting enables interrupt sharing - the last version of Windoze that did not 'natively' support this was Millenium Edition (which all of eight people ever bought!), so you always want this enabled - and again, this setting ONLY affects the Intel southbridge...
"Onboard SATA/IDE Device" to "Enabled"; this one turns on the GSATA (jMicron) ports, and the associated IDE controller...
"Smart Backup Function" to "Diasabled"; this one is the equivalent of RAID1 for the jMicron SATAs, and has no bearing on the IDEs...

Then, Xp:
You should be using the default windows drivers here - the jMicron drivers are essentially for RAID/AHCI, and, by all means, you wouldn't want write caching disabled; write caching allows window to stash data to be written to the drive in memory until it can be physically 'fed' to the drive; this makes hard drive useage faster, but leaves your data in RAM while it's 'waiting' for the drive; windows, when it receives instructions to shut down, 'flushes' this data to the drive(s) before it can be lost, but, if you have a power loss, the data awaiting the disk's physical write is lost - disabling the write cache removes this possibilty, but significantly slows disk operations. With a DVD writer, the function is a little different - writing to an optical drive works best if it's done with a steady stream of data - if the write cache runs 'empty', the data to the drive 'stutters', and likely ruins the disk. Most disk writing software (Roxio, Nero, et al) has its own write cache, simply to manage the process, and circumvent that possibility... The reason it took me so long to answer is that my systems been busy in the background for a couple days, and I haven't been able to boot to Xp32 to get a look at the driver situation:





October 12, 2009 1:26:12 PM

Cheers for the reply bilbat.

I 'rolled back' the drivers and selected 'Standard Dual IDE Controller' from the list of available drivers and it worked like a charm. Shows the drive as ATA now and burning is enabled and full speed.

Only thing is the Standard driver is from 2001. Is there a more up to date version i can get. Also is this driver the best one to use anyway???

Cheers again!
Related resources
Can't find your answer ? Ask !
a c 177 V Motherboard
October 12, 2009 1:54:46 PM

I would simply do 'driver update', and then select the 'search on-line' option; if it comes back and says 'up to date', you're good...
a b V Motherboard
October 12, 2009 3:17:43 PM

The 7/1/2001 date for the driver is simply the date of most of your WinXP files. Although many may be dated externally for newer SP2 and SP3 release dates, the internal date is still the earlier one. Think of these files as ones that Microsoft got right the first time!

You'll find that date on many of the basic function drivers in System resources. Like Floppy and Hard Drives, Keyboard, etc...

Even when you install chipset drivers which come with new motherboards, the basic function drivers remain with that 7/1/2001 date.
October 12, 2009 3:28:50 PM

Cool, yeah thought it might be...i'll leave it as is then. I tried clicking update driver with online search but all it did was find the Jmicron driver and install that again.

Well, sorted anywho. Cheers all. :) 
a b V Motherboard
October 12, 2009 5:58:59 PM

Yeah, there's something in Windows that won't let go of a driver once it's decided you need it. Often you have to Disable it rather than Delete to get rid of it. And I hate those ? marks and X's in the System.
!