Sign in with
Sign up | Sign in
Your question

Read speed limited to 20mbps? Sandisk SSD in HP 2710p

Last response: in Storage
Share
November 29, 2010 6:40:33 AM

I have just updated my hp 2710p with the following sdd drive:
sandisk uata 5000 pata zif 1.8" 64gb.

While i get expected write speeds (and good read/write values in 4k files operations), I'm getting only 20mbps speed in reading large files.

It seems like if it were limited anyway...

I have done a fresh windows 7 x64 install, and my SSD firmware is 0.63f

any help with this?

CrystalDiskMArk 3.0 results:
Read/write speed (MB/s)
Seq: 20.23 / 49.71
512k: 20.24 / 47.66
4k: 11.07 / 3.555
4k QD32: 12.50 / 3.791

a b α HP
a c 96 G Storage
November 29, 2010 11:17:51 AM

What SATA mode do you have set in your BIOS (IDE, AHCI, or RAID)? Also, are your chipset drivers up to date? I suggest you go to intel.com and download and then install the latest Intel chipset drivers for your flavor of Windows (x64). Don't just go with the generic Windows 7 drivers. Link is below:

http://downloadcenter.intel.com/
November 29, 2010 1:16:16 PM

COLGEK, 2710p uses PATA interface, not SATA.
It's running at ATA100 (although it's ATA133 capable).

I'm going to try the drivers you say from intel.com, althought I don't expect anything... I have tried this morning with windows xp and got same results that windows 7 x64.

I have read some of these disk are firmware limited to ATA33 (to save energy, although that's not the case, CrystalMark tell it's running at ATA100, and I get write speeds over ATA33 limit).

a b α HP
a c 96 G Storage
November 29, 2010 1:22:53 PM

Oops, I missed the PATA vs. SATA info in your first post. Regardless, going with the most current drivers won't do any harm (and could help). You can also check in your BIOS to see what IDE mode you are running in. You should be an a DMA mode and LBA, not sure what selections you have to chose from, but with OEMs and laptops (in general) your options tend to be very limited. Still you should be able to operate at the highest (least common denominator) speed that both your SSD and laptop can support. In your case, that should be ATA100.
November 29, 2010 5:10:16 PM

Got no luck with intel drivers.

Btw, can't view in BIOS what ide mode I'm using. It only let me chose LBA / bitshit.
I'm using LBA currently, altough I tried bitshift too.

Anyways, HD-Tune says I'm using UDMA mode 5.

This week i'll buy an usb enclosure so i can test the ssd in other computer...
a b α HP
a c 96 G Storage
November 29, 2010 6:11:44 PM

USB is not likely to show any improvement. You may simply be at the max your "older" system will support. Does HD-Tune indicate whether you are operating at ATA100 or not?
a c 415 G Storage
November 29, 2010 7:25:26 PM

Watch out for "PIO" mode with IDE-attached drives. If Task Manager (Ctrl-Shift-Esc) shows very high CPU time while you're doing disk I/O then that may be the culprit.
November 29, 2010 8:34:52 PM

Thanks, sminlal, although I've verified i'm not in PIO mode, and no PIO modes get 50mbps write speed.
November 29, 2010 8:38:40 PM

COLGeek, yes, HD Tune says I'm at ATA100.

With the USB enclosure, at least, I'll know if it's a "problem" of my laptop, or if it's of the SSD.

I've seen reviews of other 2710p with SSD getting 65mbps read speed, so I don't think it's matter of my laptop.
!