Core i7 2600k & World of Warcraft

Strange indeed, I got the 2600k and have been stress testing and playing games. Two things i noticed...

1. Even if i turn speedstep off and leave all the rest of the BIOS settings on default, the CPU still throttles to 1.6 GHz

2. When playing World of Warcraft on default BIOS settings, overclocked, speedstep on or off, it will ALWAYS throttle to 1.6 GHz and it stays that speed while in WOW, no matter what

Anyone having similar issues or am i missing something?
3 answers Last reply
More about core 2600k world warcraft
  1. yep, tried many different combinations and still no luck. Going to download and install all the latest chipset/BIOS drivers and such and flash the BIOS
  2. yeah, was thinking that myself, will try it out later when i get home...

    Ps. Other games were pushing my CPU to the Max 4.5 that i had set...
  3. So weird, updated to the latest BIOS on ASUS website, (the one with PLL addition) and still, I turn Speedstep off and it rocks 1.6 idle... Got some nice overclocks though, 4.8 @ 1.38 vcore and 66c temps max on a 6-hour run on prime 95 with no errors... Have not tested Warcraft yet since BIOS update/OC but i will check it out this weekend.
Ask a new question

Read More

CPUs Default World Of Warcraft Intel i7 BIOS Overclocking