Sign in with
Sign up | Sign in
Your question

HIS 4870 Artifacts with Pixel Shader 3

Last response: in Graphics & Displays
Share
May 13, 2009 2:15:00 AM

Hello everyone,

I have a HIS 4870 1 Gb card and I have been having some problems with it. This card seems to run every game pretty well, but once pixel shader 3 is involved there are problems. I recently picked up the game Darkfall and if I play it with pixel shader 3 EVERYTHING is messed up. Once I drop it down to pixed shader 2 everything is fine, but everything looks like 1990's graphics. I have the latest drivers to my knowledge and I've tried to fiddle with the settings in the CCC to no avail. Any help would be GREATLY appreciated!

Here is a picture with pixel shader 3 on:



Here is a picture with pixel shader 2 on:
May 13, 2009 3:26:39 AM

Those are not artifacts. I might be wrong but I think your issue will get fixed as you go and change the CCC > DTV > Pixel Format to RGB 4:4:4 Pixel Format PC Standard (Full RGB)
May 13, 2009 2:10:00 PM

Thank you for your reply, but I do not see a DTV section on my CCC screen.

Here is a picture of what I have available to me.
Related resources
May 13, 2009 2:18:28 PM

OK, I assumed you have a HDTV... I had a similar problem on my HDTV until I changed the Pixel Format...

Try going under Digital Panel (DVI) 3 and see if there is such an option as Pixel Format.
May 13, 2009 3:05:35 PM

I had the opposite problem with Oblivion. It was caused by the Asus programs that came with the card making the game detect my GPU wrong. It then selected the wrong shader package, which then game me a nice grey screen (though I could walk around and do stuff, just not see. Once I removed the Asus programs and reinstalled drivers, everything worked. I'm not sure if my scenario is in any way related to yours, but you could try reinstalling the drivers and the game or try older drivers (maybe 9.3) and see what happens.
May 13, 2009 6:27:50 PM

@ Euphoria_MK
I will give that a shot when I get home from work, I really hope that is the issue.

@EXT64
This problem has plagued me for many, many drivers. I just didn't play games to often and didn't care. I just installed new drivers last night and it didn't fix anything, sadly.
May 13, 2009 8:29:15 PM

Have you tried any other Pixel Shader 3 games?
May 13, 2009 8:45:32 PM

I'm still at work, but I did have this problem in Mirrors Edge, Mafia 2, Far Cry 2 and I think a few others. It seems to only happen when pixel shader 3 is used, otherwise everything is great.

I did play World of Warcraft with no problems along with Warhammer Online.

Thanks for the help so far though!
May 13, 2009 8:50:09 PM

Wow, that certainly is odd. Try the other suggestions first, but if Euphoria_MK's suggestions don't work and using driver cleaner to remove the drivers (then reinstall them, of course, and maybe reinstall the game as well) it may be best to try reinstalling windows. You could also try 3DMark 06 (the free version) as that does a Shader 2.0 test and a Shader 3.0 test and see if it glitches in that too.
May 13, 2009 11:53:27 PM

I am downloading 3dmark 06, I will reply with results when it is finished.

@Euphoria_MK

I don't have any options like that :/ 
May 14, 2009 1:36:13 AM

I just ran the 3dmark 06 and I did not get anything like I got in other games, everything ran fine.
May 14, 2009 2:07:49 AM

And I assume the other games still don't work, correct?
May 14, 2009 2:19:40 AM

Ya, I still get the bizarre spam of triangles.
May 14, 2009 11:14:31 PM

Anyone else have any suggestions?
May 15, 2009 1:10:22 AM

You might just need to do a full reinstall of windows. Something certainly seems messed up software wise. Before that though, you could try redownloading and installing Directx 9 and see if that helps. Also, you could post your dxdiag which could say something useful.
May 15, 2009 2:18:08 AM

Reinstall windows, and use your mobo drivers. That worked for me with the same problem i had with a 6600gt years ago and nothing else did.
May 15, 2009 2:25:24 AM

I just ran driver cleaner again and it has seem to fixed it!

But for some reason when I reinstalled the new drivers I don't have access to the CCC and it says in device manager that my driver version is 8.600.0.0 when it should be 9.4. Either way, the weird graphic thing has stopped, which is good.
May 15, 2009 11:47:26 AM

8.60 is 9.4. ATI's driver number version vs. package version is weird.
May 15, 2009 1:12:03 PM

Oh, ok. Well, I got everything up and running properly. To get the CCC to show I just downloaded the individual packages and installed them one at a time and it worked.

A big thanks to everyone for your help, it was greatly appreciated!
!