Sign in with
Sign up | Sign in
Your question

Toshiba RAM only showing 896MB of ram when I have 1.5GB

Last response: in Motherboards
Share
October 9, 2009 6:03:54 PM

The laptop i'm using is a Toshiba M70-CL3. Before it displayed 512MB of ram and after i installed a 1GB stick it only showed 896MB of RAM. I realize my graphics could be taking up the ram but it only says that it takes 128MB of ram. Yet there is no way to check/change the shared memory in the BIOS. I'm completely stumped as to what the problem could be any help would be great.
a b V Motherboard
October 9, 2009 7:16:36 PM

jason, I tried searching Toshiba's site for a M70-CL3 but can't find it. That doesn't make sense because they clearly have a M70 with CL1 CL2 & CL3 but none of those listed on their support site. So I'm in the dark here a bit. If you have a URL for official Toshiba support with specs and such, pls post it. Usually there are guides to how to open the case to reveal the slots, etc...

What specs I've found elsewhere seems that your model had 512MB as sold, and either a single 512MB module or a pair of 256MBs. Which did you have? All sources seem to agree that it has the capacity to have 2 1GB modules for a total of 2GBs system RAM.

Here's what I would try however. I assume you had a single 512 module to start with? And the 512 is still in the 1st slot and you addd the 1GB in the 2nd? If so, try swapping the modules. Or try using only the 1GB. See what differences that gives.

Where are you getting the 512 and 896 numbers from? The POST test, the BIOS? Within Windows?
October 28, 2009 4:21:38 PM

Same problem here. I added a 1GB stick to an existing 512 MB and all I see is 896, when I should be seeing 1408 (1536 - 128). I updated to the latest BIOS and tried swapped the modules. I also ran the modules individually and they both work.

jason101, did you manage to find a solution?
March 11, 2012 12:50:10 AM

To add to the confusion... I had 1x512 RAM & was ok. added another & got 1024ok, removed both & put 2x 1gb, won't boot. (error beeps) Remove 1 & replace with 512 (now 1500mb odd) says 896.
Was told BIOS upgrade needed. Got Bios V2.1. Disaster! Now no 1gb chips recognised in any mix or mode. So stuck with 2x512 as maximum.
How do I get the old BIOS back?? Or, what chip will it recognise?
Toshiba Satellite M70 (part no PSM73A-00F007)
Not relevant but running Win XP with no problems.
!