Solved

Booting from Areca Raid 5 - not finding the correct settings

I am wanting to boot from an Areca 1220 with a 3 drive Raid 5 as the boot volume but Windows 7 is not seeing the volume when it installs. I've booted from Raid 0 before, but using the onboard raid, this time i want to boot from the Areca add-in card. gigabyte said ll i have to do is set the first boot option to the add-in card, which i did, but no show. The boot options also show the volume that i want to boot from, and I have tried to set that as the first boot volume but it doesnt work either. i am using a GA-P35-DS3P. The only settings i am not sure of are the Onboard Raid/ACHI setting, which I assume is for onboard raid only, so i set that to ACHI .

Which setting should i use?

1. Hard disk boot priority
- bootable add-in card
- SCSI -1 (raid volume)

2. SATA RAID /AHCI mode
- disbaled
- raid
- AHCI

3. Onboard SATA/IDE Ctrl mode
- IDE
- AHCI
- Raid/IDE


thanks, roger
20 answers Last reply Best Answer
More about booting areca raid finding correct settings
  1. Have you loaded the Areca 'pre-load' driver? Win (any flavor) will not see anyone's RAID without them...
  2. you mean when Windows needs a driver to install to a raid volume? Yes. When no volumes show up during the windows install, I load the driver hoping that will let windows see the drive, but it does not. Previously when the raid volume showed up, I loaded the driver and was good to go.

    Or are you talking about a driver before i load windows? I saw nothing in the Areca manual.

    Since this is Windows 7/64 i am loading a gigabyte 64 bit driver that i downloaded from gigabyte.

    I dont suppose you can show me a link to such a driver?

    Since this is Windows 7 and not XP, I cant tell if the XP instuctions, to load a driver during windows pre-install, is the same driver needed during Windows 7 install.

    Are 2 drivers needed? An Areca drive and a Gigabyte driver?

    Found the Areaca driver and will try using it instead of the Gigabyte.
  3. You don't want the Gigabyte driver - it's for the MOBO's GSATA (jMicron) chip...

    "4.2.2.1 Installation Procedures
    The following detailed procedure installing the SATA RAID controller driver while installing Windows 2000/XP/2003/Vista. Have your bootable Microsoft Windows 2000/XP/2003/Vista CD and follow the required procedure below to install SATA RAID controller:
    1. Make sure you follow the instructions in Chapter 2 “Hardware Installation” to install the controller and connect the disk drives or enclosure.
    2. Start the system and then press Tab+F6 to access the McBIOS RAID manager. Use the McBIOS RAID manager to create the RAID set and volume set to which you will install Windows. {For details, see Chapter 3 “McBIOS RAID manager”. Once a volume set is created and confgured, continue with next step to install the operating system.}
    3. Insert the Windows setup CD and reboot the system to begin the Windows installation.
    4. Press F6 key as soon as the Windows screen shows ”Setup is Inspecting your Computer’s Hardware Confguration”. A message stating “Press F6 to Specify Third-party RAID Controller” will display during this time. This must be done or else the Windows installer will not prompt for the driver for from the SATA RAID controller and the driver diskette will not be recognized.
    5. The next screen will show: “Setup could not determine the type of one or more mass storage device installed in your system”. Selected “specify additional SCSI adapter” by pressing S.
    6. Window will prompt to place the “Manufacturer-supplied hardware support disk” into foppy drive A: Insert the SATA RAID series driver diskette in drive “A:” and press Enter key.
    7. Window will check the foppy; select the correct card and CPU type for your hardware from the listing and press Enter key to install it.
    8. After Windows scans the hardware and fnds the controller, it will display:
    “Setup will load support for the following Mass Storage devices:
    ARECA [Windows X86-64 Storport] SATA/SAS PCI RAID Controller (RAID6-Engine inside)”. Press Enter key to continue and copy the driver fles. From this point on, simply follow the Microsoft Windows installation procedure. Follow the on-screen instructions, responding as needed, to complete the installation.
    9. After the installation is completed, reboot the system to load the new drivers/operating system.
    10. See Chapter 5 in this manual to customize your RAID volume sets using McRAID storage manager."

    I placed the Win7x64 drivers here for you:
    http://www.mediafire.com/?jyoyf1mmxtg
    Just unzip the entire file to a floppy, if you have one (Win7 will automatically 'look' there), or a thumb drive (if you have no floppy drive - you will have to 'navigate' to it...), and you should be good for the install as above. The Win7 drivers are 'beta' at this point - no WHQL cert yet, but should be OK... Post back if you still have problems.

    Good luck!

    Bill
  4. Ummm - just realized Areca's write-up is more oriented (step 4) toward Xp - the screen you want in the seven installer is this one:

    click on the item in the red circle to load your drivers...
  5. hmmmmmm i would not recomend all this to an amateur at all

    raid 5 for a windows install?
  6. You have a point; here's a good example: there are board mods available for GB's X58 MOBOs that allow infinitely better OCing results, by allowing an increase in the PCIe frequency, which is somehow linked to the performance of the rest of the board - but they are hard to find, on the theory that if you don't know how to research well on the web, you probably shouldn't be taking a soldering iron to expensive SMT equipment!

    I was kind of boggled by this post - I just happened to have all the Areca docs, as I'm planning an (unsupported) WHS based on an i7 12G MOBO, with 7 of the 12 reserved as a RAM-disk for the swap file (as WHS is only x86 - no x64 available), a pair of RAID0 SSDs for the OS hung off the ICH10R, and a sixteen terabyte RAID6 array with two hot-spares - I have two versions of WHS (one from TechNet, the other the last beta), all the MS WHS docs and white-papers, as well as about sixteen pieces of documentation from Hitachi for the 2T DeskStar, which, so far, is looking good... I find it odd that someone would have a four hundred dollar plus RAID controller, and not really grasp 'what's up with it'?

    I would, however, definitely reccomend that the Areca RAID array not be used to boot Win7 - especially as the drivers are, at this point, 'beta' - should really be a storage array...
  7. I understand and can follow all of those directions, and have installed Vista on Raid 0 connected to the motherboard before but havent booted from a seperate raid card. And the card already has a Raid 5, 5 drive 2GB volume on it, so I am using the other 3 ports to create a bootable 3 drive Raid 5 volume. Why Raid 5? Because it is almost as fast as Raid 0 on this card but more reliable. Basic tests show My 2GB Raid 5 at a transfer rate of around 200-220mb/sec and my current OS with a single 10K 150 Raptor at around 80 mb/sec, I want to have the OS be as fast as the other raid volume.

    So back to my original question, what should steps 2 and 3 in the original post be set to?

    Thanks very much to bilbat for the info, I have downloaded the driver and will try again.
  8. This is where its not working. I have boot priority set to Bootable Add- In Card. I have SATA RAID /AHCI mode set to Raid and I have Onboard SATA/IDE Ctrl mode set to AHCI. When I get to the screen shown above, no volume is shown, and I load the Areca driver and the volume still does not show even if I refresh the driver list.
  9. I will go through the BIOS settings with you, but I need to know if you still have the RAID0, and where? Why don't you just give me a rundown of all the drives (including CD/DVDs) connected, and where to...
  10. Both raid volumes show up during boot, the 1872GB Raid 5 which is a data volume that I do not want to touch and the 279GB volume which will be used as the boot volume. both should show up as bootable volumes in windows, but neiher one are there. Existing Raid 5 1872GB data volume is on ports 1-5 of card and the new 279GB volume is ports 6-8 of the card.

    In the BIOS

    Hard disk boot priority

    1 SCSCI-1
    > 2 Bootable add in card
    3 SCSCI-0
    4 USB HDD0
    5 USB HDD1

    First boot device - CDROM
    2nd boot device HD

    SATA Raid/AHCI mode
    -disabled
    > -raid
    -ahci

    SATA port 0-3 native mode - disabled

    Onboard SATA device - enabled

    Onboard SATA/IDE controller mode
    -ide
    -ahci
    > -raid/ide
  11. So you have no hard drives plugged into the MOBO ports at all? Where is your DVD attached?
  12. "So you have no hard drives plugged into the MOBO ports at all? Where is your DVD attached?"

    not currently except the DVD which is SATA. I have 2 other inexpensive 4 port PCI raid cards that I am using as pass through as hot swap for individual drives, but the drives are unplugged, maybe i should remove those cards as well since windows is just not seeing the available raid volumes.
  13. I'm not sure if the the boot volume is visible only after the driver is loaded or if the volume shows up during windows installation and then the driver is loaded so that windows can be installed. Because the volume isn't showing up no matter what combination of settings I use. Maybe this MB cant do this, even though it shows up in the BIOS.

    Like i said, when I've booted from raid before, its always been from the motherboard and not a raid card the volume shows up during installation, I load the driver and then windows installs.
  14. Quote:
    I have 2 other inexpensive 4 port PCI raid cards that I am using as pass through as hot swap for individual drives, but the drives are unplugged, maybe i should remove those cards as well since windows is just not seeing the available raid volumes.

    Yes, indeed, remove those; I note also that you have USB drives in your boot order - remove those - GB's don't play well with USB boots in the long haul...
    Quote:
    I'm not sure if the the boot volume is visible only after the driver is loaded or if the volume shows up during windows installation and then the driver is loaded so that windows can be installed

    Depends on where the volume is - RAIDs on the Intel ports will show up as volumes before the drivers are loaded, but will not be accessible until the driver is loaded - for most RAID and SAS controllers, the volume(s) will not be visible until the driver is loaded during the install process...

    I'll get back to you in a half hour or so with the BIOS rundown - have quick task that's got to get done pronto!
  15. Best answer
    Quote:
    I have 2 other inexpensive 4 port PCI raid cards that I am using as pass through as hot swap for individual drives, but the drives are unplugged, maybe i should remove those cards as well since windows is just not seeing the available raid volumes.

    How many drives are you hot-swapping onto this thing at one time? Are you aware that all eight of your on board ports will support hot swap simply by enabling AHCI (and, once again, loading the requisite pre-install drivers)? It sounds like you have enough stuff hung on this thing to make it a real nightmare - for you, for the board's poor BIOS, and for the operating system... Pull those out for now, so what appears in the boot order is simplified, and like I said - lose the USBs - they're known problems. Remember Murphy's corollary to Moore's law - "you can have some of your crap running all the time, and you can have all of your crap running some of the time, but you can never have all of your crap running all the time!"

    In the BIOS (assuming your DVD is plugged into a yellow [ICH] port) -

    on the "Integrated Peripherals" page:
    "SATA RAID/AHCI Mode" to "Disabled"
    "SATA Port0-3 Native Mode" to "Enabled"
    "Legacy USB storage detect" to "Disabled"
    "Onboard SATA/IDE Device" to "Disabled"
    if you're not actually using the serial and parallel ports, disable these as well - no sense assigning unused interrupts...

    on the "Advanced BIOS Features" page:
    "First Boot Device" to "CD-ROM"
    "Second Boot Device" to "Hard Disk"
    "Hard Disk Boot Priority" to whatever it shows as, once you've gotten rid of the clutter...
    "HDD S.M.A.R.T. Capability" to "Disabled" (SMART qurying can foul up RAID card comms in some instances - and they don't work 'through' the board, anyway...)

    F10 to save and exit; follow the above procedure to load the OS drivers, after which your RAID volumes should appear on the OS' list...

    Good luck!

    (later on, we can figure out [whther or how] to get the rest of the stuff put back in...

    Bill
  16. those setting didnt work either. if there is only 1 driver to load, and its loaded during the installation, then its not working. the bios sees the volume, and why wouldnt it, it will see any volume created by the raid card. but windows isnt seeing the volume as a boot volume, with or without the driver.

    I just tried an earlier beta version of 7 and it worked with the driver, both volumes at first did not show, but after loading the driver they are there. :bounce:
  17. Excellent - that's just how it's supposed to work. I'd leave it alone for a bit, until the WHQL driver certification, which should take care of proper operation with 7RTM. If you'd like, you can email me at bilbat@wi.rr.com, so I have your email, and I'll send you the final drivers as soon as they are released. I think this little exchange has cost me, oh, $200+, as, while poking around at Areca, I see they have new cards that are not only based on the Intel IOP341 IOPs with the XScale cores, but will accept a 2 Gig SODIMM, in lieu of the 1 Gigs previously allowable, and they appear to scream with the 2 Gig installed :ouch: Now, if only Intel keeps up with their promises, and delivers Gulftown in Q2 as roadmapped!
  18. thanks again, it would probably have worked all along with the earlier beta.

    Now, about those hot swappable drives. The cards I use are Tekram TR-824 because they were the only ones I could find at the time that had x64 drivers and were true hot swappable, I want to be able to remove and insert a drive, and have the drive letter disappear and reappear, just like it does w/USB. Are you saying I can do that with this motherboard connection I don't need those cards to do that?
  19. now thats more like it. the benchmark for Raid 5 on the Areca was 150 MB/sec, not really a lot of gain over the 100 MB/sec I would have from the bios raid 0. So i redid windows with Raid 0, 3 drives on the Areca and its much better, average of 200 MB/sec.
  20. I get roughly 200 from each pair of RAID0 Velociraptors on an ICH9R - use one for systems, alternating one for swaps...
Ask a new question

Read More

Gigabyte NAS / RAID Boot Motherboards