Sign in with
Sign up | Sign in
Your question

Intermittent memory errors - the worst kind

Last response: in Memory
Share
October 14, 2009 7:17:27 PM

I was hoping someone could recommend some tests or methods to help me determine if the cause is the memory or the motherboard.

The machine will be fine for a few days, then I'll come home to it and find a black screen. The wireless keyboard does not wake it up (the LED on the USB fob does not flash as it normally does for keypresses and trackball movement) and I usually end up hard rebooting. Upon reboot, I go directly to memtest and the memory will fail. It usually passes all of test 1 and starts failing wildly in test 2 at which point I turn the power off, reseat the memory, reboot, go back to memtest to check it (all tests pass) and things will be fine again for a few days. Sometimes I have to reseat and/or trade the 2 modules multiple times before I get them to pass.

Because of the fact that the memory will pass memtest after reseating makes me feel that the issue must be with the motherboard along with the fact that I trust Corsair more than Jetway but how can I know for sure and how do I prove it to Jetway Support?

I do not have another motherboard to test the memory and I do not have additional memory sticks to test the motherboard.



Motherboard is -
JetWay JMA3-79GDG-LF AM3/AM2+/AM2

Memory is -
CORSAIR Dominator 2GB (2 x 1GB) 240-Pin DDR2 SDRAM TWIN2X2048-8500C5D
October 14, 2009 7:25:30 PM

Try with just 1 stick at a time and try different dimm sockets,

may be worth checking BIOS settings that memory is using correct timings - auto detect does tend to get it wrong.
a b } Memory
a b V Motherboard
October 14, 2009 8:50:06 PM

I also had an extremely intermittent memory problem that only showed up as verify errors with NTBackup. I was able to solve the problem by reducing the memory frequency.

The possibility of my precious data being corrupted while in memory but a scare into me and when I built my latest system I made sure it had ECC memory to try to head off these kinds of issues.
Related resources
October 19, 2009 12:45:42 PM

vibe said:
Try with just 1 stick at a time and try different dimm sockets,

may be worth checking BIOS settings that memory is using correct timings - auto detect does tend to get it wrong.



-- I tested all 4 combinations, one-at-a-time (dimm1/slot1, dimm1/slot2, dimm2/slot1, dimm2/slot2)
-- my test was to run through 3 full passes of memtest 86 (default settings) - all 4 combinations succeeded with no errors

-- I double-checked the timings and voltage for my memory 5-5-5-15 at 2.10V
-- sminlal: the stated frequency for the memory is 1066, but it is running at 800 due to motherboard limitation



Just prior to this testing, I had an issue that I have had once or twice before: errors in Windows - WinTV dying with a "we're sorry" error, ie crashing with same error - I restarted the machine and went straight into memtest - I got a few errors in test 1 this time and tons of errors in test 2. This time, I did not merely reseat the memory as I have done before (this usually corrects the problem) - this time I only removed dimm2 from slot2, left dimm1 in slot1, rebooted and ran memtest - no errors. Next time it happens, I plan to remove dimm1 from slot1 and run the test with dimm2/slot2 in place.

But this is the waiting (if it happens) scenario that I hate. There is a BIOS update available which I am planning to apply (tho I am wary about doing it during an extended testing session).

Anybody got anything?
a b } Memory
a b V Motherboard
October 21, 2009 6:17:41 AM

This is going to sound rediculous, looks like every time you reseat the chips contact is good, for a while. I suspect you might want to breadboard (remove from case) look for any possible short on metal? standoffs. I have seen a board mounted that was under just enough tension to cause flex at the contact points for the ram. You could also look for any contacts which arent retracting fully as compared with the others in the ram slots. No this isn't a technical response as it appears you're already proficient in that area. Yes the board should support 1066 and I would not update the bios from within windows so as to avoid any failure. Use the usb flash method or floppy method due to the problems you currently have. good luck
October 24, 2009 9:14:24 PM

I have this exact same problem. Except it's only on cold boots. Windows loads into a black screen after the "loading bar" completes.

Memtest shows no errors what so ever after 20+ passes. I've already tried switching out the motherboard. The same problem still occurs. I tried memtest on a cold boot before Windows loaded once, and every test gave an error - about 1,000 errors per second.

No idea what's going on and I still haven't found a fix.

Specs: (everything is stock, no OC)
Intel Core i5
Asus Radeon 5850
500gb 7200rpm Samsung Spinpoint
4gb GSkill 12800 RAM
650w Antec True Power New PSU
Vista Home Premium 64 bit

Here's my thread if you wanted to check into it: http://www.tomshardware.com/forum/273054-31-problems-bu...
!