Sign in with
Sign up | Sign in
Your question

Why can I only use 32-bit HPET on my 64-bit Win 7?

Last response: in Overclocking
Share
February 3, 2011 3:38:03 PM

I'm doing an overclock (first time I've done one) and I've discovered the HPET option, which I have a few questions about...

It's default settings are "enabled" and "32-bit mode". I'm using 64 bit Windows 7 so I figured it would make more sense to set it to 64-bit mode, but this seemed to destabilize my system and Windows failed to start. Any idea why?

Also, is it even an option that I should have enabled? Or more specifically, should I have it be enabled for an overclock? I've done a bit of research on it but couldn't find a definitive answer, which leads me to believe that it should probably be kept as enabled (default), but I'd like to be sure.

I'm using a GB p55a-ud4 motherboard and an i5 760 (will OC it to 3.6ghz), in case any of that is important.

More about : bit hpet bit win

a b K Overclocking
February 3, 2011 4:17:22 PM

I have heard people mention this problem before, though I have nearly the same setup and I think I have it in 64-bit mode. Do you have the most recent (stable) BIOS?
m
0
l
February 3, 2011 5:18:02 PM

Hmm I've gotten a bit further through the OC process and tried switching it to 64 bit and it worked. Quite odd, I'll take it though.

But on to my second question, is it even something that I want turned on?

And yeah I updated my BIOS a few days ago to F15.
m
0
l
!