Need help with new sata dvd writer

I recently bought a new sata dvd writer. I have gotten the Bios to see the drive but WinXp Sp3 still does not see the drive.
Asus model # DRW-24B1ST

Do I need driver for SATA drives? I have looked for drives but do not seem to find any.
Here is the specs of what I have.

Operating System Microsoft Windows XP Professional OS Service Pack 3
CPU Type P4 3000 MHz (3.75 x 800)
Motherboard Name MSI 865GM2-S / 865GVM-S
Motherboard Chipset Intel Springdale-G i865G
System Memory 1024 MB (DDR SDRAM)
BIOS Type Award (09/17/04)

Bios report:
80 GB Primary Master IDE
200 GB Secondary slave IDE
DVD Rom IDE Secondary master
Asus DVD writer Master SATA

I ran a report using Aida32 and it list the following
PCI Devices: Bus 0, Device 31, Function 2 Intel 82801EB ICH5 - Serial-ATA/150 IDE Controller

The bios recognizes all 4 drives. But when I look at "My Computer", the Asus dvd writer is not present or is it listed in the Device Manager.

WinXp is blind to its present.

Do I need a driver for it to see? I have looked and I can only find about a new install of winxp with sata driver nothing about separate installable drives. I have also gone to the Asus site but could not find any winxp drivers for sata drives.

There are no jumpers on the board or on the drive to change anything.

One other curious thing is while the bios is loading the dvd draw will open up but once winxp has fully loaded the draw will not open up. That is using the button on the front of the drive.

I have also tried the MSI site and Intel site to see if there are any driver , no luck there.

Any suggestions?
3 answers Last reply
More about need sata writer
  1. First, delete the upper and lower filters.
    http://support.microsoft.com/kb/982116

    If that doesn't fix it, run this Fixit scan.
    http://support.microsoft.com/gp/cd_dvd_drive_problems
  2. plus 1 for aford
  3. I was able to finally get the dvd to be recongized by both the Bios and Winxp.
    The setting were contained in bios but in to different places.

    The first and easiest was in sata set up section. However the harder and not so easy to find or figure out was under the Basic Bios setting.

    Where I had to change and Auto detect into NONE.
    Why this works I have no idea but it does.
    I was luck and came across a post from a guy who had the same problem and who solved it. I would never had thought to look into the Basic Bios section or know enough to change auto to none
    Thanks for the help.

    Ps. What does this mean???

    plus 1 for aford
Ask a new question

Read More

DVD Writers SATA BIOS Storage