Sign in with
Sign up | Sign in
Your question
Solved

Gigabyte P35 DS3P onboard lan only 10 Mbps

Last response: in Motherboards
Share
October 16, 2009 4:29:40 AM

Hi all,

my motherboard onboard lan is acting strangely (RTL8168B). when i test the port in the bios i only get 10 Mbps and a 250ft cable... i don't use a 250 ft cable.

when i boot into windows 7 the detected driver does not work (RTL8168B). When i use a legecy driver from Vista it works (RTL8168) it works, but only at 10 Mbps...

The only thing i have done new is install an SSD drive and then windows7. I was running Windows 7 before and it worked fine... is there i jumper on the bios i knocked out or something? seems very strange from just from last week...

Thanks!
October 17, 2009 5:05:51 AM

Thanks!

however i can;t access the website maybe because of the great chinese firewall. Any chance you can email to me? hok55@hotmail.com?
m
0
l
Related resources
a c 177 V Motherboard
October 17, 2009 3:21:44 PM

Done!
m
0
l
October 18, 2009 10:02:35 AM

thanks, but i tried this driver already. i tried most of the newer ones. and some old vista.. does this mean the board is on its way out?

Thanks.
m
0
l
a c 177 V Motherboard
October 18, 2009 5:14:56 PM

What are you basing your idea that it's not running gigahertz enet on? If it's just the BIOS diagnostic, I've yet to see that POC work right since I started using GBs... If your router or switch is 'saying so' (they usually have a 'bi-color' activity light - one color for 100MHz, another for GHz), it's likely right, but it, too, could be 'forcing' the on-board port to 100 - I've seen this a number of times... I'll zap you an 'in-windows' diagnostic app - give it a try and see what you get; also, might post what to and how your enet is hooked up - might suggest something, or give me a better basis to hunt for (likely) problems; my own grief in this direction was caused by really crappy firmware on my (Cisco - you'd think they'd know better!) primary router - it's still abysmal, but at least they got that problem fixed!
m
0
l
October 19, 2009 2:24:39 AM

Oh, that's right. I haven't mentioned my problems. My transfer rates over the network on this computer barely reach 1 MB/s. When i first installed windows 7, the driver installed, but the network card wouldn't work. IE it said it had no cable plugged in. then i used the old gigabyte driver for vista and it worked but only at 1MB/s and the network said only 10 Mbps. I tried all kinds of drivers to no avail. only the old original vista driver can work, while all others cannot detect the cable plugged in.

When the cable is plugged in with the newer drivers, it has lights blinking in the port. When I plug in my laptop to the same wire, it runs at 100Mbps and transfers at 25MB/s. so everything after the router and cable it fine.

So it is either the card, motherboard. I mentioned the bios level detection mainly, because it makes we assume the network card has gone south... but i;ve used some for years without incident...
m
0
l
October 19, 2009 2:24:59 AM

Btw, thanks very much for your help..
m
0
l
a c 177 V Motherboard
October 19, 2009 3:03:49 AM

I've a random idea - you might want to give it a try; enter your BIOS, do a <CTRL><F1>, and go to your "PnP/PCI Configurations" page - do you get some king of a PCI Timing, or PCI BusDelay setting? If so, try raising it 'one notch' (usually, I think, from 32 to 64 ps), save, exit, and reboot to test - if it's in your BIOS, it sometimes cures wierd bus timing issues like magic...
m
0
l
October 19, 2009 5:39:39 AM

ok thanks will give it a try...
m
0
l
October 21, 2009 2:40:58 AM

Well here is an update....

I tried the various things you mentioned Bilbat... btw thank you very much for the aid.
As i was rebooting trying to install different drivers, the card refused to get an IP... then i tried forcing the IP and it still refused to work. So I decided forget it and get a standalone PCI net card (TP-Link). I have a crossfire setup so i used the only avail slot which was the last slot. wow... wouldn't you know it... it didn;t work... the card's lights would flash, but the bios and windows7 wouldn't detect the card....

So I have one PCI slot that is covered by the 2nd GPU i took out the GPU and pu the new card into the 2nd last slot... - everything worked... it detects it as a REALTEK card though (are they OEM?)

so anyways... i have a great fully working network card at 100 Mbps with 25 MB/s transfer and my crossfire setup is useless now...

its an old board... about 2 years... but I don't think its time to upgrade with the issues of the foxconn cpuslots and with the 5870x2 .... sigh...
m
0
l

Best solution

a c 177 V Motherboard
October 21, 2009 1:45:51 PM

Had another 'random' thought... Are you overclocking at all? If you'll look at the "MB Intelligent Tweaker(M.I.T.)", you'll see an entry for "PCI Express Frequency (Mhz)", which defaults to "Auto". While the manual states "Auto sets the PCIe clock frequency to standard 100 MHz", this is not quite true. It would appear that in auto, this setting is taken from some kind of internal divider, and if the system clock is changed, it causes the PCIe frequency to vary, as well. On the socket 775 MOBOs, you always want to set this to "100" and not "Auto"; the LAN chip is 'hung off' the PCIe bus, and if the frequncy goes up, it is generally the first thing to suffer - either behaving erratically, or, 'dropping off the bus' completely. This is an issue for socket 1366/i7/X58 boards, as boosting the frequncy of the PCIe bus somewhat is, for no reason I've ever seen a physical explanation regarding, key to getting high, stable overclocks with these platforms - but - the LAN chip 'waves goodbye' somewhere slightly above 105 to 108, and, past 110 or 112, most video cards 'check out' as well. I occasionally see this problem when people 'bump up' this setting, thinking it will make their video card(s) faster, (which it doesn't - just adds to their instability), and manage to 'crank' something else off the bus...
Share
October 21, 2009 2:42:43 PM

ill add 2 cents worth. My W7 added a driver update (its not optional! it does this automatically), and then it renders the ethernet LAN utterly useless.

I finally figured out it was this update, so i set the W7 not to add this update. The driver from the motherboard installation disc is the only one that works for my gigabyte mobo (GA-EP45-UD3P).
m
0
l
October 22, 2009 3:19:11 PM


thank you both for the insight...

Bilbat - that sounds awfully logical... i will go home and try it... however i have been overclocked for over 2 years... but i do remember i had to reset the settings. Sounds like a try though...

Thanks again...
m
0
l
October 24, 2009 1:39:46 PM

Bilbat it worked!!! thanks!

i didn't remember to change it back i guess.. silly... but my video card is still crashing...

but thanks very much again!
m
0
l
!