Sign in with
Sign up | Sign in
Your question

BIOS/Windows sees 4gb out of 6gb

Last response: in Memory
Share
October 17, 2009 3:18:44 AM

Hi,

I'm having an issue with my ram/mobo. I've seen a post on this forum posted earlier in the year, but no solution.

I just built a new system with the following specs:

Windows XP PRO 64bit
CPU i7 920
EVGA E758-A1 3-Way SLI
XFX HD-587A-ZNF9 Radeon HD 5870
OCZ Gold 6GB (3 x 2GB)
******* CMPSU-750TX 750W
Sunbeam CR-CCTF 120 mm
Sunbeam CR-LGA1366 LGA 1366 Core I7 Socket Retention Bracket

The BIOS are at the default settings. I did not touch them. Upon boot up, going into the BIOS, it only sees 4GB of ram, same goes for Windows. When I test each one individually, both BIOS and Windows see 2gb fine. When I test 4GB, both also see them fine. When I test 6GB, the BIOS does see the 6gb, but when I boot to Windows, it's 4GB again. Another restart into BIOS right after, shows 4GB again.

Upon inserting all 6GB initially, the BIOS seems to see the 6GB. But when going into Windows and then back to the BIOS again, it seems to just go back to 4GB. But I can't seem to get it to see 6GB all the time. It's hit or miss.
a b } Memory
October 17, 2009 4:33:01 PM

How do you go into Windows and then back to the BIOS? Do you mean when you reboot?

Run MSConfig - then Boot.ini settings. Then Advanced. If there's a MaxMem value, remove it. Reboot.
m
0
l
October 17, 2009 7:30:46 PM

Yes, when I reboot. Most of the time I would see 6gb in Bios and Windows in a cold boot. Then I would reboot and Bios and Windows shows 4gb. CPUz always show 6gb.

The MaxMem value was unchecked.
m
0
l
Related resources
October 17, 2009 10:04:39 PM

are you running them at ?
8-8-8-24
Voltage 1.65V

any overclocks?

from a quick google that board seems to have issues with some memory. not your specifically though
m
0
l
October 18, 2009 12:02:21 AM

rand_79 said:
are you running them at ?
8-8-8-24
Voltage 1.65V

any overclocks?

from a quick google that board seems to have issues with some memory. not your specifically though

He said he did not touch bios so he did not overclock
m
0
l
October 18, 2009 2:33:22 AM

any chance you could try windows 7 or vista and see it if works?

xp 64 is a crappile sometimes.
m
0
l
a b } Memory
October 18, 2009 3:35:12 AM

Regardless, the OS is not going to make the BIOS show less RAM.

You need to post the part# of your RAM and what speed it is.

Go into the BIOS and set the DRAM voltage to 1.65V.
m
0
l
October 18, 2009 3:38:43 AM

Hi, just updating my tests so far on trying to resolve this issue.

Ran memtest for each stick: no errors
Ran memtest for two sticks/all combinations: no errors
Ran memtest for three sticks: 100+ errors, 2 passes

Tested all three sticks on a Asus P6T Deluxe board: Bios/Windows sees 4gb, CPUz sees 6gb, so same problem.

Reseated the CPU, no bent pins.

I've set the memory timing and power settings, as recommended by ocz. Everything else is on auto. But personally I feel that even if the memory was at factory settings and underperforming, the Bios and Windows should still see 6gb with no problem.

So bad ram? Even though all three showed no errors individually.

Bad cpu memory controller?

Is it time to RMA? and which would be the likely culprit to RMA first? Or other suggestions and thoughts would be great. Thanks.
m
0
l
a b } Memory
October 18, 2009 3:48:39 AM

If I was going to RMA... RMA the memory but buy new RAM at the same time. Don't wait for them to receive your old, do the paperwork and send replacement. The time left to RMA the MB might expire. Eat the restocking fee to save time.

What voltage did OCZ recommend? The speed and timing doesn't matter, won't keep BIOS from seeing modules. Neither should voltage really on 3 sticks.

What is the model # of RAM?
m
0
l
October 18, 2009 3:58:46 AM

Ram model #OCZ3G1600LV6GK

Recommended voltage: 1.65v

Yeah, I'll probably just return the ram at newegg and maybe buy a different brand. Any recommendations around the same price/performance? Is Gskill good?

At this point, I don't think it would be the board, since my Evga board and my Asus test board both showed 4gb. I would RMA the CPU next most likely.
m
0
l
a b } Memory
October 18, 2009 1:44:41 PM

I've been impressed with many of G.Skill's modules and tend to recommend them. In addition, they make what I think is likely the best 1333 module around, but NewEgg doesn't have them in the 3x2GB kit. That's this one, with only 1.5V and CL=7
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Of the 3x2 kits, look at this one:
http://www.newegg.com/Product/Product.aspx?Item=N82E168...
and the ones on this page
http://www.newegg.com/Product/ProductList.aspx?Submit=E...

Because of what I read, I think most are better off with lower voltage 1333 RAM even in high-end i7 builds. 1600 RAM doesn't give you any performance edge really and 1.5V RAM is the newest and best out there. Those rated at 1.65V might be just on the edge of qualifying under Intel's specs for the i5/i7 and really need more voltage to work well. To read about RAM speeds vs good latency try this article, skip to the Conclusions if you want.
http://www.tomshardware.com/reviews/memory-scaling-i7,2...

If you've got a close-fitting cooler/fan for the CPU, look carefully at how tall the RAM is. I have G.Skill's tallest "Pi" RAM which fits under my cooler but wouldn't work for everyone.

One thing you might try before sending it off is with the DRAM voltage set to 1.7V.
m
0
l
October 19, 2009 6:03:46 PM

Thanks. I will take a look at those rams. Someone also recommended Corsair.

I will try the DRAM voltage at 1.7v. But would that be too high, as I've read that anything above 1.65v would be putting your cpu or ram at risk.
m
0
l
a b } Memory
October 19, 2009 9:16:46 PM

Nothing will be damaged at 1.7V. If it requires 1.65V, then it's often necessary to go to 1.7V to get the right timing from the RAM. That's the basic problem of having memory that NEEDS the 1.65V to start with. Certainly if you have 6 (or 4) modules installed, you're going to need some extra voltage.

Nothing jumps out at me as being particularly attractive about the Corsair XMS models of DDR3. All require 1.65V except for 1 model, and it has lousy timings.

Anyway, let us know if any new RAM works - and don't forget ticking clock for RMA'ing the motherboard if needed.
m
0
l
October 22, 2009 2:32:21 PM

Update: Picked up the Corsair XMS3 6GB TR3X6G1600C9

Initially, when sticks went in, 4gb again. Then another cold boot, 6gb. Then every restart after that shows 6gb so far, without setting power/timings. Set the XMP profile. Tested the memory/system with Memtest, Occt, Prime95, 3dmark03, and Sisoftware Sandra. All results passed with no errors. This took about a full day and a half.

Then I tried to shutdown the computer and turned off the PSU. Waited a few minutes. Turned the PSU back on. And as soon as the light went on, on the mobo, I pressed the power button. And then upon boot, back to 4gb. Another cold boot would bring it back to 6gb.

So right now, it would seem like the situation is reversed.

With the OCZ golds, I would get 6gb sometimes on initial cold boots, with and without setting timings. And then restarts would ALWAYS show 4gb again. And of course, memtest saw 6gb but had errors.

With the Corsairs, I would now get 6gb about 70% of the time upon cold boots and once bios/windows sees 6gb, restarts always show 6gb. And when I turn off the PSU and then back on, then power on right after, it would be 4gb. But if I wait a few minutes first, after I've turned the PSU back on, then power on, 70% of the time it would be 6gb. Also, turning off the computer at night, then powering it on the next morning would show 4gb, but a second cold boot would bring it back to 6gb again.

So I tried setting the voltage. Dimm: 1.7 (from 1.65) QPI: 1.4 (from 1.35) I know Intel specs say anything more than 1.65 might damage the integrated memory controller, but I've seen people post much higher voltages than these. I hope that it would be fine. Tested this for about 10 hours. Cold boots, restarts, and turning on/off PSU would yield 6gb all the time, at least that I can remember. There's been so many tests. So basically at this point, I'm feeling pretty confident with the system.

Woke up this morning, boot up the computer, back to 4gb. Windows locked up. Another cold boot, and back to 6gb. Haven't tested it more after that yet. So right now, I'm guessing that the system is 'pretty' stable, except sometimes from cold boots it would have trouble powering the 6gbs maybe?

So a definite improvement with the Corsairs. At this point, with all the testing, should I still be thinking about changing any hardware? (Haven't changed the CPU or PSU) Is this occurrence which happens much less often now, normal/expected/tolerable? I assume I can increase the voltages more.

The RMA window is closing in. Thoughts and suggestions please. Thanks.
m
0
l
a b } Memory
October 22, 2009 5:26:31 PM

When you say 6GBs or 4GBs, we're still talking the actual POST or BIOS message, before Windows begins starting???

If so, if that number isn't stable, I'd RMA the motherboard. And I'd likely eat the restocking fee and try a different brand or model too. You just shouldn't ever have that problem.

A couple things to try first perhaps. We didn't seem to cover checking the BIOS version or updating it. I show a version SZ2SBIOS Date :10/06/2009 on the website. Several of the previous updates mention fixes to the BCLK Bootup - might pertain to you.

In addition, they have a forum, might be worth a shot.

Also, in one of the Mfg responses to a poor review of this board at NewEgg (and those happen with all boards) the Mfg Rep listed his name and email addr and invited a email. Might try this and reference this forum thread in the email for faster explanation. (Plus he might comment and tell me what mistakes we made in advice!)
Quote:
Thank you for the review. I apologize about the issues you are experiencing with your EVGA product. Please email your product details so that we can look into ways to better support you. My email address is ksabine@evga.com.
Thank you,
Kyle Sabine


BIOS updates here:
http://www.evga.com/Support/Drivers/default.asp?switch=...
MB main page here:
http://www.evga.com/products/moreinfo.asp?pn=132-BL-E75...
m
0
l
October 22, 2009 6:28:48 PM

Hi Mongox,

Thanks for your reply.

Yes, for my problem, the issue shows incorrect ram in Bios and Windows, but not CPUz.

With my original ram(OCZ Golds), my Evga board and a new Asus test board both had problems showing the full 6gb. So I assume that the board is fine then. Switching to the new ram along with some voltage settings seems to have fix the issue, except the one I posted earlier.

Unfortunately, updating the BIOS was one of things I've already tried when I was testing the OCZ golds. I've also posted this issue in the EVGA forums.

Now for the most part, it would seem that my system is almost 100% stable and might just require some minor voltage changes. But long term it might start happening again, but that's out of my hands. At this point, I'm not sure what else to test next or even should.
m
0
l
a b } Memory
October 23, 2009 2:59:08 AM

Well, not knowing how much RAM you'll have on the next boot isn't stable. And it's not something any user should have to worry about.

If it was my problem, I'd return the MB.
m
0
l
October 23, 2009 1:26:23 PM

But the OCZ golds had problems for both test mobos. You still think that's the problem?
m
0
l
October 23, 2009 9:47:35 PM

I was experiencing the same issue on Windows7. I checked my motherboard manual and I had one chip in the wrong dimm slot for tri channel support.
Vista read the 6gb and never said 4gb usable so I didn't realize there was an issue til I upgraded.
Once I noticed the issue though, it also read 4gb in the bios and a bios upgrade did nothing.
I wouldn't suspect you have a bad mobo but it happens. If you've tested each chip individually with some memory test for an extended amount of time - more than 30 minutes per stick or until it gives you a prompt that it passed.
Also, with your boot deal changing the amount of usable ram - consider a bad power supply, especially since you had the same problem with totally different ram.
Just is just from my experience but I hope it helps someone. I had the same OCZ ram but an ex45-ud3r with a i7 920.
m
0
l
October 30, 2009 5:34:09 PM

Update: I've RMAed the motherboard. Basically same issue as my previous post.

After changing to new rams, the 4gb/6gb issue only appeared from cold boots. So I increased the dimm and cpu vtt voltages. For the most part after the increase, 6gb is recognized from restarts and SOME cold boots. The mobo replacement had no improvement.

To try to fix the cold boot issue, I increased the dimm to 1.725 and cpu vtt to +300mv. This appeared to 'fix' the problem. To test this, I would wait 10-30 minutes in between cold boots, and as far as I can remember, the system would see all 6gb. So as long as the voltage levels don't damage my system in the long run, then I can live with these settings I suppose. BUT...

For cold boots that are farther apart, say turn off at night and turn on in the morning, my system would get to the logon screen and freeze, and then restart over and over. Another cold boot would stabilize the system again. When logged in, I get a message saying that my system could not recover the registry hive.

So at this point, having replaced the ram and the motherboard, this cold boot/freezing issue is either voltage settings or a CPU that seems to need alot more power to see all 6gb properly. And this would happen more likely when the time frame between cold boots are longer.

I really don't like setting the voltages that high, when I'm not even overclocking. But I've been told that some memory might require higher volts. Increasing the voltages seems to help the 4gb/6gb issue, and maybe increasing them even further might fix the 'cold boot 4gb/6gb' issue. But should I have to go that high for a system that is not overclocking and could that increase be the cause of the freezes/restarts.

Should I just rma the cpu?

Btw, for the voltage settings in the BIOS, EVGA has the increments color coded, gray, green and red. Are the greens the recommended levels? What do those colors mean?

Thanks.
m
0
l
a b } Memory
October 30, 2009 10:10:30 PM

I'd make sure you have the RAM in the right slots - I was surprised when I read back over the posts that no one ever mentioned that - including me! Even if you have them right, we should have asked or pointed out the slot positions.

I don't like having the RAM voltage up that high either, which is why I strongly recommended lower voltage RAM. RAM rated at 1.65V is might be under-rated just to qualify as "Intel Approved" and may really need 1.70-1.75V - sounds like yours does. Lower voltage RAM means higher quality and newer design.

I'm not up on Intel CPU voltage settings and can't really make suggestions.

Generally, the color-coding in BIOS is: grayed out means you can't change it, green means it's auto or acceptable, orange/red means your setting is outside normal recommendations but is OK if you have a good reason to do so. I'm guessing your RAM voltage setting is in red?

m
0
l
December 14, 2009 1:58:52 AM

I saw where you have not modified your BIOS. If your BIOS is like mine and you are trying to run in the 64bit mode, then you need to modify the BIOS and set the HPET to 64bits. 32bits can't read past 4GB.

Also, you might try reseating your memory strips. It can't hurt and it might fix your problem. It did mine.
m
0
l
May 30, 2012 10:39:38 PM

I had the same problem and I resolved it just 5 minutes ago.

I did multiple things at once therefore I don't know which option could help you.

I changed the HPET as Gandalf replied but it didn't help me.

So, I too a closer look at the motherboard's pins and corrected some I thought were out of the line. Then I looked at the pins under the CPU and I have seen one which was leaning a little bit so I corrected that one as well. I tried to remove any dust located at the motherboard, especially near RAM modules.

Then I set up PC again and voila, it worked !!!

Hope some of this helps you ;) 
m
0
l
!