Sign in with
Sign up | Sign in
Your question
Solved

P55-UD3R: Can't install Win7 "CD/DVD drive device driver missing"

Last response: in Motherboards
Share
October 18, 2009 2:15:23 AM

I just replaced my Athlon X2-based system with a new Core i5 750 and GA-P55-UD3R motherboard. I was able to boot into the existing 32-bit Windows 7 RTM install without any problems, it automatically got the drivers and everything works. However, when I try to install the 64-bit version of Windows 7, I get this error (after pressing Install Now on the first dialog that comes up):

"A required CD/DVD drive device driver is missing"

I put in the disc that came with the motherboard but the installer claims there are no compatible drivers. I thought this could be due to my old IDE DVD burner so I physically disconnected the drive from the motherboard and attempted to install the OS from a USB stick. While significantly faster than the DVD, this method still gives me the error. It won't let me install the OS without this driver.

Any ideas? Has anyone been able to install the RTM on this motherboard?

edit: I tried my 32-bit disc and it did not give me the error, so it's possible my download of the 64-bit .iso was corrupted somehow. I got it from MSDN but it was interrupted at one point by a power outage. The downloader program that Microsoft makes us use allowed me to resume and reported no problems. I will try downloading another copy of the .iso.

Best solution

a c 177 V Motherboard
October 18, 2009 3:06:46 AM

I think you found your own trouble - I'm laughing because the exact same thing happened to me - only with a TechNet copy of one of the servers... Had a buffer overrun crash, and, much to my amazement, the downloader picked right back up when I restarted; burned the iso and went to install it, and it blue screened. Didn't think much of it, tried again, same crash. Wiped the partition again, and installed Win7 to it to check the machine - fine! Wipe again, server install, BSOD! Thought "must've gotten a bad burn", burned the iso again - same thing! Finally thought to re-download, installed perfectly! You'd think, as sophisticated as the MS downloader looks, it'd catch the problem when it 'final copies' the file - find a CRC error or something, or that the iso burner likewise would 'see' some kind of structural deficiency, but, NO, you gotta dink around for four hours... :kaola: 
Share
Related resources
!