Sign in with
Sign up | Sign in
Your question

Can't access hard drive in Rosewill RX-DU300 hub

Last response: in Storage
Share
December 16, 2010 12:12:49 AM

I installed the latest drivers and firmware for my ASUS U3S6 card. Hooked up the Rosewill hub and the drivers installed automatically for that. When I inserted my hard drive, it installed the drivers for that as well, but the drive is not showing up under my computer. It's not under Disk Management either, the only place I see the drive listed is under Disk Drives in my Device Manager. I tried updating the drivers but it says it already has the latest. When I unplug the Rosewill hub, the drive disappears from my Disk Drive list. I'm not sure what else to try, any suggestions?
December 17, 2010 5:21:43 PM

I plugged the hard drive dock into a USB 2.0 port and go the same results, can only see the drive under Device Manager. I also tried plugging a USB 2.0 device into the USB 3.0 port and it worked fine. So, the problem is definitely with the hard drive dock. I e-mailed Rosewill customer service about my problem and here is there response:

Quote:
Right now the Dock itself is functioning because you can see the drive attached to it in Device Manager.
The issue that you are experiencing seems to be related to a setting in Windows 7.

You may wish to contact Microsoft support for assistance beyond these next few brief troubleshooting steps.


~ When the Drive in this Dock unit shows up in Device manager, right click the Drive listing and click into "Properties".
~ Click the "Volumes" tab and click the "Populate" Button. Click OK.

~ Right Click the Drive listing again and this time click into "Update Drivers Software..." and allow Windows to search for the best driver.

~ Finally, go into Disk management and click the "Action" tab. Select Rescan Disks.

Refresh Disk management Window and check for the drive appearing in Disk mangement.


There may be an IRQ addressing conflict in the OS.
By running the Drive through the ASUS USB 3 card the card AND the HDD may be having this IRQ conflict. You should seek assistance from ASUS for this possibility.


Populating the volumes didn't work, I got an error message that said "this volume can not be populated" or something like that.

Had already tried updating the drivers, but did again, no change, still has the latest.

Rescanning the disks in disk management didn't change anything either.

Not sure what an IRQ addressing conflict is.

Guess I'll start talking to ASUS, but if anybody here thinks of anything to try, let me know.
m
0
l
December 21, 2010 4:14:48 PM

Any help?
m
0
l
!