Sign in with
Sign up | Sign in
Your question

2TB hard drive showing as 128gb

Last response: in Storage
Share
December 16, 2010 9:28:14 AM

I just got a Western Digital Caviar Green WD20EARS 2TB 64MB Cache SATA 3.0Gb/s 3.5" and it is showing up as only 128GB in disk management (after formatting as well). I've never had this problem before, I have a 350GB drive connected to this same computer and its the right size and everything.

To make sure it wasn't windows I booted into ubuntu and it says the same thing.

I'm running windows 7 and my motherboard is a gigabyte ga-p35-ds3l with a dual core EE6600
a c 371 G Storage
December 16, 2010 11:00:31 AM

What size does it show in the bios? If it shows wrong there too, it may be defective.
m
0
l
December 16, 2010 6:56:56 PM

Ah, didnt realize I could check the size in the bios. It shows it as 137GB, its defective then?
m
0
l
Related resources
a c 371 G Storage
December 17, 2010 10:43:26 AM

Seems odd that it would show 137Gb. It looks as if your bios doesn't support LBA48 - drives larger than 137G. Is your 350G drive partitioned? I checked the WD20EARS specs and I didn't notice any jumpers that could limit it's size.

Anyhow, your motherboard and your OS need to support LBA48 to support large drives. Windows 7 definately supports this which makes me think it's your motherboard, but you said you already have a 350G drive in it. That is why I asked if your 350G drive is partitioned.

If your board doesn't support LBA48, their may be a newer bios out for it that will fix the problem.
m
0
l
a c 127 G Storage
December 17, 2010 12:54:34 PM

Windows XP RTM does not support disks larger than 128GiB (or 137GB).

You need Windows XP Service Pack1 to use HDDs larger than 128GiB. Windows XP is not recommended in combination with 4K sector drives like the WD20EARS; i recommend to upgrade to at least Vista SP1, and preferably Windows 7.

Do not use the jumper on the HDDs; never use that jumper. If you want to fix the slow speeds, you would want a partition alignment utility, GParted/MagicParted can do this; Windows 7 / Vista can do too.
m
0
l
a c 371 G Storage
December 17, 2010 12:56:55 PM

sub mesa said:
Windows XP RTM does not support disks larger than 128GiB (or 137GB).

You need Windows XP Service Pack1 to use HDDs larger than 128GiB. Windows XP is not recommended in combination with 4K sector drives like the WD20EARS; i recommend to upgrade to at least Vista SP1, and preferably Windows 7.

Do not use the jumper on the HDDs; never use that jumper. If you want to fix the slow speeds, you would want a partition alignment utility, GParted/MagicParted can do this; Windows 7 / Vista can do too.


The OP says he's using windows 7 and currently has a 350G drive working.
m
0
l
a c 127 G Storage
December 17, 2010 7:45:21 PM

Sorry i should have read better.

This is kind of odd though; you could check with AS SSD which storage driver you use and try others, and switching between IDE/AHCI mode in BIOS may be worthwhile, but i'm just guessing here.

If you got a 300GB drive working then 48-bit LBA should be working. The suggestion offered to try BIOS update may be helpful. Did you connect this disk to chipset SATA controller or third party controller?
m
0
l
a b G Storage
December 17, 2010 8:12:41 PM

Are you using BIOS Version F7 or later? In Version F7 they fixed a problem with hard disk drive size detection on some 1TB drives about 3 years ago.
m
0
l
a c 87 G Storage
December 17, 2010 9:12:02 PM

You should download the Western Digital diagnostic software and run a full test.

My full recommendation would be:
1) Write ZEROS to (WD zero erase) which removes all traces of a file structure
2) Format (NTFS)
3) Checkdisk in Windows (check both options). The one option confirms the File Table you just made is intact and the second option reads and writes to every location and builds a BAD SECTOR table (so it won't even try to write to any bad sectors if you have any).

Once that's done I'd still go back and run the Extended test from Western Digital. (18 hours for 2TB via USB. Probably 2-3x faster via SATA)
m
0
l
a c 371 G Storage
December 18, 2010 2:20:08 PM

ko888 said:
Are you using BIOS Version F7 or later? In Version F7 they fixed a problem with hard disk drive size detection on some 1TB drives about 3 years ago.



This is good to know. This is why I suggested a bios update also.
m
0
l
!