Sign in with
Sign up | Sign in
Your question

ATI Catalyst 9.5 Driver: Performance Express-Test

Last response: in Graphics & Displays
Share
May 22, 2009 9:17:47 AM

There u go :) 
http://xbitlabs.com/articles/video/display/catalyst-9-5...

"We didn’t detect any serious performance drops on transition from Catalyst 9.4 to Catalyst 9.5. The only exception is a 4% drop Radeon HD 4770 showed in BattleForge game in 1280x1024 resolution. Therefore, we have every reason to recommend all owners of contemporary ATI Radeon HD 4000 graphics cards to upgrade to the new Catalyst 9.5 driver."
May 22, 2009 9:57:21 AM

Maziar said:
There u go :) 
http://xbitlabs.com/articles/video/display/catalyst-9-5...

"We didn’t detect any serious performance drops on transition from Catalyst 9.4 to Catalyst 9.5. The only exception is a 4% drop Radeon HD 4770 showed in BattleForge game in 1280x1024 resolution. Therefore, we have every reason to recommend all owners of contemporary ATI Radeon HD 4000 graphics cards to upgrade to the new Catalyst 9.5 driver."


I had issues with win 7 rc. Haven't fixed it yet, will probably drop back to 9.3. XP sp3 x32, no issues so far, but haven't run my usual test suite yet. Vista ultimate x64, so far no issues. Still a few tests to run. As to performance, meh.... 9.3 was a great release. No release since then has shown me much.
May 22, 2009 11:48:57 AM

What issue do u have ? i'm running Win7 RC X64 with Cat 9.5 and i have no issues so far.
Related resources
May 22, 2009 12:48:53 PM

Hi Maziar,
I have a bit of an issue with this statement,
"We didn’t detect any serious performance drops on transition from Catalyst 9.4 to Catalyst 9.5. The only exception is a 4% drop Radeon HD 4770 showed in BattleForge game in 1280x1024 resolution."
I realise its taken from a review and it isnt you posting it, however for everyones information the 9.4 didnt even support the 4770 so how they can test a differance is beyond me. Untill these 9.5 drivers were released the drivers on the disc that came with the card were the only drivers worked.
There were some W7 drivers that were rushed out but i wouldnt think they tested on W7 did they ?

Mactronix
May 22, 2009 9:53:38 PM

Maziar said:
What issue do u have ? i'm running Win7 RC X64 with Cat 9.5 and i have no issues so far.


Just didn't install properly on my set-up. I'll now have to do a manual uninstall, I suppose. Had similar issues with 9.4 on both Vista x64 and win7 beta, never tried 9.4 again on win7 RC.
May 23, 2009 9:06:50 AM

mactronix said:
Hi Maziar,
I have a bit of an issue with this statement,
"We didn’t detect any serious performance drops on transition from Catalyst 9.4 to Catalyst 9.5. The only exception is a 4% drop Radeon HD 4770 showed in BattleForge game in 1280x1024 resolution."
I realise its taken from a review and it isnt you posting it, however for everyones information the 9.4 didnt even support the 4770 so how they can test a differance is beyond me. Untill these 9.5 drivers were released the drivers on the disc that came with the card were the only drivers worked.
There were some W7 drivers that were rushed out but i wouldnt think they tested on W7 did they ?

Mactronix


Sorry mac, i didnt get what you are saying.
That statement is from xbitlabs site and they tested with
VISTA ULTIMATE 64 SP1,also Cat 9.5 supprts HD 4770 doesnt it.
May 23, 2009 9:20:13 AM

Hi Maziar,
yes the 9.5 supports the 4770 but the 9.4 didnt. So i dont see how they can measure a 4% drop between the two sets of drivers.
Mactronix
May 23, 2009 11:26:46 AM

Maybe it was some kind of hotfix drivers(based on 9.4) that where out for the 4770?
May 23, 2009 12:23:38 PM

Some of the reviewers were left with what was on the disc and some were given a "Press release driver" It was these drivers that lead me to beleive there would be performance gains for the 4770 with the release of the 9.5 drivers. This was based on the test performance of the card vs what i expected from the reviews and my own knowlegde of my system. Unfortunatly it hasnt happened that way :( 

Mactronix
May 23, 2009 7:45:03 PM

Hey mac :)  yeah you are right,hmm thats strange how come did they test when 9.4 didnt support HD 4770.

Hey nuke ;)  long time no see :D 
I dont think we have a hotfix for 9.4,i googled and found that we have a 9.4 hotfix for APG cards ,the other thing that i found was this:
http://support.amd.com/us/kbarticles/Pages/GPU-6-Hotfix...

Maybe they tested with that ?
May 24, 2009 4:26:21 AM

Not sure, but they had to test with something. Since i do not have a 4770, i can not see if that works.

Does list

* ATI Radeon™ HD 4000 Series <-maybe it would work
* ATI Radeon™ HD 3000 Series
* ATI Radeon™ HD 2000 Series

Yeah Maziar, long time indeed. I am not on here as much anymore.
!