Can't Acquire or Install Correct NIC Drivers, GA-EX58-UD5

I got the GA-EX58-UD5 motherboard, testing it with Win Xp and now Win 7, and so far everything looks okay... but in both OS's I can't connect to the local network. Indeed, the Ethernet cable is connected at both ends. BIOS has the onboard LAN chips enabled, and weirdly, the disc that came with the mobo doesn't have the relative drivers for XP, but it does for Vista however they're not in the installation interface -- I have to sift through Explorer to find them and even then they still don't work.

The mobo is specified as such:
# 2 x Realtek 8111D chips (10/100/1000 Mbit)

I went to Realtek and downloaded both Vista and Non-Vista drivers for the purposes of trying just about anything that will work... what comes close is the Vista version, naturally.

During the installation of the 8111D driver I acquired, I got a "FindFile failed" error towards the end of the installation (for Win 7). Whether it's on the CD or from the mirror I got it from, the name of the file is something akin to Realtek_8111, but when I go to install it, the installation window says "Welcome to the Realtek 8169 8168 8101E 8102E Ethernet Driver Setup...." making me think it's not the correct one or it would include 8111.. no?

I really don't want to have to purchase a PCI NIC card, but all the drivers I see available are for PCI only, NOT onboard chips... what gives? I installed the PCI NIC drivers, but they ask me to shut down my system and insert the relative card - which I don't have, nor should I need. I did though put in an older NIC card that can't be used in this system since it's too big taking up what another card is already doing... so I'd have to get a PCIE_4_1 or 8_1 sized NIC card if I can't get these onboard adapters to function... the card that I just now put in does enable me to connect to the network... any ideas why the built-in adapters are not allowing me to connect?

Any pointers?
9 answers Last reply
More about acquire install correct drivers ex58
  1. Did you try to upgrade the drivers and manually select the folder where they can be found, e.g., 64? I ran into that issue today on a different motherboard and that's how I resolved the issue. You downloaded the Windows XP and Windows 7 drivers from
  2. Yes on both accords. That's what I alluded to when I said I sifted through Explorer to find them... they didn't show up on the autorun software that Gigabyte gave (CD) with the mobo. Realtek only works for the PCI-E card, not the onboard chips... which is severely unfortunate... Seeing as it doesn't matter if it's XP or 7, I can't see OS being the problem.
  3. The onboard chip is PCI-E. How are you installing the drivers? Using Setup.exe might not work, but updating the drivers from Device Manager should. Right click the controller, click Update Driver and select the location where you extracted the drivers. I did that for Win 7 (different motherboard, but the same onboard chip) and it worked fine.
  4. Realtek's site says that the 8111D chips use the RTL8169/8110 Family PCI drivers... so I went into Device Manager: had it browse the Internet for drivers, which it did and reported back that my drivers are up to date; I then proceeded to use the other option (Browse my computer manually) but after routing it to the CD which contains the Gigabyte network drivers, it couldn't find them.... I gave up....

    So I went to install a new card that I recently ordered, PCI-E_x1 sized, which was $15 from newegg, but before that I tried the onboard chips again, plugged in the ethernet to the appropriate ports, took out the older NIC card, I think it's PCI x16 in size, which I can't use due to its size... so with no NIC cards in, I tried the onboard chips and wala! They work... I don't know how or why, but apparently I did something from the other day that enabled them... which is frustrating because not knowing how it works is bitter sweet, when they clearly did not work before.

    Thus, this thread's topic can be dropped... I guess my question now is, do I hold onto the new and cheap card, or do I send it back to newegg, but with a forced restocking fee? I think I'll keep it. :)

    Ugh, thank you to everyone that reviewed this thread, and a big thank you to GhislainG for the assistance... I'm not sure what happened, but I started this thread after a day's worth of failingly attempting to set up the onboard NICs, and I checked them a day, maybe almost two days later and they still didn't work... so I did something yesterday or today, which definitely wasn't much on this system, for them to all of sudden work. I wish Gigabyte would at least have them show up on the driver list from the autorun CD.
  5. Mmmm, have you tried some Linux LiveCD to make sure the onboard LAN is not defective (would rule-out the OS)?

    Have you tried to use the drivers from Gigabyte instead of Realtek, they have both XP (32/64) and Vista (32/64)?
  6. Hi Captainmorgan,

    I u do by chance come across the solution be sure n let me know please... as u can see from my posts here:

    I have had exactly the same issues as yourself. I don't have the original CD that came with the mobo....

    I'm currently using an old intel pci nic, which is not ideal to say the least...

    Interestingly the onboard chips do appear to work in the bios cause I get a green light on the ethernet ports upon cable connection & when i go into the bios(smart lan option) i can detect the incoming lan signal. As soon as i go into the OS (win7RTM)
    the green light goes out n the lan connection dissappears. As i outline in the above forum despite numerous installs using all sorts of driver versions i always get the chips detected in the device managerbut with an exclamation mark through them & code 10 error.

  7. Have you tried the following:

    1. Download the LAN drivers for your controllers;
    2. Extract them in a folder;
    3. Update the drivers and select the location where the new drivers can be found.

    I've done that with a few different motherboards and it has always worked for me.
  8. I know this is a very late posting to a very old thread. However due to the popularity of these chipsets I'm posting some wisdom about why (high potential) the original poster had the problem he did, and why it just magically seemed to start working.

    These chips, (or cores) like the Realtek 8111D, (and of course most all other PCI chips), have tot be enumerated on the PCI bus. From a systems SW perspective (inside the OS), this has over the years become a very intricate ordeal to insure that the Intel bridges (northbridge/southbridge/controllers) are configured appropriately. In fact, Intel makes drivers that are used by Windows which load very early in OS boot process to make the PCI configuration process even possible.

    The original poster probably had his ethernet ports (on board his Mobo) just start "magically" working because he probably did something that caused the Intel Motherboard driver to get installed (or be loaded). Then, and only then, his Realtek drivers could then FIND the Realtek 811D hardware in his PCI bus.

    The moral to this story is, when you KNOW that you have inserted hardware into a PCI slot / bus that SHOULD be working, but it is not even being found or reported...there is a VERY GOOD CHANCE that the Intel Chipset drivers are not loaded or are not configuring your motherboard properly. You need to go back an look for ALL the drivers that exist for your motherboard. Those can be labeled as coming from the Mobo manufacturer....or in the distant past...these were even available from Intel (and may still be in some cases). But the BIG TAKE-AWAY here is....a slight misconfiguration at the Northbridge/Southbridge/Controllers...will almost always add up to HW that you add not being found. (and sometimes your HW might be found, but can't be configured appropriately, when the bridges aren't configured correctly).
Ask a new question

Read More

Drivers Networking