Sign in with
Sign up | Sign in
Your question

NFS Undercover running slow on a HD4670

Last response: in Graphics & Displays
Share
May 24, 2009 1:05:32 PM

I upgraded my 8500 GT with a HD 4670 ATI card.
Booting is perfect but problem comes when u are playing the games.

For ex- While playing NFS Undercover, it runs perfectly ok for first 1 or 2 mintues but goes very slow after that. I had removed all the prevoius NVidia drivers b4 installin the ATI driver.

Can anyone help me on this ??
June 2, 2009 12:34:42 PM

rohitb22000 said:
I upgraded my 8500 GT with a HD 4670 ATI card.
Booting is perfect but problem comes when u are playing the games.

For ex- While playing NFS Undercover, it runs perfectly ok for first 1 or 2 mintues but goes very slow after that. I had removed all the prevoius NVidia drivers b4 installin the ATI driver.

Can anyone help me on this ??


Try this

-uninstall ATI drivers
-get a driver cleaner program
-install ATI drivers and see how it goes

hope this helps
m
0
l
a b U Graphics card
June 2, 2009 1:05:27 PM

The title of this topic has been edited by Randomizer

I don't see how this thread relates to ATI vs Intel :) 
m
0
l
Related resources
a c 191 U Graphics card
June 2, 2009 1:18:14 PM

Full specs would be helpful! In the meantime do a reinstall of your drivers, using something like Driver Cleaner or Driver Sweeper in Safe Mode to make sure all the driver components are removed.
One word of caution: If you use a driver cleaner program check every item it is going to delete, they can remove registry entries and system files, so set a Restore Point as well.
Get GPUZ and use it to log the card temperatures as well as Speedfan and use it to monitor your CPU temperatures.
m
0
l
June 2, 2009 5:40:36 PM

coozie7 said:
Full specs would be helpful! In the meantime do a reinstall of your drivers, using something like Driver Cleaner or Driver Sweeper in Safe Mode to make sure all the driver components are removed.
One word of caution: If you use a driver cleaner program check every item it is going to delete, they can remove registry entries and system files, so set a Restore Point as well.
Get GPUZ and use it to log the card temperatures as well as Speedfan and use it to monitor your CPU temperatures.


thanks for adding "in safe mode"

i totally forgot

Uber :D 
m
0
l
June 2, 2009 5:50:58 PM

this sounds like the temperature of the card is effecting the game. That could be the reason why the first couple of minutes its fine, then it starts to lag. Play the game until it lags, exit out, go check the temperature of your cpu and gpu and post them here. If the temperature is not the case, what UberGenocide said is another legit option. Also try uninstalling the game along with the drivers and installing everything fresh. Let me know ;) 
m
0
l
June 2, 2009 5:56:38 PM

coozie where do you download gpuz from? sorry for offtopic
m
0
l
a c 191 U Graphics card
June 2, 2009 7:28:56 PM

Easiest way is just type GPUZ into your browser, the official site is Techpowerup, find Speedfan the same way.
Speedfan has to be installed, but GPUZ just needs to be extracted and you run it by clicking on the .EXE in the extracted folder.
As always, scan for infections before running or uncompressing a downloaded file;)
m
0
l
!