NFS Undercover running slow on a HD4670

I upgraded my 8500 GT with a HD 4670 ATI card.
Booting is perfect but problem comes when u are playing the games.

For ex- While playing NFS Undercover, it runs perfectly ok for first 1 or 2 mintues but goes very slow after that. I had removed all the prevoius NVidia drivers b4 installin the ATI driver.

Can anyone help me on this ??
7 answers Last reply
More about undercover running slow hd4670
  1. rohitb22000 said:
    I upgraded my 8500 GT with a HD 4670 ATI card.
    Booting is perfect but problem comes when u are playing the games.

    For ex- While playing NFS Undercover, it runs perfectly ok for first 1 or 2 mintues but goes very slow after that. I had removed all the prevoius NVidia drivers b4 installin the ATI driver.

    Can anyone help me on this ??


    Try this

    -uninstall ATI drivers
    -get a driver cleaner program
    -install ATI drivers and see how it goes

    hope this helps
  2. The title of this topic has been edited by Randomizer

    I don't see how this thread relates to ATI vs Intel :)
  3. Full specs would be helpful! In the meantime do a reinstall of your drivers, using something like Driver Cleaner or Driver Sweeper in Safe Mode to make sure all the driver components are removed.
    One word of caution: If you use a driver cleaner program check every item it is going to delete, they can remove registry entries and system files, so set a Restore Point as well.
    Get GPUZ and use it to log the card temperatures as well as Speedfan and use it to monitor your CPU temperatures.
  4. coozie7 said:
    Full specs would be helpful! In the meantime do a reinstall of your drivers, using something like Driver Cleaner or Driver Sweeper in Safe Mode to make sure all the driver components are removed.
    One word of caution: If you use a driver cleaner program check every item it is going to delete, they can remove registry entries and system files, so set a Restore Point as well.
    Get GPUZ and use it to log the card temperatures as well as Speedfan and use it to monitor your CPU temperatures.


    thanks for adding "in safe mode"

    i totally forgot

    Uber :D
  5. this sounds like the temperature of the card is effecting the game. That could be the reason why the first couple of minutes its fine, then it starts to lag. Play the game until it lags, exit out, go check the temperature of your cpu and gpu and post them here. If the temperature is not the case, what UberGenocide said is another legit option. Also try uninstalling the game along with the drivers and installing everything fresh. Let me know ;)
  6. coozie where do you download gpuz from? sorry for offtopic
  7. Easiest way is just type GPUZ into your browser, the official site is Techpowerup, find Speedfan the same way.
    Speedfan has to be installed, but GPUZ just needs to be extracted and you run it by clicking on the .EXE in the extracted folder.
    As always, scan for infections before running or uncompressing a downloaded file;)
Ask a new question

Read More

Graphics Cards NFS ATI Graphics