Sign in with
Sign up | Sign in
Your question

Windows 7 will not boot, HDD not detected by Windows 7 installer

Last response: in Storage
Share
December 21, 2010 2:06:15 PM

I have an ASRock 775Twins-HDTV Motherboard. Originally it had 1 IDE Optical drive plugged in, 1 IDE hdd and 1 SATA hdd. I attempted to remove the IDE hdd and install another SATA drives. I changed some settings in the BIOS so the new hdd would be detected.

Now, the PC will restart before Windows 7 completely boots. If I try to reinstall Windows 7, the hdd (or any other hdds I've tested) are not detected by the installer.

I have tried puttin the drive in SATA mode, IDE mode, AHCI mode. I have restored CMOS settings, reflashed the BIOS and have tried to replicate the original BIOS settings as far as I can remember. This is a really strange issue. Can anyone help?
a b G Storage
December 21, 2010 2:49:06 PM

You may need to load drivers for the SATA controller when installing windows. Depends on how old the board is.

If you put the IDE drive back in does it boot?
m
0
l
December 21, 2010 3:27:45 PM

Hmm it is from 05/06. I've actually managed to boot it in "ATA Combination Mode" - which I guess is just IDE mode (I think I exited BIOS without saving before when I tried that). Unfortunately this mode restricts me to use only 1 SATA port.

I assume the current Windows Installation doesn't have the SATA drivers. Is it possible to install them through the Start Up Repair suite Windows offers? Because I can boot into that in SATA mode.

UPDATE: Yes, you were correct! I found the correct drivers. I guess I'm going to just have to reinstall D: So much time wasted reinstalling + setting it up last night.

Thanks very much for your help sturm!
m
0
l
Related resources
a b $ Windows 7
a c 812 G Storage
December 21, 2010 11:29:02 PM

you dont have to reinstall, you can just tell the system toload the drivers, shut down, go into the bios and switch to achi mode, and then reboot and it will work fine. MS has a bulletin out on this. let me go see if I can find it.
m
0
l
!