Hard drive reading problems

Hello
I have a hard drive (Seagate ATA) which is formatted in Linux. I tried to read it with some special software under windows. I was able to read it. However, I do not know why whenever I try to plug it again to my computer (using the same usb to sata conversor I was the first time) I cannot read the contents of the hard drive anymore. It seems as if the hard drive was unreadable. Would it be possible that this ATA hard drive had turned unreadable for having unplugged the usb-SATA converter before unmounting the device in windows?
The only strange thing is that Windows keep mounting the drive. Of course it does not assign a drive or letter. But if I use a software like Linux reader, there will only show up an icon for this hard drive which says "empty".
Does anyone have any idea to be able to read the hard drive again?
I thought these hard drives would not turn unreadable because of not unmounting the usb -sata converted with which I plugged it into the computer but in the end this might be the reason.
What do you think?
Thanks
2 answers Last reply
More about hard drive reading problems
  1. Removing a hard drive under Windows without ejecting it first can corrupt whatever was being written.
    Have you tried connecting it to your Linux machine? What happens when you do?
  2. Well thanks, but it is already solved. It is strage but eventually it seems the usb-sata adapter had been plugged badly to the hard drive because when I unplugged and plugged it again, it worked fine. At least that is the only explanation I could come up with.
Ask a new question

Read More

SATA Hard Drives USB Storage