Sign in with
Sign up | Sign in
Your question

AHCI stopped working, now IDE is not working as well

Last response: in Motherboards
Share
October 24, 2009 5:06:29 PM

Here is my setup relevant to my post:

ASUS P5QL Pro
HDD 1: SATA 160 GB (Win7 RTM on drive) (connected to SATA 1)
HDD 2: IDE 80 GB (IDE Connection)
HDD 3: External eSATA 1 TB (External adapter connected directly to SATA 5)
SATA DVD RW (connected to SATA 3)

Last night I read that you could configure some settings in the registry and BIOS so I could enable a hot-swappable external hard drive (I forget to turn it on sometimes).

Here is what I did:

1. I set a value (I can't remember where and I can't seem to find the tutorial now) to 0 in the registry
2. Restarted and enable AHCI in the BIOS.
3. Restarted and let Windows 7 install the drivers needed.
4. Restarted and everything worked perfectly.
5. Powered down last night and this morning I got an error stating that there was not boot manager.
6. Thinking that something was wrong with the AHCI setup, I changed things back to IDE and now I'm getting the error "Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key"

My Storage configuration is currently as follows:

SATA Configuration [Enhanced]
Configure SATA as [IDE]

Boot Device Priority:

1st: [SATA: 160 GB (Win7)]
2nd: [DVD RW]
3rd: [ 1st Floppy Drive] (Even though I don't have one)

I am stumped. I can't figure out why restoring the original settings will not allow me to boot as I was previously. Could it have something to do with the value that I changed in the registry? Any ideas?
October 24, 2009 5:09:59 PM

Nevermind, I fixed it. Sorry. I had the external hard drive and 180 GB hard drive mixed up.
m
0
l
Related resources
!