Sign in with
Sign up | Sign in
Your question

Raid 0 Bsod on splash screen

Last response: in Storage
Share
December 27, 2010 1:19:04 AM

Hi, I've been trying to set up two identical Seagate Barracuda 1tb 7200 drives to run in raid 0. I have my os already installed on a different drive. I enabled raid in my Bios and set the two drives up in an array, but every time I get to the splash screen my computer crashes. I looked in my Bios and saw that all of my drives (4, two standalone and my two new seagate's) were listed as raid, even though I only put two in an array. I'm really new to all of this so I might be missing something big, am I doing this right XD?

Any help or things to try would be appreciated

My rig
AMD Phenom x4 overclocked Processor
2x2 1066 2gb sticks ddr 2 patriot ram
Geforce gtx 275
Biostar TA785ge 128m mobo
750 corsair psu
sata 1.5 200gb hdd
sata 3gb/s 300gb hdd
December 31, 2010 6:05:25 PM

Did you change your SATA controller mode from IDE/AHCI to RAID as part of setting up your array? Doing this will cause windows to fail to load because windows only installs the storage driver for the current mode (IDE/AHCI/RAID) enabled at OS install, and if the correct driver for the mode you are switching to isn't installed and configured before you change then windows isn't able to access the drive during boot. That's my guess anyway.

As for all your drives being listed as RAID, that's probably referring to the controller being configured in RAID mode, not because they're in a RAID array.
December 31, 2010 8:12:41 PM

I did have to change the mode to Raid, but I was hoping for a workaround. A lot of people with asus and other higher end mobo's seem to be able to do it, but I haven't found a way to do it with my motherboard. Perhaps the downside of going with a low end biostar XD.
Related resources
a b G Storage
January 2, 2011 12:58:12 AM

You need to disconnect the other drives and set it back to ahci/ide

let it boot into windows then install the windows raid drivers..

then it should work in raid mode

this is why they have the f6 load drivers option on fresh installs.

you have no raid drivers loaded so it fails.
January 2, 2011 11:41:13 PM

I thought I might have to install the raid drivers, but I had hoped I might be able to get it to work without doing it, or perhaps do it without reinstalling my os :/ .
a c 748 G Storage
January 3, 2011 12:41:21 AM

You dont have to reinstall your OS, just edit the registry to load the drivers at boot, or simply boot in IDE mode and load the drivers after windows loads and then back out and change to raid mode.
January 3, 2011 2:53:45 AM

I tried both, windows doesn't let me do it. I even tried putting it on a floppy and it didn't work.
!