Sign in with
Sign up | Sign in
Your question

Remote Desktop printing problem

Tags:
  • Remote Desktop
  • Printers
  • Windows XP
Last response: in Windows XP
Share
October 12, 2011 9:29:06 AM

Hello,

I am trying to print from the remote machine to a printer on my local machine using RD. The printer is an HP Officejet 5610 connected via USB which from what I've read may be part of the problem.

Here's what I've done so far:

At first it wouldn't even see my printer on the remote machine, so I followed some instructions to do with printer pooling ports.. now I have the printer visible on the remote machine. When I try and send a test page it leaves the remote machine and appears in the HP printer queue on the local machine.. so far so good. But then it just sits there, with the status saying "printing" but the printing doesn't start.

Also the size is stuck on 571bytes/278kb. I believe the print job name should have a suffix like "from remote machine" or something like that but it just says "no document name". It seems like I am close to making it work, but not sure how to solve this?

cheers

More about : remote desktop printing problem

October 13, 2011 2:46:03 AM




Yup, sounds close to me too. Check that you have "File and Printer sharing" turned on at the host machine. Check firewall isn't blocking printer.
Check printer driver is installed in remote machine so it can send data properly to the printer.

June 27, 2012 11:08:20 AM

I had the same problem and I can recommend any of the commercial solutions but do not recommend installing a print driver on the server because it can lead to the destruction of the server, users were constantly called because printers doesn’t working, print spooler crash, and then I found TSPrint and solved all the problems with RDP printing, and many other problems, I tried several commercial solutions and the most I like is TSPrint due to low prices and good support feedback. Hope it helps. Take a look at http://terminalworks.com/remote-desktop-printing/
!