Sign in with
Sign up | Sign in
Your question

Windows 7 only uses 8 GB of 12 GB of RAM

Tags:
  • Asus
  • Windows 7
  • RAM
  • Memory
  • Motherboards
Last response: in Motherboards
Share
November 1, 2009 11:21:31 PM

I am running Windows 7 Home Premium 64 bit. I have 12 GB (6 x 2GB) of memory installed in my system with the ASUS p6t motherboard. Windows only recognizes 8 of the 12 GB. How can I get Wondows to use all of the available memory?

More about : windows ram

November 2, 2009 12:44:34 AM

what software is telling you this?
make sure all of the RAM modules are in place, it is possible that two are loose.
November 2, 2009 2:16:18 AM

cheepstuff said:
what software is telling you this?
make sure all of the RAM modules are in place, it is possible that two are loose.



Under Basic System Information, Windows states that only 8 GB of memory is installed. If I use CPU-Z, it states that all 12 GB of memory are installed. None of the modules are loose, I can't figure out why Windows won't use all the memory available.
Related resources
November 23, 2009 4:23:34 PM

I have the exact same issue kefko. While running the win 7 RC, all 12GB were showing, but after installing the RTM, only 8GB shows up, but all 12 appears in CPUZ. Did you find a solution to this?
a b Ĉ ASUS
a b $ Windows 7
a b V Motherboard
November 24, 2009 10:50:50 AM

I suspect that Windows may be reserving extra RAM for Kernal use (sort of like the default 2GB the kernal uses in 32 bit versions of Windows), although I'm not familliar enough with Vista/7 to know for sure if this is whats happening. I'm seeing this a LOT though.

Could also be lack of forsight by some motherboard manufacturers, who may have a 8GB limit for some boards.
January 12, 2010 6:01:58 AM

I just completed my system using Corsair 6x2GB. Even before I loaded windows, my motherboard only recognized 8GB. Same result in Windows.

Further, I have 2x128GB SSDs in raid 0 and a 1.5TB data drive. All three drives show up properly in device manager, but Win 7 Explorer only sees one of the SSDs (the "C" drive).

O/S: Win 7 Ult 64bit
Mobo: ASUS P6X58D w/ i7-975 and 12GB 1600MHz Corsair memory.
Drives: 2x128GB Patriot Torkz and one 1.5TB Data drive
Two optical drives. Master Cooler 212 plus w/ 2 fans
Saphire HD 5970 video card (Received today!!!)

Good luck - to both of us :wahoo: 
January 12, 2010 6:38:02 AM

12 GB???? Why would anyone want 12 GB? I find that 50% to 75% of my 6GB RAM is unused most of the time.
a b $ Windows 7
a b } Memory
a b V Motherboard
January 12, 2010 12:23:42 PM

open an elevated command prompt (type cmd in the search box, right click the restult and choose 'Run As Administrator')

type: msconfig

This brings up the configuration utility.

Click the Boot tab, and then click the Advanced Options button.

In that window, there is a setting for Maximum Memory - Make sure the checkbox for it is clear (not checked), then reboot your computer.
January 12, 2010 10:39:42 PM

same problem here 6gb 2gb usable, tried reseating ram & cpu. unchecked maximum memory. installed latest bios.
January 13, 2010 2:17:08 PM

I 'm having a similar problem as well. I have 9gb of ram installed and windows shows 6gb but CPU-Z shows 9gb. Windows used to show 9gb as well. I had removed my video card and reinstalled it at one point. I did notice that in system info>conflicts that the video card is in some memory addess conflict. I tried to do a memory remap but there is no option for it in BIOS ( Asus Renegade II Gene ). Thoughts....?
May 17, 2010 3:34:43 AM

My Asus P6T did the exact same thing. It was not a Windows 7 issue at all. It was a ram timing issue. The SPD values that the motherboard was reading were completely wrong. I had to look up the voltage and timing information for the RAM I have and set it manually in the BIOS. I bet if you press tab while the BIOS is loading you will see that the motherboard is not reporting the full amount of memory that you have installed. Ever since I set the values correctly in the BIOS, I've been able to clock my RAM higher and all of it is being detected. HTH.
a b Ĉ ASUS
a b } Memory
a b V Motherboard
May 17, 2010 5:15:13 AM

Also it could be bent motherboard pins.
Anonymous
a b $ Windows 7
a b } Memory
a b V Motherboard
May 17, 2010 8:59:06 AM

GhostTech said:
My Asus P6T did the exact same thing. It was not a Windows 7 issue at all. It was a ram timing issue. The SPD values that the motherboard was reading were completely wrong. I had to look up the voltage and timing information for the RAM I have and set it manually in the BIOS. I bet if you press tab while the BIOS is loading you will see that the motherboard is not reporting the full amount of memory that you have installed. Ever since I set the values correctly in the BIOS, I've been able to clock my RAM higher and all of it is being detected. HTH.


Hmm, i have P6T too, and im thinking it detects the frequency wrong also. Did you run into this problem? I had them officially @ 1333Mhz, but it was detected at 1066mhz. Solved somehow?
May 17, 2010 1:02:05 PM

I ran into this too. I just manually set the speed to 1866 (I think that is the number. Don't really remember ATM) in the BIOS and has running at that speed since. I press tab on start up to verify what frequency it is running at.

@Lmeow: That is also an excellent point. I haven't seen that myself on these boards. I have heard reports that people have had bent pins which is causes memory detection and utilization problems.
March 8, 2011 3:49:51 PM

Windows 7 Home 64 bit is only design to use and recognize up to 8Gb of RAM. Therefore if you have 12Gb installed, not only will it not recognize the extra RAM, but it will not make use of it. The solution is to upgrade to Windows 7 Home Premium 64 bit which has a 16Gb maxium, or Windows 7 Professional 64 bit which has a max of 192Gb of RAM. The alternative would be switching to LINUX which does not limit the ammount of RAM it accepts. Hope this helps! http://www.zdnet.com/blog/hardware/max-memory-limits-fo...
a b Ĉ ASUS
a b } Memory
a c 107 V Motherboard
March 8, 2011 3:58:15 PM

lol

Holy thread necro Batman!

It was dead for nearly a year, and now you've resurrected its corpse. Way to go!
March 8, 2011 5:00:46 PM

Leaps-from-Shadows said:
lol

Holy thread necro Batman!

It was dead for nearly a year, and now you've resurrected its corpse. Way to go!



:lol: 

True, but he appears to have shared an answer that is rather helpful! Thanks Jern, the author may not have been reading but other newbs are!
a b Ĉ ASUS
a b } Memory
a c 107 V Motherboard
March 8, 2011 5:51:15 PM

I don't know about all the rest of the posters, but the OP already had the Home Premium 64-bit version. I haven't actually seen the Home Basic version for sale anywhere, and all pre-built systems come with Home Premium. Is Home Basic even available any more?
March 9, 2011 5:06:27 PM

Hmm.. I think you're right L.F.S. Just checked newegg and I dont see a basic version.

But there is a 32 bit ver. of home premium. Don't know if that would make a big difference but I was under the impression that is a scaled down version no?




September 24, 2011 4:09:43 PM

Scotteq said:
open an elevated command prompt (type cmd in the search box, right click the restult and choose 'Run As Administrator')

type: msconfig

This brings up the configuration utility.

Click the Boot tab, and then click the Advanced Options button.

In that window, there is a setting for Maximum Memory - Make sure the checkbox for it is clear (not checked), then reboot your computer.


This worked for me . I had 12 Gb and only 7,2 usable. Thanks W7 ultimate.
October 14, 2011 11:16:54 PM

Kefko said:
I am running Windows 7 Home Premium 64 bit. I have 12 GB (6 x 2GB) of memory installed in my system with the ASUS p6t motherboard. Windows only recognizes 8 of the 12 GB. How can I get Wondows to use all of the available memory?





Are you running win 7 64bit? I upgraded to ultimate 64bit and it detects the full amount of ram.
December 15, 2011 2:19:24 PM

I had the same problem with my computer. I have 8 GB of RAM and only 4 would come up as usable. I read in some other forum that one guy remounted his CPU fan, why he did it and why it worked I have no idea but nonetheless I did exactly that. At first my computer would not turn on and I freaked out because all I did was mess with my CPU fan. By doing just that I was forced to unlatch my CPU, take it out, and place it back in finally latching it back into place. Once this was done my system started right up and now 7.50 GB comes us as usable. Rumor has it that if you own any of the i cores( i3, i5, i7) the CPU fan being on too tight could affect how much RAM is able to be used. I have an i5-750 and moving the fan worked for me.
January 13, 2012 11:54:13 AM

SenjuRoy said:
I had the same problem with my computer. I have 8 GB of RAM and only 4 would come up as usable. I read in some other forum that one guy remounted his CPU fan, why he did it and why it worked I have no idea but nonetheless I did exactly that. At first my computer would not turn on and I freaked out because all I did was mess with my CPU fan. By doing just that I was forced to unlatch my CPU, take it out, and place it back in finally latching it back into place. Once this was done my system started right up and now 7.50 GB comes us as usable.
worked for me too, unreal. $7 in thermal paste and I was good to go. thanks!
February 24, 2012 6:17:15 AM

GUYS I REPORTED THIS TO ASUS. THE PROBLEM IS WITH THE FREQUESNCY.

IF I SET THE RAM TO 1333MHZ IT SHOWS 12GB, AND IF SET TO 1600MHZ IT SHOWS ONLY 8GB. ANYHOW CPUZ SHOWS 12 EVERYTIME. IT BETTER TO GO WITH UPGRADING THE BIOS AND THEN SETTING THE SETTINGS PROVIDED BY ASUS SUPPORT TEAM.
!