Sign in with
Sign up | Sign in
Your question
Solved

1TB Wester Digital Green poor performance

Last response: in Storage
Share
January 8, 2011 3:40:06 PM

Hi,

I just got a 1tb Wester Digital Green edition and... it sucks !!!

I have a core i3 and 4gb ram using Windows 7 Ultimate 64bit.

Hard drive light is almost always turned on, and it seems that is constantly reading/writing.
It slows down even FireFox and mp3 playback.
And I don{t even could copy a file and use FireFox or Wianamp at the same time.

Seems like my older 120gb 5400rpm notebook hard drive was a lot better than this.


So... after reading a bit, I learnt that this WD hd has a variable speed, from 5400 to 7200rpm... so, I wonder,
is it posible to set the hard drive to always run at 7200rpm ?
I don't care about the power saving.
I just want this hard drive to work as better as posible.

Is there a way to do that ?
What else could be wrong with this hard drive or even my system ?

I'm using an Asus P7H55-USB3 mother/model.
And I also have conected the 120gb hard drive (the one I used on my old notebook) and a dvd-rw combo drive.

Thanks !!!
a b G Storage
January 8, 2011 11:06:12 PM

Caviar Green are not performance drives, as you found out. If you want performance should get Caviar Black, or SSD.

Also be sure you don't have any virus/trojans.
m
0
l
a b G Storage
January 9, 2011 6:04:16 AM

If you are looking for performance, then do not buy WD Green drives in the future. You will probably also want to avoid WD Blue drives as well which balances power efficiency and performance. WD Black drives are for performance. SSD offers even better performance but are expensive.

I use a 1TB WD Green drive to store my music and movie files on. I'm not a big fan of MP3 file format so all my music is in FLAC format (roughly 5MB per 1 minute of music), my Green drive never caused my music or movies to stutter.
m
0
l
Related resources
January 9, 2011 10:49:40 AM

Thanks for the replys.

I just don't understand why it is almost always like reading/writing.
The system it was just installed. I supposed I don't have any virus/troyan.
I'm also running Avira antivirus and it didn't find anything.

Myabe there's some Windows process in background... I just don't know.


Still... is there a way to set the hard drive to always work at 7200rpm ?
m
0
l

Best solution

January 9, 2011 2:35:28 PM

The caviar greens will never work at 7200 RPM. They are 5900 rpm drives. As for the constant reading/writing light being on I may be able to explain that.

When you install Windows 7 it does not index the drive. You may find that you have a spyglass in your taskbar (near the clock) that says it is indexing the drive. While indexing is occurring the system will be very slow to respond as the drive is being read/written to during this process. This process can be time consuming. Also 4GB of ram is the bare minimum to run 64bit windows (they say 2 however performance is really lacking at minimum specs). Try running 6-8 GB of ram in your system.

Also caviar green drives will go to sleep more often than caviar blacks. If it were me I would swap that drive out for a caviar black edition then use that drive as a storage drive for media.
Share
January 10, 2011 9:52:11 AM

I didn´t have that spyglass, so I guess indexing should be over yet, but...

I read a few articles about Windos 7 64bit ram requirements and those articles says that the minimun ram recommended is 4GB because of the 64 bit words that uses... I have 4gb but... I´m running on board graphics (Intel Hd core i3 graphics)... so... that would take some ram away, making the total Windows ram to be less that 4GB.
So... maybe... that´s causing the hard drive/windows to use more virtual ram for every proces. Making the hard drive to be reading/writing almost all the time.
I don´t know... I think that could be part of the problem.
I´ll try adding at least 2gb more ram.


Thanks!
m
0
l
January 10, 2011 10:57:59 AM

Check the bios and enable DMA and LBA modes.
Check windows device manager and make sure you are running in DMA mode. NOT PIO mode.
m
0
l
January 11, 2011 11:32:37 AM

It is set to DMA.
Thanks.


I tryed to disable Windows Search (indexing) Service and now seem to work better.
Hard disk still keeps like reading/writing, but now is not all the time as it used to be.
I guess that was part of the problem... but still, drive performance is not good.

I´ll try to update to a Black edition hd or another brand.


Thanks !
m
0
l
a b G Storage
January 11, 2011 2:22:32 PM

There's nothing wrong with WD drives, you just need to choose the appropriate one for your needs.
m
0
l
a b G Storage
January 11, 2011 3:07:13 PM

the green drives arent THAT slow. when its being slow hit
control-alt delete bring up task manager
goto the performance tab and click resource monitor

then goto the disk tab and see whats accessing it.

if its for the first 10min after you turn it on it could be superfetch

I'd also recommend running your favorite hdd benchmark program on it

like hd tach

http://www.simplisoftware.com/Public/index.php?request=...

green drives can still hit over 80MB/sec its just that the seek time between file access can be longer due to the low power design (mainly lower rpm)
m
0
l
January 18, 2011 9:50:59 AM

Thanks to for all the replys.

I just re-installed the SO on my old notebook HD, and system now runs smooth.
I´ll just leave the WD Green hd as second storage drive. And make sure I´ll never buy a "green" HD again. :D 
m
0
l
January 21, 2011 9:40:16 AM

Best answer selected by illya.
m
0
l
!