Sign in with
Sign up | Sign in
Your question

ATI 4830 for graphics, NVIDIA 9500GT for Physx

Last response: in Graphics & Displays
Share
a b U Graphics card
June 5, 2009 12:48:26 AM

So after reading countless forums of simple screenshots and whispers of running a Geforce card as a Physx accelerator while having an ATI card to do graphics, I decided that I would spring for the $45 for a 9500GT to test it out for my own.

I'm running Windows 7 x64, build 7100.
I have an Asus P5N-D, latest BIOS, Xeon X3220 @ 3.42 GHz, 8GB of 1013Mhz DDR2, an HD 4830 1GB DDR3 version @ 770MHz / 1120MHz, and a 9500GT 512MB DDR2 at stock settings, an X-Fi XtremeGamer, and two WD 320's in RAID 0.



Drivers are all latest, 9.5 (8.612) for ATI, 186.08 for NVIDIA, whatever the latest pack from daniel_k is for the sound card, and 15.35 for the mobo.

3DMark Vantage Scores are as follows:

GPU----------------------------GPU Score-----CPU score-------Total
4830 (9500 disabled)------------7227-----------11778---------P8000
9500 (4830 disabled)------------1207-----------11943---------P1557
9500 (4830 disabled ------------1210-----------17964---------P1577
w/ Physx enabled)

Now, when I disable the 4830 in Device Manager, the NVIDIA control panel (from here on, NCP) immediately shows that PhysX can be enabled or disabled, but once I reenable the ATI card, the option for PhysX disappears.

I've read in some other forums to leave the NCP open, and after enabling the other card to select and deselect the PhysX option, and it should enable it. I did this and ran Vantage again, but it was a no go, the CPU scores didn't change.

I've tried a few different drivers, such as 182.50 and 181.something, and it didn't help. I haven't tried any more ATI drivers, as the problem seems to be in the NVIDIA ones.


Does anybody have any ideas on how we can make this work? If you've got any more information on the subject, or have driver suggestions, let me know.

Edit: Made scores and such a little easier to read.
a b U Graphics card
June 5, 2009 2:19:52 AM

Well, I think I've taken a step forward. I downgraded the Geforce drivers to 178.13, and now I can enable Physx on the second monitor (the one one the 9500) while having the 4830 still enabled in device manager.

Testing in Vantage, the CPU score didn't go up. I don't really wanna try new drivers in the 4830, as these are the only WDDM 1.1.

Now I just have to figure out what I can change and then try again.
Related resources
a b U Graphics card
June 5, 2009 2:53:57 AM

Got it. :) 




Not as much of a jump in 3dMark score, but now I can do PhysX!

All I had to do was make the monitor on the 9500 my main monitor, then enable Physx and leave that window open, then make the ATI monitor my main, then click enable and apply a lot in the Physx window.

I need to get Fluidmark now.
a c 271 U Graphics card
June 5, 2009 3:07:24 AM

How many monitors are you using?
a b U Graphics card
June 6, 2009 1:12:50 AM

Two. My main 19" LCD and my 26" LCD TV over HDMI as the second. I'm gonna now try doing it on just the one monitor, but use the DVI and VGA ports.
a c 271 U Graphics card
June 6, 2009 1:24:06 AM

Keep us posted if you wouldn't mind.
a b U Graphics card
June 6, 2009 3:08:54 AM

Well, I tried a few things tonight. I tried disabling the second monitor after making sure that Physx was enabled and working, but upon running Vantage again, the CPU score showed that Physx was disabled, so you would have to leave a second monitor plugged in (doesn't have to be on, though).

I also tried updating the Geforce drivers. The drivers I'm running are 178.13, so they don't have the newest version of CUDA, and may be able to sqeeze some more performance out of it with new drivers. So I downloaded the newest 186.08 (as I've already tried the 185's), ran them in Vista compatibility mode, and gave it a shot. Unfortunately, after endless toying with it, I couldn't get Physx to stay on. :( 

I just downloaded Fluidmark to test it out. I'll have Mirror's Edge here shortly to see how much it likes Physx.
a b U Graphics card
June 6, 2009 6:15:23 PM

Fluidmark crashes upon leaving the configuration screen. Tried compatibility modes and whatnot, but no luck. :( 
a c 271 U Graphics card
June 6, 2009 6:41:55 PM

Well TGGA reckons it will work, but I still remain sceptical and your ongoing progress reports are not swaying my scepticism but I do hope you success as I would kinda liked to be proved wrong on this occasion.
a b U Graphics card
June 9, 2009 12:36:08 AM

No worries :) 

I'll post a video or something of me disassembling and whatnot to show the cards, then run the benchies. Think that would help?
a c 271 U Graphics card
June 9, 2009 12:44:05 AM

It could well be useful to others who are trying to get their heads around the Ati/Nvidia graphic/physX thing.
June 9, 2009 6:35:49 PM

it will be ideal when win 7 gets relsed properly :p 
a b U Graphics card
June 14, 2009 8:52:34 PM

So last night I stuck in an 8800GTS 320 instead of the 9500 to see if that would work as well. The CPU score on Vantage jumped to ~26000 from the ~18000 or so with the 9500 doing PhysX.

Tonight (or maybe tomorrow) I'm gonna try Mirror's Edge and Cryostasis and post some benchies (or videos if FRAPS will let me).
a b U Graphics card
June 15, 2009 3:14:11 AM

Left the 8800 in there and fired up Mirror's Edge after several successful runs of Vantage. The opening parts went fine, but as soon as the glass started breaking on the 3rd level, my framerate dropped to around 9 or so, showing that PhysX wasn't being accelerated. Again, this was on 178.13 drivers. I tried installing 186.08 again, but it was a no go.

I just downloaded 185.66, which is the oldest driver with the CUDA 2.2 dll files with fancy new enhancements and such, so I'm gonna give it a shot.

Don't worry mousemonkey, I'll sway you yet!!
a b U Graphics card
June 16, 2009 10:31:07 PM

I'm trading my boss the 9500GT for his 8800GT in the computer at work, as he does no gaming, and I really need a card that has a single slot cooler (the cooler on the 9500 is seriously hairs over a single slot).

I'll have that whenever I can convince him that it'll take 5 minutes to uninstall the driver, replace the card, and reinstall the new ones that support the 9500. :) 
a c 271 U Graphics card
June 16, 2009 10:56:45 PM

I would just swap the cards and try it, but that's 'cos Im lazy. :lol: 
a b U Graphics card
June 16, 2009 11:46:35 PM

Nah, he's using the 169.13 driver, which doesn't support the 9500. But he knows how simple it is, he's done it millions of times before, he just doesn't want to go through the "hassle" right now. haha

Maybe I can convince him tomorrow. Then again, tomorrow is my day off, and would run the risk of him saying "oh, by the way, can you work today? Closing would be good, too."
a c 271 U Graphics card
June 16, 2009 11:52:26 PM

Going in to work on a day off is never a good idea, unless you're trying to suck up of course.
June 17, 2009 2:46:10 AM

Just curious as to the Windows Aero & gaming scores on the Windows 7 Experience Index for the 9500 GT & 4830. I am looking at both of these cards as an option. Do you have the scores?
a b U Graphics card
June 17, 2009 3:11:19 AM

Actually, I go in on my day off almost every week. I work at the UPS Store here in Okeechobee, and I have a mailbox there, so I check my mail and such, or to just tell some joke I heard to the people I work with (they're awesome).

My 4830 (heavily overclocked) gets a 6.6 on the WEI, but trust me that that score doesn't really make a difference.



And for the record with the PhysX,

IT WORKS!

I saw that someone on another forum updated their post from last year or so, and gave instructions he used to get Mirror's Edge to work.

Drivers 181.22 are the key, and deleting a DLL file from the Mirror's Edge directory gets it to work in ME. I gave it a shot, and BAM! Glass shattered all over the floor and stayed there, which is the main thing that really bogged my system down when it wasn't hardware accelerated.

I'll have to borrow my coworker's video camera so I can get mousemonkey some real proof (I figure that that's MUCH better than just a video of what's going on on the desktop).
a c 271 U Graphics card
June 17, 2009 8:58:29 AM

I shall look forward to seeing it in action. :) 
June 18, 2009 8:06:35 PM

jedimasterben, could you either post a link to the other forum or write/make a quick tutorial on how to do get it running ? oh and btw what OS did you get it to work under?
a b U Graphics card
June 18, 2009 9:52:08 PM

I use Windows 7 64-bit. You'll need either it or XP, as Vista does not allow having multiple different graphics drivers running at the same time. It's just a limitation to how Vista's WDDM (Windows Driver Display Model) works.

I can't find the link currently, so I'll have to do it from memory.


1) Install the ATI card and the drivers (9.6 is the latest, works great for me)

2) Install the nVidia card and install the drivers in Vista compatibility mode since they are written for Vista (use ONLY 181.22, this is the only one I could PhysX to work properly) XP 32-bit XP 64-bit 7 32-bit 7 64-bit

3) Install the latest PhysX runtime

4) Make sure your main monitor is attached to your ATI card, and a secondary monitor (or, if you only have one monitor that has two inputs, eg DVI and VGA, you can attach the card to that other connection)

5) Extend the Windows desktop onto the nVidia card

6) Set that one as the primary monitor.

7) Open up the PhysX control panel, located in your Windows System32 (or SysWOW64 directory if you're 64-bit). The file will be something like PhysXcpl or something like that.

8) Check the "Geforce PhysX" button and hit APPLY, NOT OK!! DON'T CLOSE IT!!

9) Switch the primary monitor/input back to the ATI card

10) Go back to the PhysX control panel and select "No Acceleration" but DON'T HIT APPLY OR OK! Select "Geforce Accleration" again and hit APPLY.

Enjoy PhysX. :) 

Now, to get Mirror's Edge to work, I had to go to the game's directory, then to the binaries (or bin, I can't remember right now, I'm not on my computer) and either rename or delete the PhysXdevice.dll file. Once you do this, the game will default to hardware PhysX and will be playable with full acceleration!

Credit goes to the guys on the other forums (I will post links whenever I get home) to set me in the right direction.
June 18, 2009 9:57:21 PM

Thanks great info, just two more things.

Do I need to redo this everytime I want to use physX or is it "permanent"

And after I'v set it up, can I then unplug the monitor that is connected to the nvidia card ?

=)
a b U Graphics card
June 18, 2009 10:17:00 PM

You'll have to do steps 5-10 each time you want PhysX, as it resets every time you reboot.

I've heard from others that you can indeed unplug the second monitor at that point, but I haven't tried it myself, as I don't want to go through the hassle of plugging and unplugging every time. I'd rather click. :) 
June 18, 2009 10:22:41 PM

ok thank you very much, then I need to take that into consideration before deciding between another ATI for xfire or that since my motherboard only has 2x PCIe x16 :/ 
a b U Graphics card
June 19, 2009 12:52:25 AM

Well, it depends on how much you use PhysX titles. If you don't need that support, then grab another ATI card and get more performance that way.

Also, you could get an actual Ageia PhysX card (either PCI or PCI-E x1 if you have the available slot for it) to get PhysX support that way. Then you wouldn't have to follow any of these steps!
a b U Graphics card
June 19, 2009 12:55:39 AM

Also, I got the 8800GT up and running. At first I thought it wasn't reading the monitor, but I changed the default windows background and it just gave a black screen on the second monitor. I redid the background change and it changed it for both monitors, so I could finally see what I was doing.

Vantage CPU score went up by around 4000, which is standard coming from the GTS 320, but this card uses less power, makes less heat, and is single slot so I can actually use the other PCI slot in my mobo (I had a Hauppauge TV tuner in the first PCI slot, but the 9500gt and 8800gts were dual slot so I couldn't use them).
June 21, 2009 12:21:39 AM

I have a similar setup. You do have to use the 181.22 drivers for the Nvidia card. If you look at the driver notes on the Nvidia website you will see a note saying that PhysX is disabled when running "multi gpus". Basically if you use an ATi card with Nvidia in Win 7 PhysX will not be available. Way to go Nvidia! Jerks.
a b U Graphics card
June 21, 2009 1:21:23 AM

I know, right! You'd think that they'd be happy to release a driver allowing it so that everyone would think "Hey, I can go out and buy a Geforce card and get PhysX!" therefore giving nVidia some money out of it.
June 21, 2009 9:10:18 AM

since ATI apperently seems to be having the upper hand on price/performance ratio atm nVidia should actually be thinking of making a driver that allows you to use their cards as a stand alone physx card. Since that would probably give the nvidia cards more value... but that's just what i think/say
June 22, 2009 12:53:03 AM

Well Nvidia might want to smarten up. With DX11 right around the corner and OpenCL they might just be told to stuff PhysX by developers since both AMD and Intel platforms will be using Havok.
a b U Graphics card
June 23, 2009 1:25:09 PM

And there's a ton of games that use Havok, to boot.
November 25, 2009 3:16:12 PM

jedimasterben said:
I use Windows 7 64-bit. You'll need either it or XP, as Vista does not allow having multiple different graphics drivers running at the same time. It's just a limitation to how Vista's WDDM (Windows Driver Display Model) works.

I can't find the link currently, so I'll have to do it from memory.


1) Install the ATI card and the drivers (9.6 is the latest, works great for me)

2) Install the nVidia card and install the drivers in Vista compatibility mode since they are written for Vista (use ONLY 181.22, this is the only one I could PhysX to work properly) XP 32-bit XP 64-bit 7 32-bit 7 64-bit

3) Install the latest PhysX runtime

4) Make sure your main monitor is attached to your ATI card, and a secondary monitor (or, if you only have one monitor that has two inputs, eg DVI and VGA, you can attach the card to that other connection)

5) Extend the Windows desktop onto the nVidia card

6) Set that one as the primary monitor.

7) Open up the PhysX control panel, located in your Windows System32 (or SysWOW64 directory if you're 64-bit). The file will be something like PhysXcpl or something like that.

8) Check the "Geforce PhysX" button and hit APPLY, NOT OK!! DON'T CLOSE IT!!

9) Switch the primary monitor/input back to the ATI card

10) Go back to the PhysX control panel and select "No Acceleration" but DON'T HIT APPLY OR OK! Select "Geforce Accleration" again and hit APPLY.

Enjoy PhysX. :) 

Now, to get Mirror's Edge to work, I had to go to the game's directory, then to the binaries (or bin, I can't remember right now, I'm not on my computer) and either rename or delete the PhysXdevice.dll file. Once you do this, the game will default to hardware PhysX and will be playable with full acceleration!

Credit goes to the guys on the other forums (I will post links whenever I get home) to set me in the right direction.



Could I ask you something?
I haven't got a monitor with two input (dvi+vga) sockets, but a single monitor with only one socket available (model=LG 1915s) can I use this technology?I was wondering, should I used a splitter on the two VGAs(8600GT and HD4890) connecting them with the monitor,is it going to work?


a c 172 U Graphics card
November 25, 2009 3:54:36 PM

jedimasterben said:
Left the 8800 in there and fired up Mirror's Edge after several successful runs of Vantage. The opening parts went fine, but as soon as the glass started breaking on the 3rd level, my framerate dropped to around 9 or so, showing that PhysX wasn't being accelerated. Again, this was on 178.13 drivers. I tried installing 186.08 again, but it was a no go.

I just downloaded 185.66, which is the oldest driver with the CUDA 2.2 dll files with fancy new enhancements and such, so I'm gonna give it a shot.

Don't worry mousemonkey, I'll sway you yet!!


Did you delete the old physx files in mirrors edge since they are out of date in this game while the driver has the files that are up to date.
December 16, 2009 8:55:00 AM

jedimasterben said:
I use Windows 7 64-bit. You'll need either it or XP, as Vista does not allow having multiple different graphics drivers running at the same time. It's just a limitation to how Vista's WDDM (Windows Driver Display Model) works.

I can't find the link currently, so I'll have to do it from memory.


1) Install the ATI card and the drivers (9.6 is the latest, works great for me)

2) Install the nVidia card and install the drivers in Vista compatibility mode since they are written for Vista (use ONLY 181.22, this is the only one I could PhysX to work properly) XP 32-bit XP 64-bit 7 32-bit 7 64-bit

3) Install the latest PhysX runtime

4) Make sure your main monitor is attached to your ATI card, and a secondary monitor (or, if you only have one monitor that has two inputs, eg DVI and VGA, you can attach the card to that other connection)

5) Extend the Windows desktop onto the nVidia card

6) Set that one as the primary monitor.

7) Open up the PhysX control panel, located in your Windows System32 (or SysWOW64 directory if you're 64-bit). The file will be something like PhysXcpl or something like that.

8) Check the "Geforce PhysX" button and hit APPLY, NOT OK!! DON'T CLOSE IT!!

9) Switch the primary monitor/input back to the ATI card

10) Go back to the PhysX control panel and select "No Acceleration" but DON'T HIT APPLY OR OK! Select "Geforce Accleration" again and hit APPLY.

Enjoy PhysX. :) 

Now, to get Mirror's Edge to work, I had to go to the game's directory, then to the binaries (or bin, I can't remember right now, I'm not on my computer) and either rename or delete the PhysXdevice.dll file. Once you do this, the game will default to hardware PhysX and will be playable with full acceleration!

Credit goes to the guys on the other forums (I will post links whenever I get home) to set me in the right direction.


Hello

Do you know if I can use Windows 7 64-bit and the actual Ageia PhysX PCI card?

I want to use Ageia because I read that the Ageia card is 10 frames per second faster than the 8600

and I don't have to re-do steps 5-10 every time

Thanks
December 16, 2009 8:56:35 AM

Oh one last thing
I want to play Batman with my new Radeon 5850
I want to be able to play DX11 games (DiRT 2), and Physx games (Batman) in Windows 7 64-bit with my Radeon 5850

And I want to use the PCI port since I only have one PCI Express

No reason to use two PCI Express video cards when you have ATI :) 
NO SLI CRAP

Thanks a lot
!