Sign in with
Sign up | Sign in
Your question

External hard drive not working

Last response: in Storage
Share
January 8, 2011 8:04:22 PM

Hello, My external hard drive is not working. My computer does not read it. I unhooked to fix my tower and than hooked it back up and the lite on the external hard drive just keeps flashing.
January 9, 2011 2:42:34 AM

Can you tell us what brand of external drive it is, as well as how it's connected (USB, eSATA, firewire)? Most are USB and I have found that these can be tricky. If it is USB, I would keep trying it in different USB ports until you find one that works. Note: If windows says that you must reformat the drive before you can use it, DON'T: Unplug the power cable for a few seconds then plug it back in. That usually resolves the situation.
m
0
l
January 19, 2011 1:06:27 AM

dg27 said:
Can you tell us what brand of external drive it is, as well as how it's connected (USB, eSATA, firewire)? Most are USB and I have found that these can be tricky. If it is USB, I would keep trying it in different USB ports until you find one that works. Note: If windows says that you must reformat the drive before you can use it, DON'T: Unplug the power cable for a few seconds then plug it back in. That usually resolves the situation.


I did that and it worked for a while and than it quit working. I have 4 ports and have tried all of them. It was working fine until I unplugged it to get my computer fixed.
m
0
l
Related resources
January 19, 2011 1:08:15 AM

I forgot to tell u that the external drive is Maxtor.
m
0
l
January 27, 2011 3:22:53 PM

I have several Maxtor externals and a couple of them are pretty iffy in terms of the system recognizing them. Do you have Maxtor Manager installed? This sometimes help in getting them recognized. I'd also try unplugging the drive (assuming it's plugged in) and plugging it into a port with the system shut down When you power up you may see the "New Hardware Found." message. Which OS and version are you using?
m
0
l
January 28, 2011 7:07:44 PM

Hey guys i could really use help. I have a SATA Seagate Baracuda 1TB drive that i use as an external HD. I've been using it for about 2 months now and just all of a sudden stopped working. When i plug in the USB cable there is no responce fromt the computer but the drive does spin when i turn it on. I also tried connecting it to a Desktop PC, running win 7 Directly (Brand new computer, used working SATA Data Cable and known working SATA Power connection from the Power Supply). This allowed me to see the root level of the drive (ie the first set of folders on the drive) but thats it, no manipulation possible. The masseage that show up is ("E:\ is not accesible. The Device is not cennected."). I attempted changing ownership/ permissions and running a check disk from the properties/tools window but same error. After that i tried running a chkdsk from a CLI but it thinks the drive is a RAW partition, however when i look in computer managment it shows it as an NTFS system. ANY HELP PLEASE
m
0
l
January 30, 2011 3:34:14 PM

Jeff_1080: Please start your own thread rather than hijacking trad57's.
m
0
l
!