Sign in with
Sign up | Sign in
Your question

Realtek HD detecting rear speaker as side (5.1)

Last response: in Components
August 19, 2009 7:18:54 AM


Ive just recently switched from vista64 to windows 7 64.

The thing is that im using logitech X-540 5.1 speakers but realtek HD is detecting my "rear" speakers as "side" speakers when I select the 5.1 option. Same thing happened in vista too.

The only way round this to select the 7.1 option and disable the "side" speakers and hence I can use "rear". The sound from the "side" speakers then comes from the ones in the front in the testing.

Now the problem is that when I play games/movies in 5.1 it probably detects my system as a 7.1 and some sound will be missing.

So how can I use the 5.1 option and keep my surround speakers as "rear" and not "side".

Thanks in advance,

P.S. Buying a new soundcard isnt an option for me.
August 19, 2009 8:30:03 AM

Use the dolby digital
August 19, 2009 8:38:39 AM

With the realtech software doesnt it ask you what you plugged in? and then you tell it thats its Rear not Side?
Related resources
August 19, 2009 8:39:12 AM

Are You sure they are plugged in correctly?
August 19, 2009 11:01:15 AM

here are 2 pics to show my problem

June 27, 2011 4:44:56 PM

I'm having the exact same problem too, please advice!
June 27, 2011 5:06:13 PM

Wow its been almost 2 years since I saw this! haha!

Well, technically, 5.1 speaker setyp doesnt have "rear" speakers. It is indeed supposed to be "side". Just make sure you've plugged everything properly.
May 26, 2012 4:52:11 PM

I just made an account to leave you guys an answer (lol); well, here it is:

While your computer is turned on, your Windows account is logged in, and your Realtek Audio Manager is open in the Sound Manager window (the one that shows the Speaker Configuration), unplug the BLACK jack for your 5.1 speakers, then plug it in again. You will see a pop-up asking you what the device is, and this is where you can tell stupid Realtek that your speakers are in fact side speakers and not rear speakers!

I hope this helps!
June 19, 2013 11:33:38 PM

This is how I solved my Realtek HD Audio, center, side and rear speaker problem. Went to Control Panel, clicked Sound, double clicked my Speakers on the Sound popup menu, on Speaker Properties menu , scrolled down to and selected DTS connect option. All speakers are working fine now.