Sign in with
Sign up | Sign in
Your question

One HDD unused?, RAID 0 configuration-Solved

Last response: in Storage
Share
January 12, 2011 5:40:39 PM

My question involves a problem concerning two WD 150Gb HDD's in a RAID 0 configuration.

Pertinent specs.: Custom built machine, Win. XP Pro Version 2002 Sp3 (installed 32 bit), Abit Crosshair MB (Socket AM2), AMD Athlon 64 x2 6000+ Windsor 3.0Ghz cpu, Mushkin DDR2 800 Ram (4Gb), 2 Western Digital 150Gb Raptor HDD’s, 2 GeForce 8600 GT video cards, Rosewell Extreme Series 850 Watt PS.

This is my third RAID 0 installation, all have functioned well without problems with one "small" exception regarding this latest installation. The OS installation was smooth, the computer boots properly, including the appropriate HDD boot postings of a healthy striping, and the machine functions as expected.

Nvidia MediaShield properly shows both HDD's,


and checking the Device Manager for Disk drives shows a Healthy Nvidia Stripe of the proper size.


However, when I right click Local Disk C in My Computer and check Properties I only see information for one of the HDD’s.


Finally, using Disk Manager to look at the HDD's it may provide clues regarding this discrepancy but I do not know how to interpret the information.


It would appear that I am only using one HDD, but I don’t know how that could be the case with a RAID 0 configuration. If someone could please tell me what is happening and how I might correct this discrepancy I would be most grateful.
January 12, 2011 8:10:02 PM

Could it have anything to do with Basic versus Dynamic?
m
0
l
January 13, 2011 6:00:00 PM

Hmmm...did I post this in the wrong section?
m
0
l
Related resources
January 15, 2011 8:39:46 AM

it looks like it is actually done properly but drive C is setup as half of the available space if you right click on the section that says C: with the blue bar above it you should have the option to extend the volume and it would let drive C take up the entire space.
m
0
l
January 15, 2011 2:48:50 PM

Thanks for your reply picspace.

I looked into the solution you suggested but the option to extend the volume is not available in the drop down menu.

If I right click on Disk 0 Basic (to the left of the blue bar section) I get an option in the drop down menu to change the volume from basic to Logical, but I'm not sure that is a step in the right direction especially after I found these statements when checking Help in Computer Management:
"You cannot extend a system volume or boot volume."
"You cannot extend striped volumes, mirrored volumes, or RAID-5 volumes."
I also found this in the same Help section:
"You can extend a simple volume onto additional dynamic disks to create a spanned volume. Spanned volumes cannot be mirrored or striped." ...so it would appear that creating a spanned volume will not work either.

I'm wondering 1) how this happened (obviously it occurred at installation/set up time but I don't have a clue as to what I actually did to cause this), and 2) if anyone could recommend a software program that would extend a striped volume?
m
0
l
January 18, 2011 5:40:52 PM

I am completing this thread with my solution in case someone else needs the fix.

I still don't know how I caused the problem, but I have resolved the issue using the BootIt™ Next Generation program. I am amazed that the software can resize, move, extend, etc. disk partitions and volumes, even on striped arrays. I was able to use the 30 day trial version to delete the MBR 1 Extended Partition and then to resize the MBR 0 Partition to include the Free Space. Awesome!

Needless to say I purchased the product. :D 

If anyone knows what I did to muxxor the installation I'd appreciate the insight. ;) 
m
0
l
!