Sign in with
Sign up | Sign in
Your question

Using samba to access a linux drive from win98

Last response: in Linux/Free BSD
Share
October 18, 2001 12:07:48 AM

i have been trying to install and configure Samba on my RH7.1 system so that i can access the computer from my networked win98 machine. I have configured it as was specified in my Red Hat manual and on the linuxdoc.org howto and i am able to see the computer in my Network Neighborhood, however as soon as i try to open it, it asks me for a password. Not even a username first, so the user/password setup i have prepared isn't being considered. I try all passwords conceivable ranging from blank entry to root password. Incidentally i have already set the Registry key to use unencrypted passwords. Any advice would be greatly appreciated.

also, does there exist a linux telnet hosting program? i tried exploring telnetd, but i didn't have any luck figuring it out.


Zazoo.
October 18, 2001 4:07:37 AM

Have you done "smbpasswd -a <new-user>"?

If so, what does samba put at the end of your /var/log/messages file when your Win98 box tries to connect? It might be useful to have "tail -f /var/log/messages" running during a connection attempt.

Kelledin

"/join #hackerz. See the Web. DoS interesting people."
June 26, 2002 11:49:38 PM

This particular post is old, I know, but maybe you can help me since you have gone through something similar:

I am trying to set up samba now, well my first problem is that I cannot FIND my smb.conf file. I have rpm'd the rpms but they did not create the file, it seems. Is there an intermediary step? I am trying to achieve the same thing as you: browse the Linux box in Network Neighborhood on XP and vice-versa.
Related resources
June 26, 2002 11:57:15 PM

Ok I've read around ALOT on this and it seems that the part that I don't understand is a makefile. Apparently I am supposed to specify the location of smb.conf in the makefile but I don't know what that is.
June 27, 2002 2:43:49 AM

um well you wouldn't need to use makefile and RPM for the same task. if you've already done
rpm -ivh samba*.rpm
it should have created all the files you would need to configure it.
your smb.conf is located in /etc/samba/smb.conf for most installations. I assume you're attempting to install the newest version? 2.4 or 2.2.4 or something? (i'm using 2.2.2)

Zazoo.
June 27, 2002 7:34:38 AM

My smb.conf lives at /etc/smb.conf

If it's not there or /etc/samba/smb.conf, then you are probably missing some samba packages. You'll need samba-common, samba-client, as well as samba itself (all of the samba rpms except the *-dev-* ones).

<i>Do I look like I care?</i>
June 27, 2002 9:01:28 PM

Ah, yes, I found my smb.conf file and after a few tries at uncommenting things (I so totally guessed haha) I can see my Linux share from my windows machines! Ahahaha! Ok this is so cool. But now I want to see my windows machines from my linux box and I don't know how to do that. I don't even know what the linux equivalent of Network Neighborhood is.
June 28, 2002 5:30:53 AM

It sounds like you are looking for smbclient. But under GNOME, the gnomba program is the easiest way to see Windows machines. (I don't know the KDE equivilant).



<i>Do I look like I care?</i>
June 28, 2002 2:13:44 PM

Sounds good...ok so how do I run this gnomba thing? It's not under my "start menu" (forgive the windows expression) and it won't work at the command line.
June 28, 2002 6:34:04 PM

you can also just use the text tool smbclient. this is how:
#smbclient -L //COMPUTER_NAME
to list all shares from one service computer
#smbclient //COMPUTER_NAME/SHARENAME
(if you need to use a password/usename add the -U {username})
to actually ACCESS the shared ressource

Finally, you can also mount a windows shared filesystem into your linux tree as follows:
#smbmount //COMPUTER_NAME/SHARENAME /MOUNTPOINT (-U {username})

hope that helps... :) 



Zazoo.
June 28, 2002 10:22:18 PM

Yes, it does help! Thank you! This is awesome!
July 1, 2002 5:06:45 PM

gnomba works great. Now I want to configure Linux to act as a Windows NT domain. I found this page on the web:

and it had great instructions, but a few things were confusing: this is what I wrote the webmaster:
_____________________________________________________
Help! I was reading your page
http://www-106.ibm.com/developerworks/library/samba-tng...
and it's just great, but I have a few questions:

When I used the command:
smbpasswd -j MSHOME

I got an error:
modify_trust_password: machine IBN is one of our addresses.
Cannot add ourselves.
<date>: change_trust_account_password: failed to change password
for domain MSHOME. Unable to join domain MSHOME.

testparm showed my syntax was ok, I guess, it did not return any
errors anyway. Also, when you put in bold letters a litle bit
further down: "Set permissions on profiles path so any user can
create files in the directory (0777)" - I didn't know what to do
there. I am familiar with the chmod command - is this what you
want me to use and if so, what is the my profiles directory?
_______________________________________________________

I know this is hard to tell without my smb.conf but I can tell you that my hostname (ibn) is in my smbpasswd file twice. Once with a $ and once without.

What do you think? I'm most concerned about the "unable to join domain"...
July 1, 2002 5:21:00 PM

I had a quick look at that page, and it's dated 2000, so things may have changed slightly since then. I think samba has come a ways closer to being a good NT domain citizen.

I'll take a punt and say you've had a look at <A HREF="http://www.samba.org" target="_new">samba.org</A> already, but...

<A HREF="http://us1.samba.org/samba/docs/man/Samba-HOWTO-Collect..." target="_new">Try this.</A>









<i>Do I look like I care?</i>
July 1, 2002 8:54:36 PM

Ok I have gone through that page thoroughly. I still get the same error when trying the -j option on smbpasswd. Two possibilitites I figger:

Either the PDC is not supposed to "join" its own domain, or I do not have my domain right. How do I know what my domain is named? When I am on the Windows machine, what do I type into the domain name box when I am logging in? Also, the samba.org page says that the username & password I type in on the Windows machine need to be the same as a username and password with root privileges on the Linux box? That doesn't seem right...

I have gone through smb.conf a trillion times and everything looks exactly as it does in the examples I've seen....my errors don't match any of the errors on the page, though. They are like "No domain controller was able to validate your password...same old same old..."
July 1, 2002 11:03:08 PM

Ok, I think the problem is a) you should use -l not -j, and b) I don't think the PDC needs to explicitly join its own domain. I think it trusts itself implicitly.

The domain is usually the same as the workgroup name. It should probably also be the same as your lan name. I think you must be misreading the samba page, no way do you need to logon with root account - you sure wouldn't want to give your users your Linux root password!

It says that PDC can't validate password, so at least it's trying... Sounds like you need to get the password part sorted out - hopefully the howto will lead you through it.

FWIW, here's another more concise take on things:
<A HREF="http://www.samba.org/samba/ftp/docs/htmldocs/Samba-PDC-..." target="_new">http://www.samba.org/samba/ftp/docs/htmldocs/Samba-PDC-...;/A>

And a 2-part tutorial:
<A HREF="http://networking.earthweb.com/netos" target="_new">http://networking.earthweb.com/netos&lt;/A>


<i>Do I look like I care?</i>
July 2, 2002 5:03:56 PM

Yep...that did it. First shot, straight off. I need to write the web page guy and tell him that I don't think it works unless you DO use the same name for your workgroup and your domain... Well I guess it goes to show you gotta ask those in the know. Thanks.

Oh and I didn't bother with the -j -L whatever command. I didn't need it I guess, cuz it's just fine! It didn't make sense that I would need it anyway. I was just taking his word for it. Oh well thanks!
!