Sign in with
Sign up | Sign in
Your question

Iomega eGo HD not detected by laptop

Last response: in Storage
Share
January 13, 2011 2:16:32 AM

Hello again, after your help with building a new computer (), I'm back with another question.

As the title suggests, I bought an Iomega eGo USB 3.0 external hard drive to transfer files between my laptop and the aforementioned new computer, among other things. The problem is that the hard drive is not detected on my laptop. I know that the drive works because I can see it on my new comp; however I neither hear a sound nor see a pop-up when I connect the device to my laptop. The drive itself does light up and I can hear/feel it spinning.

I've tried to look for it in disk management and in "My Computer," as well as looked for driver updates from HP, but to no avail. I should note that the hard drive came with a cable that had both USB 2.0 and 3.0 inputs.

Possibly important laptop specs:

HP Pavilion zv6000
Windows XP Service Pack 3
a b D Laptop
a b G Storage
January 14, 2011 4:10:02 PM

Is the drive portable or desktop version?

If portable, make sure the USB ports are USB 2.0 which provides 5V. If USB 1.1, it needs external power source.

If desktop type, are you using the AC adapter?

Does the drive show up in Disc Management? (Right click My Computer, Manage, Disc Management)
m
0
l
January 14, 2011 4:43:11 PM

It's a portable drive. Actually, I figured out the problem myself: turns out I was just using the wrong USB plug on the Y-cable...durrrrrrrrrrrrrrrrr .
m
0
l
!